summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Boman <mboman@gentoo.org>2004-01-26 08:20:58 +0000
committerMichael Boman <mboman@gentoo.org>2004-01-26 08:20:58 +0000
commit40a983df7cb468eab64b6543911805e2d8649c80 (patch)
tree74d68a7c61b837e731c7bb0af091179f4cd88e0f /net-analyzer
parentChanged dependency on app-text/ghostscript to virtual/ghostscript. Closes bug... (diff)
downloadhistorical-40a983df7cb468eab64b6543911805e2d8649c80.tar.gz
historical-40a983df7cb468eab64b6543911805e2d8649c80.tar.bz2
historical-40a983df7cb468eab64b6543911805e2d8649c80.zip
Changed dependency on app-text/ghostscript to virtual/ghostscript. Closes bug #39422
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/piwi/Manifest4
-rw-r--r--net-analyzer/piwi/files/digest-piwi-0.8.0.20031109-r11
-rw-r--r--net-analyzer/piwi/piwi-0.8.0.20031109-r1.ebuild81
3 files changed, 84 insertions, 2 deletions
diff --git a/net-analyzer/piwi/Manifest b/net-analyzer/piwi/Manifest
index fc28eea8b546..ff33a9b93b54 100644
--- a/net-analyzer/piwi/Manifest
+++ b/net-analyzer/piwi/Manifest
@@ -1,8 +1,8 @@
-MD5 fe5e77715a0355516f8b877aebf881a7 ChangeLog 1375
+MD5 b0587ac75f032755f3f79e5111e71b61 ChangeLog 1586
MD5 c2812f32b8a1ea5383fa49fff7a216d5 metadata.xml 343
MD5 054de99a5ec78c01edc182b2a203812c piwi-0.0.20030717.ebuild 2465
MD5 e305bd0a7add8c4a824f7324d1b6b9dc piwi-0.8.0.20030726.ebuild 2615
-MD5 19facfb202edf3807535ec4b2d5c71d5 piwi-0.8.0.20031109-r1.ebuild 3066
+MD5 79a1c5f01b36bcc9a1164e2e75b9a004 piwi-0.8.0.20031109-r1.ebuild 3069
MD5 a4b4e73150007c9f5d6c72312e28a10f piwi-0.8.0.20031109.ebuild 3067
MD5 4e10c46e4399dbacec468d5433b76fb7 files/digest-piwi-0.0.20030717 70
MD5 a9b9a178c6b87eaa2badd137c8852c20 files/digest-piwi-0.8.0.20030726 72
diff --git a/net-analyzer/piwi/files/digest-piwi-0.8.0.20031109-r1 b/net-analyzer/piwi/files/digest-piwi-0.8.0.20031109-r1
new file mode 100644
index 000000000000..9cf32c317a09
--- /dev/null
+++ b/net-analyzer/piwi/files/digest-piwi-0.8.0.20031109-r1
@@ -0,0 +1 @@
+MD5 61f78ced1975e580ad32ae400ac188ad piwi_v0.8.0.20031109.tar.gz 251843
diff --git a/net-analyzer/piwi/piwi-0.8.0.20031109-r1.ebuild b/net-analyzer/piwi/piwi-0.8.0.20031109-r1.ebuild
new file mode 100644
index 000000000000..7cabeb8e719a
--- /dev/null
+++ b/net-analyzer/piwi/piwi-0.8.0.20031109-r1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/piwi/piwi-0.8.0.20031109-r1.ebuild,v 1.1 2004/01/26 08:20:27 mboman Exp $
+
+DESCRIPTION="(Prelude|Perl) IDS Web Interface"
+HOMEPAGE="http://www.prelude-ids.org"
+
+# [LeRoutier] son, i'll keep this versionning scheme : x.y.z.t (x.y to
+# match the major of prelude, z is piwi
+#SRC_URI="http://www.leroutier.net/Projects/PreludeIDS/${PN}_v${PV}.tar.gz"
+#SRC_URI="http://dev.gentoo.org/~mboman/distfiles/${PN}_v${PV}.tar.gz"
+SRC_URI="mirror://gentoo/${PN}_v${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="mysql postgres gd"
+DEPEND=""
+RDEPEND="
+ dev-lang/perl
+ dev-perl/DBI
+ dev-perl/Date-Calc
+ virtual/ghostscript
+ dev-perl/Geo-IP
+ postgresql? ( dev-perl/DBD-Pg )
+ mysql? ( dev-perl/DBD-mysql )
+ gd? ( dev-perl/GDGraph )
+"
+
+S=${WORKDIR}/
+
+src_install() {
+ into /var/www/localhost/htdocs/piwi || die
+ into /etc/piwi || die
+
+ # "install" the files into the destination
+ cp -aR ${S}/* ${D}/var/www/localhost/htdocs/piwi/ || die
+
+ # Fix permissions
+ # Opt not to use the ebuild functions fowners() and fperms()
+ # as they doesn't seem to work reqursively.
+ chown -R root:apache ${D}/var/www/localhost/htdocs/piwi/* || die
+ chown -R apache:apache ${D}/var/www/localhost/htdocs/piwi/generated || die
+ chmod -R o-rwx ${D}/var/www/localhost/htdocs/piwi/* || die
+
+ # Move files around and create symlinks to make sure configuration files
+ # are not being overwritten when you do upgrades...
+ mv ${D}/var/www/localhost/htdocs/piwi/generated/Filters ${D}/etc/piwi/Filters || die
+ dosym /etc/piwi/Filters /var/www/localhost/htdocs/piwi/generated/Filters
+
+ mv ${D}/var/www/localhost/htdocs/piwi/Profiles ${D}/etc/piwi/Profiles || die
+ dosym /etc/piwi/Profiles /var/www/localhost/htdocs/piwi/Profiles
+
+ # default config.pl is looking for ghostscript in /usr/local/... that's not where
+ # Gentoo has it.. So we do some sed magic to fix it..
+ cat ${D}/var/www/localhost/htdocs/piwi/Functions/config.pl | sed s:/usr/local/bin/gs:/usr/bin/gs: > ${D}/etc/piwi/config.pl || die
+ rm ${D}/var/www/localhost/htdocs/piwi/Functions/config.pl
+ dosym /etc/piwi/config.pl /var/www/localhost/htdocs/piwi/Functions/config.pl
+
+ # Install configuration file for apache
+ insinto /etc/piwi
+ doins ${FILESDIR}/piwi-apache.conf
+}
+
+pkg_postinst() {
+ einfo ""
+ einfo "To have Apache run PIWI, please do the following:"
+ einfo "1) Include the /etc/piwi/piwi-apache.conf in your apache configuration"
+ einfo "2) Edit /etc/conf.d/apache or /etc/conf.d/apache2 and add \"-D PIWI\""
+ einfo "3) Edit /etc/piwi/config.pl to reflect your settings"
+ ewarn ""
+ ewarn "NOTE: If you do not perform these steps PIWI will _not_ work."
+ ewarn " You have been warned. Any bugs against this will be either:"
+ ewarn ""
+ ewarn " - directed to /dev/null"
+ ewarn " - resolved with a RTFM comment"
+ ewarn ""
+ ewarn "Consider yourself warned"
+ # Make sure that the user pay attention
+ echo -ne "\a"; sleep 0.25 ; echo -ne "\a"; sleep 0.25
+}