summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2004-01-22 08:40:16 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2004-01-22 08:40:16 +0000
commit0729e5b23cc427c30443af29263345d996e8efba (patch)
tree76fdc8bdaa314ff0512b45ab54f3a95f0e42ff0b /net-analyzer
parentadd in latest release, which now works (diff)
downloadhistorical-0729e5b23cc427c30443af29263345d996e8efba.tar.gz
historical-0729e5b23cc427c30443af29263345d996e8efba.tar.bz2
historical-0729e5b23cc427c30443af29263345d996e8efba.zip
initial ebuild by Christophe Radovcic <christophe.radovcic@laposte.net>, heavily modified by robbat2@gentoo.org. bug #28541.
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/nam/ChangeLog11
-rw-r--r--net-analyzer/nam/Manifest3
-rw-r--r--net-analyzer/nam/files/digest-nam-1.101
-rw-r--r--net-analyzer/nam/nam-1.10.ebuild63
4 files changed, 78 insertions, 0 deletions
diff --git a/net-analyzer/nam/ChangeLog b/net-analyzer/nam/ChangeLog
new file mode 100644
index 000000000000..f0945bd91cbc
--- /dev/null
+++ b/net-analyzer/nam/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for net-analyzer/nam
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nam/ChangeLog,v 1.1 2004/01/22 08:40:16 robbat2 Exp $
+
+*nam-1.10 (22 Jan 2004)
+
+ 22 Jan 2004; Robin H. Johnson <robbat2@gentoo.org> nam-1.10.ebuild,
+ files/nam-1.9-correct_ettk.patch, files/nam-1.9-fixcasts.patch:
+ initial ebuild by Christophe Radovcic <christophe.radovcic@laposte.net>,
+ heavily modified by robbat2@gentoo.org. bug #28541.
+
diff --git a/net-analyzer/nam/Manifest b/net-analyzer/nam/Manifest
new file mode 100644
index 000000000000..1925ea732208
--- /dev/null
+++ b/net-analyzer/nam/Manifest
@@ -0,0 +1,3 @@
+MD5 491840916c0f40d08f4404f9f97b9bb9 ChangeLog 505
+MD5 af041b9f9e3b5517c7413249eee8e9ea nam-1.10.ebuild 1657
+MD5 343bf4790e73307088d986e95861bb34 files/digest-nam-1.10 65
diff --git a/net-analyzer/nam/files/digest-nam-1.10 b/net-analyzer/nam/files/digest-nam-1.10
new file mode 100644
index 000000000000..4fb2ac63d0f8
--- /dev/null
+++ b/net-analyzer/nam/files/digest-nam-1.10
@@ -0,0 +1 @@
+MD5 35efe4a43f1cc3dd03fb744c5603fc58 nam-src-1.10.tar.gz 4324890
diff --git a/net-analyzer/nam/nam-1.10.ebuild b/net-analyzer/nam/nam-1.10.ebuild
new file mode 100644
index 000000000000..719e06ccc25b
--- /dev/null
+++ b/net-analyzer/nam/nam-1.10.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nam/nam-1.10.ebuild,v 1.1 2004/01/22 08:40:16 robbat2 Exp $
+
+DESCRIPTION="Network Simulator GUI for NS"
+HOMEPAGE="http://www.isi.edu/nsnam/${PN}/"
+SRC_URI="http://www.isi.edu/nsnam/dist/${PN}-src-${PV}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+need_tclver="8.4.4"
+valid_tclver="${need_tclver}"
+mytclver=""
+DEPEND="virtual/x11
+ >=dev-lang/tcl-${need_tclver}
+ >=dev-lang/tk-${need_tclver}
+ >=dev-tcltk/otcl-1.0.8a
+ >=dev-tcltk/tclcl-1.0.13b
+ dev-tcltk/tcl-debug"
+RDEPEND=">=net-analyzer/ns-2.27
+ ${DEPEND}"
+
+S=${WORKDIR}/${P}
+
+findtclver() {
+ # input should always be in INCREASING order
+ local ACCEPTVER="8.3 8.4"
+ [ -n "$*" ] && ACCEPTVER="$*"
+ for i in ${ACCEPTVER}; do
+ use debug && einfo "Testing TCL ${i}"
+ # we support being more specific
+ [ "$(#i)" = "3" ] && i="${i}*"
+ has_version ">=dev-lang/tcl-${i}" && mytclver=${i}
+ done
+ use debug && einfo "Using TCL ${mytclver}"
+ if [ -z "${mytclver}" ]; then
+ die "Unable to find a suitable version of TCL"
+ fi
+}
+
+src_compile() {
+ local myconf
+ findtclver ${valid_tclver}
+ myconf="${myconf} --with-tcl-ver=${mytclver} --with-tk-ver=${mytclver}"
+
+ econf ${myconf} \
+ --mandir=/usr/share/man \
+ --enable-stl \
+ --enable-release \
+ || die "./configure failed"
+ emake || die
+}
+
+src_install() {
+ dodir /usr/bin
+ make DESTDIR=${D} install || die
+ dohtml CHANGES.html TODO.html
+ dodoc FILES VERSION INSTALL.WIN32 README
+ cp -ra ex ${D}/usr/share/doc/${PF}/examples
+ cp -ra iecdemos edu ${D}/usr/share/doc/${PF}
+ doman nam.1
+}