summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChuck Brewer <killian@gentoo.org>2003-04-30 11:25:02 +0000
committerChuck Brewer <killian@gentoo.org>2003-04-30 11:25:02 +0000
commit011939e75906a51d9a12d0d0d062e94c01f4a5ef (patch)
tree764841cc60ecc8e7d7aaf2b46144522f545607c8 /net-analyzer
parentNew version, mark 0.96.0 x86 and cleanup (diff)
downloadhistorical-011939e75906a51d9a12d0d0d062e94c01f4a5ef.tar.gz
historical-011939e75906a51d9a12d0d0d062e94c01f4a5ef.tar.bz2
historical-011939e75906a51d9a12d0d0d062e94c01f4a5ef.zip
new pkg
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/slurm/ChangeLog15
-rw-r--r--net-analyzer/slurm/files/digest-slurm-0.2.21
-rw-r--r--net-analyzer/slurm/files/slurm-0.2.2-altcolors-gentoo.patch18
-rw-r--r--net-analyzer/slurm/files/slurm-0.2.2-fix-gentoo.patch59
-rw-r--r--net-analyzer/slurm/slurm-0.2.2.ebuild31
5 files changed, 124 insertions, 0 deletions
diff --git a/net-analyzer/slurm/ChangeLog b/net-analyzer/slurm/ChangeLog
new file mode 100644
index 000000000000..97ee78e4ef3f
--- /dev/null
+++ b/net-analyzer/slurm/ChangeLog
@@ -0,0 +1,15 @@
+# ChangeLog for net-analyzer/slurm
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/slurm/ChangeLog,v 1.1 2003/04/30 11:25:02 killian Exp $
+
+*slurm-0.2.2 (30 Apr 2003)
+
+ 30 Apr 2003;Chuck Brewer <killian@gentoo.org> slurm-0.2.2.ebuild,digest
+ and files/*:
+ Credit goes to Jyrki Muukkonen <jyrki@kruu.org>. Initial import. His
+ description follows (trimmed somewhat)-
+ Includes two patches. One for some typos and color usage bugs and another
+ for alternative color set (red and white, instead of the rather ugly default
+ colors). It can be used with USE="altcolors". Note that I made this patch
+ just for fitting slurm to my personal desktop. Nevertheless, wanted to
+ include it. Maybe in future slurm will support external themes...
diff --git a/net-analyzer/slurm/files/digest-slurm-0.2.2 b/net-analyzer/slurm/files/digest-slurm-0.2.2
new file mode 100644
index 000000000000..c6545f05233c
--- /dev/null
+++ b/net-analyzer/slurm/files/digest-slurm-0.2.2
@@ -0,0 +1 @@
+MD5 aad89f043045e0f3bf330ea8da5b7741 slurm-0.2.2.tar.gz 52665
diff --git a/net-analyzer/slurm/files/slurm-0.2.2-altcolors-gentoo.patch b/net-analyzer/slurm/files/slurm-0.2.2-altcolors-gentoo.patch
new file mode 100644
index 000000000000..df9cd7a58404
--- /dev/null
+++ b/net-analyzer/slurm/files/slurm-0.2.2-altcolors-gentoo.patch
@@ -0,0 +1,18 @@
+diff -ru slurm-0.2.2/slurm.c slurm-0.2.2-hack/slurm.c
+--- slurm-0.2.2/slurm.c 2003-04-02 00:46:36.000000000 +0300
++++ slurm-0.2.2-hack/slurm.c 2003-04-26 11:18:23.000000000 +0300
+@@ -1410,11 +1410,11 @@
+ ifdata.if_amount = 0;
+
+ sprintf(data_type, "mbytes");
+- colors.ingoing[0] = 2; colors.ingoing[1] = 1;
+- colors.outgoing[0] = 3; colors.outgoing[1] = 1;
++ colors.ingoing[0] = 7; colors.ingoing[1] = 1;
++ colors.outgoing[0] = -1; colors.outgoing[1] = 0;
+ colors.intersection[0] = 2; colors.intersection[1] = 1;
+ colors.background = 0;
+- colors.data[0] = 6; colors.data[1] = 1;
++ colors.data[0] = 1; colors.data[1] = 1;
+ colors.border[0] = 7; colors.border[1] = 1;
+ colors.labels[0] = 7; colors.labels[1] = 1;
+ colors.power_led[0] = 2; colors.power_led[1] = 1;
diff --git a/net-analyzer/slurm/files/slurm-0.2.2-fix-gentoo.patch b/net-analyzer/slurm/files/slurm-0.2.2-fix-gentoo.patch
new file mode 100644
index 000000000000..5cfada55797f
--- /dev/null
+++ b/net-analyzer/slurm/files/slurm-0.2.2-fix-gentoo.patch
@@ -0,0 +1,59 @@
+diff -ru slurm-0.2.2/slurm.c slurm-0.2.2-hack/slurm.c
+--- slurm-0.2.2/slurm.c 2003-04-02 00:46:36.000000000 +0300
++++ slurm-0.2.2-hack/slurm.c 2003-04-26 11:18:23.000000000 +0300
+@@ -682,7 +682,7 @@
+ /* TX graph */
+ if (tx_graph[x][y] == 1)
+ {
+- chcolor(COLOR_YELLOW, colors.ingoing[1]);
++ chcolor(colors.outgoing[0], colors.outgoing[1]);
+ mvprintw(10+y, x+1, "x");
+ }
+ else
+@@ -988,7 +988,7 @@
+ /* TX graph */
+ if (tx_graph[x][y] == 1)
+ {
+- chcolor(COLOR_YELLOW, colors.ingoing[1]);
++ chcolor(colors.outgoing[0], colors.outgoing[1]);
+ mvprintw(6+y, x+1, "x");
+ }
+ else
+@@ -1303,28 +1303,28 @@
+ if (displaymode != MODE_LARGE)
+ {
+ mvprintw(20, 9, "Received Packets:");
+- mvprintw(22, 6, "Errors on Receiving:");
+- mvprintw(20, 45,"Transmited Packets:");
++ mvprintw(22, 16, "RX Errors:");
++ mvprintw(20, 44, "Transmitted Packets:");
+ switch(data_type[0])
+ {
+ case 'b' :
+- mvprintw(21,11, "Bytes Received:");
+- mvprintw(21,47, "Bytes Transmited:");
++ mvprintw(21, 11, "Bytes Received:");
++ mvprintw(21, 46, "Bytes Transmitted:");
+ break;
+ case 'k' :
+- mvprintw(21,10, "KBytes Received:");
+- mvprintw(21,46, "KBytes Transmited:");
++ mvprintw(21, 10, "KBytes Received:");
++ mvprintw(21, 45, "KBytes Transmitted:");
+ break;
+ case 'm' :
+- mvprintw(21,10, "MBytes Received:");
+- mvprintw(21,46, "MBytes Transmited:");
++ mvprintw(21, 10, "MBytes Received:");
++ mvprintw(21, 45, "MBytes Transmitted:");
+ break;
+ }
+ }
+
+ if (displaymode == MODE_SPLIT)
+ {
+- mvprintw(22, 41, "Errors on Transmission:");
++ mvprintw(22, 54, "TX Errors:");
+ mvprintw(14, 37, "RX");
+ mvprintw(14, 41, "TX");
+ mvprintw(17, 9, "Current RX Speed:");
diff --git a/net-analyzer/slurm/slurm-0.2.2.ebuild b/net-analyzer/slurm/slurm-0.2.2.ebuild
new file mode 100644
index 000000000000..d642ba8dd701
--- /dev/null
+++ b/net-analyzer/slurm/slurm-0.2.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/slurm/slurm-0.2.2.ebuild,v 1.1 2003/04/30 11:25:02 killian Exp $
+
+DESCRIPTION="Realtime network interface monitor based on FreeBSD's pppstatus"
+HOMEPAGE="http://www.raisdorf.net/slurm/"
+SRC_URI="http://www.raisdorf.net/files/code/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND=">=sys-libs/ncurses"
+
+# internal use flag for alternative color set ;>
+IUSE="altcolors"
+
+src_compile() {
+ # fixes some typos and color usage
+ epatch "${FILESDIR}/slurm-0.2.2-fix-gentoo.patch"
+ # apply alternative color set (red & white)
+ use altcolors && epatch "${FILESDIR}/slurm-0.2.2-altcolors-gentoo.patch"
+
+ ./configure || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ dobin slurm
+ doman slurm.1
+ dodoc Changelog COPYRIGHT KEYS README THANKS TODO
+}