summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Boman <mboman@gentoo.org>2004-03-22 12:20:59 +0000
committerMichael Boman <mboman@gentoo.org>2004-03-22 12:20:59 +0000
commitf9af9764a07469e7a54bc821c328dbbf34440d0f (patch)
tree228f7350cd2f1ca36a0471be2c36312e83b6b362 /net-analyzer/snorticus
parentfix fam message (diff)
downloadhistorical-f9af9764a07469e7a54bc821c328dbbf34440d0f.tar.gz
historical-f9af9764a07469e7a54bc821c328dbbf34440d0f.tar.bz2
historical-f9af9764a07469e7a54bc821c328dbbf34440d0f.zip
QA: DEPEND/RDEPEND (see bug 45343). Noticed that it used plain patch instead of epatch, which also got fixed. The installed shell scripts depends on csh/tcsh which was not listed as a dependency, and the search path for the interpreter was wrong as well. All these issues fixed.
Diffstat (limited to 'net-analyzer/snorticus')
-rw-r--r--net-analyzer/snorticus/ChangeLog10
-rw-r--r--net-analyzer/snorticus/Manifest5
-rw-r--r--net-analyzer/snorticus/metadata.xml10
-rw-r--r--net-analyzer/snorticus/snorticus-1.0.4.ebuild23
4 files changed, 33 insertions, 15 deletions
diff --git a/net-analyzer/snorticus/ChangeLog b/net-analyzer/snorticus/ChangeLog
index d865d42ce267..88d1c3ff210a 100644
--- a/net-analyzer/snorticus/ChangeLog
+++ b/net-analyzer/snorticus/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/snorticus
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/snorticus/ChangeLog,v 1.1 2003/02/13 10:19:02 aliz Exp $
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/snorticus/ChangeLog,v 1.2 2004/03/22 12:20:59 mboman Exp $
+
+ 22 Mar 2004; Michael Boman <mboman@gentoo.org> snorticus-1.0.4.ebuild:
+ QA: DEPEND/RDEPEND (see bug 45343). Noticed that it used plain patch instead
+ of epatch, which also got fixed. The installed shell scripts depends on
+ csh/tcsh which was not listed as a dependency, and the search path for the
+ interpreter was wrong as well. All these issues fixed.
*snorticus-1.0.4 (13 Feb 2003)
diff --git a/net-analyzer/snorticus/Manifest b/net-analyzer/snorticus/Manifest
index 3253836e3892..11e4d917b1bc 100644
--- a/net-analyzer/snorticus/Manifest
+++ b/net-analyzer/snorticus/Manifest
@@ -1,4 +1,5 @@
-MD5 ff5151d34c50f0f39dbf83496ab232ff ChangeLog 383
-MD5 8b7712d0ce11ed45cf691094cf2bb34c snorticus-1.0.4.ebuild 1473
+MD5 e10f636b5bed8a508920ee95b223cf3f ChangeLog 746
+MD5 f021401a2e148a96596469c750f9539a snorticus-1.0.4.ebuild 1552
+MD5 adc312ef1f45d8b94944fbae7430611d metadata.xml 401
MD5 58b5bcacaeeb295cc8f0cee6beba68ad files/digest-snorticus-1.0.4 66
MD5 eda912eea5751601bc4e8be74f1ac5b0 files/snorticus-1.0.4-gentoo.patch 2675
diff --git a/net-analyzer/snorticus/metadata.xml b/net-analyzer/snorticus/metadata.xml
new file mode 100644
index 000000000000..84307dec76ac
--- /dev/null
+++ b/net-analyzer/snorticus/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>netmon</herd>
+ <maintainer>
+ <email>mboman@gentoo.org</email>
+ <description>Interim Maintainer</description>
+ </maintainer>
+<longdescription>Snorticus is a collection of shell scripts designed to allow easy managment of Snort sensors.</longdescription>
+</pkgmetadata>
diff --git a/net-analyzer/snorticus/snorticus-1.0.4.ebuild b/net-analyzer/snorticus/snorticus-1.0.4.ebuild
index b7d67e2f2f38..563425476f42 100644
--- a/net-analyzer/snorticus/snorticus-1.0.4.ebuild
+++ b/net-analyzer/snorticus/snorticus-1.0.4.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/snorticus/snorticus-1.0.4.ebuild,v 1.3 2003/09/05 23:40:10 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/snorticus/snorticus-1.0.4.ebuild,v 1.4 2004/03/22 12:20:59 mboman Exp $
-DESCRIPTION="Snorticus is a collection of shell scripts designed to allow easy
-managment of Snort sensors."
+inherit eutils
+DESCRIPTION="Snorticus is a collection of shell scripts designed to allow easy managment of Snort sensors."
HOMEPAGE="http://snorticus.baysoft.net/"
SRC_URI="http://snorticus.baysoft.net/snorticus/${P}.tar.gz"
LICENSE="GPL-2"
@@ -12,23 +12,24 @@ SLOT="0"
KEYWORDS="x86"
IUSE=""
-RDEPEND="virtual/glibc
+DEPEND=""
+RDEPEND="
+ app-shells/tcsh
net-analyzer/snort
net-analyzer/snortsnarf
sys-apps/sh-utils
net-misc/openssh"
-DEPEND="${RDEPEND}"
-
src_unpack() {
unpack ${A}
cd ${S}
- patch -p0 < ${FILESDIR}/${P}-gentoo.patch || die
-}
+ epatch ${FILESDIR}/${P}-gentoo.patch
-src_compile() {
- return 0
+ for file in hourly_wrapup.sh push_rules.sh retrieve_wrapup.sh
+ do
+ sed -i s:/usr/bin/csh:/bin/csh: $file
+ done
}
src_install () {