summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-08-21 05:17:06 +0000
committerMike Frysinger <vapier@gentoo.org>2003-08-21 05:17:06 +0000
commite87c6ed46e5e3d5be3cad7f8375823adb438a8fe (patch)
tree56dcc9fa08dec73b424a171955dc61b08a106ecd /net-analyzer/snort
parentppc #27012 (diff)
downloadhistorical-e87c6ed46e5e3d5be3cad7f8375823adb438a8fe.tar.gz
historical-e87c6ed46e5e3d5be3cad7f8375823adb438a8fe.tar.bz2
historical-e87c6ed46e5e3d5be3cad7f8375823adb438a8fe.zip
use enewuser/enewgroup and add patch for SLOT-ed libnet
Diffstat (limited to 'net-analyzer/snort')
-rw-r--r--net-analyzer/snort/ChangeLog20
-rw-r--r--net-analyzer/snort/files/1.9.1-libnet-1.0.patch57
-rw-r--r--net-analyzer/snort/files/2.0.1-libnet-1.0.patch57
-rw-r--r--net-analyzer/snort/files/digest-snort-1.9.1-r31
-rw-r--r--net-analyzer/snort/files/digest-snort-2.0.1-r12
-rw-r--r--net-analyzer/snort/snort-1.9.1-r3.ebuild88
-rw-r--r--net-analyzer/snort/snort-2.0.1-r1.ebuild100
7 files changed, 322 insertions, 3 deletions
diff --git a/net-analyzer/snort/ChangeLog b/net-analyzer/snort/ChangeLog
index f7170ae767ff..a48d26d55c9f 100644
--- a/net-analyzer/snort/ChangeLog
+++ b/net-analyzer/snort/ChangeLog
@@ -1,14 +1,28 @@
# ChangeLog for net-analyzer/snort
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/snort/ChangeLog,v 1.18 2003/08/11 05:58:07 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/snort/ChangeLog,v 1.19 2003/08/21 05:17:06 vapier Exp $
+
+*snort-2.0.1-r1 (21 Aug 2003)
+
+ 21 Aug 2003; Mike Frysinger <vapier@gentoo.org> :
+ Patch to compile against SLOT-ed libnet-1.0.x #17772.
+ Also fix user adding to enewuser/enewgroup and switch use
+ flags over to `use_enable`.
+
+*snort-1.9.1-r3 (21 Aug 2003)
+
+ 21 Aug 2003; Mike Frysinger <vapier@gentoo.org> :
+ Patch to compile against SLOT-ed libnet-1.0.x #17772.
+ Also fix user adding to enewuser/enewgroup and switch use
+ flags over to `use_enable`.
+
+*snort-2.0.1 (09 Aug 2003)
11 Aug 2003; <solar@gentoo.org> snort-2.0.1.ebuild,
files/snort-2.0.1+prelude.patch:
Snort 2.0.x does not support snmp bug #26310, Moved large prelude patch to
mirror://
-*snort-2.0.1 (09 Aug 2003)
-
09 Aug 2003; <mboman@gentoo.org> snort-2.0.1.ebuild,
files/snort-2.0.1+prelude.patch:
Added libprelude support to snort. Closes bug 19672.
diff --git a/net-analyzer/snort/files/1.9.1-libnet-1.0.patch b/net-analyzer/snort/files/1.9.1-libnet-1.0.patch
new file mode 100644
index 000000000000..c547388a74f4
--- /dev/null
+++ b/net-analyzer/snort/files/1.9.1-libnet-1.0.patch
@@ -0,0 +1,57 @@
+--- configure.orig 2003-08-19 01:15:46.481148448 -0400
++++ configure 2003-08-19 01:15:46.645123520 -0400
+@@ -3756 +3756 @@
+- CPPFLAGS="${CPPFLAGS} -DENABLE_RESPONSE `libnet-config --defines --cflags`" LDFLAGS="${LDFLAGS} `libnet-config --libs`"
++ CPPFLAGS="${CPPFLAGS} -DENABLE_RESPONSE `libnet-1.0-config --defines --cflags`" LDFLAGS="${LDFLAGS} `libnet-1.0-config --libs`"
+@@ -3764,2 +3764,2 @@
+- if test -z `libnet-config --cflags | grep "\-I"`; then
+- echo "configure: warning: libnet-config --cflags is broken on your system. If you" 1>&2
++ if test -z `libnet-1.0-config --cflags | grep "\-I"`; then
++ echo "configure: warning: libnet-1.0-config --cflags is broken on your system. If you" 1>&2
+@@ -3770,2 +3770,2 @@
+- if eval "libnet-config --libs | grep -C1 -v \"\-L\" >/dev/null"; then
+- echo "configure: warning: libnet-config --libs is broken on your system. If you" 1>&2
++ if eval "libnet-1.0-config --libs | grep -C1 -v \"\-L\" >/dev/null"; then
++ echo "configure: warning: libnet-1.0-config --libs is broken on your system. If you" 1>&2
+@@ -3777 +3777 @@
+- for ac_hdr in libnet.h
++ for ac_hdr in libnet-1.0.h
+@@ -3829 +3829 @@
+- if test -z `libnet-config --cflags | grep "\-I"`; then
++ if test -z `libnet-1.0-config --cflags | grep "\-I"`; then
+@@ -3836 +3836 @@
+- libnet_dir=`libnet-config --cflags | cut -dI -f2`
++ libnet_dir=`libnet-1.0-config --cflags | cut -dI -f2`
+@@ -3841 +3841 @@
+- if test -r $i/libnet.h; then
++ if test -r $i/libnet-1.0.h; then
+@@ -3847 +3847 @@
+- if eval "grep LIBNET_VERSION $LIBNET_INC_DIR/libnet.h | grep -v 1.0.2a >/dev/null"; then
++ if eval "grep LIBNET_VERSION $LIBNET_INC_DIR/libnet-1.0.h | grep -v 1.0.2a >/dev/null"; then
+@@ -3852 +3852 @@
+- echo " ERROR: unable to find" "libnet 1.0.2a (libnet.h)"
++ echo " ERROR: unable to find" "libnet 1.0.2a (libnet-1.0.h)"
+@@ -3873 +3873 @@
+- echo " ERROR: unable to find" "libnet 1.0.2a (libnet.h)"
++ echo " ERROR: unable to find" "libnet 1.0.2a (libnet-1.0.h)"
+@@ -3885,2 +3885,2 @@
+- echo $ac_n "checking for libnet_build_ip in -lnet""... $ac_c" 1>&6
+-echo "configure:3887: checking for libnet_build_ip in -lnet" >&5
++ echo $ac_n "checking for libnet_build_ip in -lnet-1.0 "... $ac_c" 1>&6
++echo "configure:3887: checking for libnet_build_ip in -lnet-1.0 >&5
+@@ -3892 +3892 @@
+-LIBS="-lnet $LIBS"
++LIBS="-lnet-1.0 $LIBS"
+@@ -3926 +3926 @@
+- LIBS="-lnet $LIBS"
++ LIBS="-lnet-1.0 $LIBS"
+--- src/detection-plugins/sp_react.c.orig 2003-08-19 01:15:46.577133856 -0400
++++ src/detection-plugins/sp_react.c 2003-08-19 01:15:46.652122456 -0400
+@@ -56 +56 @@
+-#include <libnet.h>
++#include <libnet-1.0.h>
+--- src/detection-plugins/sp_respond.c.orig 2003-08-19 01:15:46.582133096 -0400
++++ src/detection-plugins/sp_respond.c 2003-08-19 01:15:46.657121696 -0400
+@@ -33 +33 @@
+-#include <libnet.h>
++#include <libnet-1.0.h>
diff --git a/net-analyzer/snort/files/2.0.1-libnet-1.0.patch b/net-analyzer/snort/files/2.0.1-libnet-1.0.patch
new file mode 100644
index 000000000000..c26fa717ba1c
--- /dev/null
+++ b/net-analyzer/snort/files/2.0.1-libnet-1.0.patch
@@ -0,0 +1,57 @@
+--- configure.orig 2003-08-19 01:19:05.948824752 -0400
++++ configure 2003-08-19 01:19:06.212784624 -0400
+@@ -6376 +6376 @@
+- CPPFLAGS="${CPPFLAGS} -DENABLE_RESPONSE `libnet-config --defines --cflags`" LDFLAGS="${LDFLAGS} `libnet-config --libs`"
++ CPPFLAGS="${CPPFLAGS} -DENABLE_RESPONSE `libnet-1.0-config --defines --cflags`" LDFLAGS="${LDFLAGS} `libnet-1.0-config --libs`"
+@@ -6382 +6382 @@
+- if test `libnet-config --cflags | wc -c` = "1"; then
++ if test `libnet-1.0-config --cflags | wc -c` = "1"; then
+@@ -6387,3 +6387,3 @@
+- if test `libnet-config --libs | wc -c` = "1"; then
+- { echo "$as_me:$LINENO: WARNING: libnet-config --libs is broken on your system. If you" >&5
+-echo "$as_me: WARNING: libnet-config --libs is broken on your system. If you" >&2;}
++ if test `libnet-1.0-config --libs | wc -c` = "1"; then
++ { echo "$as_me:$LINENO: WARNING: libnet-1.0-config --libs is broken on your system. If you" >&5
++echo "$as_me: WARNING: libnet-1.0-config --libs is broken on your system. If you" >&2;}
+@@ -6395 +6395 @@
+- LIBS="${LIBS} -lnet"
++ LIBS="${LIBS} -lnet-1.0"
+@@ -6400 +6400 @@
+-for ac_header in libnet.h
++for ac_header in libnet-1.0.h
+@@ -6533 +6533 @@
+- libnet_dir=`libnet-config --cflags | cut -dI -f2`
++ libnet_dir=`libnet-1.0-config --cflags | cut -dI -f2`
+@@ -6538 +6538 @@
+- if test -r $i/libnet.h; then
++ if test -r $i/libnet-1.0.h; then
+@@ -6544 +6544 @@
+- if eval "grep LIBNET_VERSION $LIBNET_INC_DIR/libnet.h | grep -v 1.0.2a >/dev/null"; then
++ if eval "grep LIBNET_VERSION $LIBNET_INC_DIR/libnet-1.0.h | grep -v 1.0.2a >/dev/null"; then
+@@ -6555 +6555 @@
+- echo " ERROR: unable to find" "libnet 1.0.2a (libnet.h)"
++ echo " ERROR: unable to find" "libnet 1.0.2a (libnet-1.0.h)"
+@@ -6574 +6574 @@
+- echo " ERROR: unable to find" "libnet 1.0.2a (libnet.h)"
++ echo " ERROR: unable to find" "libnet 1.0.2a (libnet-1.0.h)"
+@@ -6587,2 +6587,2 @@
+-echo "$as_me:$LINENO: checking for libnet_build_ip in -lnet" >&5
+-echo $ECHO_N "checking for libnet_build_ip in -lnet... $ECHO_C" >&6
++echo "$as_me:$LINENO: checking for libnet_build_ip in -lnet-1.0" >&5
++echo $ECHO_N "checking for libnet_build_ip in -lnet-1.0... $ECHO_C" >&6
+@@ -6593 +6593 @@
+-LIBS="-lnet $LIBS"
++LIBS="-lnet-1.0 $LIBS"
+@@ -6647 +6647 @@
+- LIBS="-lnet $LIBS"
++ LIBS="-lnet-1.0 $LIBS"
+--- src/detection-plugins/sp_react.c.orig 2003-08-19 01:19:06.106800736 -0400
++++ src/detection-plugins/sp_react.c 2003-08-19 01:19:06.220783408 -0400
+@@ -56 +56 @@
+-#include <libnet.h>
++#include <libnet-1.0.h>
+--- src/detection-plugins/sp_respond.c.orig 2003-08-19 01:19:06.111799976 -0400
++++ src/detection-plugins/sp_respond.c 2003-08-19 01:19:06.225782648 -0400
+@@ -33 +33 @@
+-#include <libnet.h>
++#include <libnet-1.0.h>
diff --git a/net-analyzer/snort/files/digest-snort-1.9.1-r3 b/net-analyzer/snort/files/digest-snort-1.9.1-r3
new file mode 100644
index 000000000000..33016cb62406
--- /dev/null
+++ b/net-analyzer/snort/files/digest-snort-1.9.1-r3
@@ -0,0 +1 @@
+MD5 50bb526b41f48fb7689bb8342b27e44d snort-1.9.1.tar.gz 146615
diff --git a/net-analyzer/snort/files/digest-snort-2.0.1-r1 b/net-analyzer/snort/files/digest-snort-2.0.1-r1
new file mode 100644
index 000000000000..210682acbfc7
--- /dev/null
+++ b/net-analyzer/snort/files/digest-snort-2.0.1-r1
@@ -0,0 +1,2 @@
+MD5 ab5bdd0cab96fe521d11d2c6d804518f snort-2.0.1.tar.gz 1817646
+MD5 ae55efd9ad3cddaf563a9bdbedae6c4a snort-2.0.1+prelude.patch.gz 94867
diff --git a/net-analyzer/snort/snort-1.9.1-r3.ebuild b/net-analyzer/snort/snort-1.9.1-r3.ebuild
new file mode 100644
index 000000000000..dbc1028bcc2a
--- /dev/null
+++ b/net-analyzer/snort/snort-1.9.1-r3.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/snort/snort-1.9.1-r3.ebuild,v 1.1 2003/08/21 05:17:06 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="Libpcap-based packet sniffer/logger/lightweight IDS"
+HOMEPAGE="http://www.snort.org/"
+SRC_URI="http://www.snort.org/dl/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~alpha"
+IUSE="ssl postgres mysql snmp"
+
+DEPEND="virtual/glibc
+ >=net-libs/libpcap-0.6.2-r1
+ >=net-libs/libnet-1.0.2a-r3
+ <net-libs/libnet-1.1
+ postgres? ( >=dev-db/postgresql-7.2 )
+ mysql? ( >=dev-db/mysql-3.23.26 )
+ ssl? ( >=dev-libs/openssl-0.9.6b )
+ snmp? ( >=net-analyzer/net-snmp-5.0 )"
+RDEPEND="virtual/glibc
+ dev-lang/perl
+ >=net-libs/libpcap-0.6.2-r1
+ postgres? ( >=dev-db/postgresql-7.2 )
+ mysql? ( >=dev-db/mysql-3.23.26 )
+ ssl? ( >=dev-libs/openssl-0.9.6b )"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/${P}-configure.patch
+ epatch ${FILESDIR}/${PV}-libnet-1.0.patch
+
+ # Fixes for alpha, and GLSA 200304-05
+ use alpha && epatch ${FILESDIR}/${P}-alpha-core_vuln.diff
+}
+
+src_compile() {
+ econf \
+ `use_with postgres postgresql` \
+ `use_with mysql` \
+ `use_with ssl openssl` \
+ `use_with snmp` \
+ --without-odbc \
+ --without-oracle \
+ --enable-pthreads \
+ --enable-flexresp \
+ --enable-smbalerts \
+ || die "bad ./configure"
+
+ emake || die "compile problem"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ dodir /var/log/snort
+ touch ${D}/var/log/snort/.keep
+
+ insinto /usr/lib/snort/bin
+ doins contrib/{create_mysql,snortlog,*.pl}
+
+ dodoc COPYING LICENSE doc/*
+ docinto contrib ; dodoc contrib/*
+
+ insinto /etc/snort
+ doins etc/classification.config rules/*.rules
+ newins etc/snort.conf snort.conf.distrib
+
+ exeinto /etc/init.d ; newexe ${FILESDIR}/snort.rc6 snort
+ insinto /etc/conf.d ; newins ${FILESDIR}/snort.confd snort
+}
+
+pkg_postinst() {
+ enewgroup snort
+ enewuser snort -1 /dev/null /var/log/snort snort
+ usermod -d "/var/log/snort" snort || die "usermod problem"
+ usermod -g "snort" snort || die "usermod problem"
+ usermod -s "/dev/null" snort || die "usermod problem"
+ echo "ignore any message about CREATE_HOME above..."
+
+ chown snort.snort ${ROOT}/var/log/snort
+ chmod 0770 ${ROOT}/var/log/snort
+}
diff --git a/net-analyzer/snort/snort-2.0.1-r1.ebuild b/net-analyzer/snort/snort-2.0.1-r1.ebuild
new file mode 100644
index 000000000000..4213e8a5e388
--- /dev/null
+++ b/net-analyzer/snort/snort-2.0.1-r1.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/snort/snort-2.0.1-r1.ebuild,v 1.1 2003/08/21 05:17:06 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="Libpcap-based packet sniffer/logger/lightweight IDS"
+HOMEPAGE="http://www.snort.org/"
+SRC_URI="http://www.snort.org/dl/${P}.tar.gz
+ prelude? ( mirror://gentoo/${P}+prelude.patch.gz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc -alpha"
+IUSE="ssl postgres mysql prelude"
+# snort 2.0.x does not support snmp yet Bug #26310
+# IUSE="${IUSE} snmp"
+
+DEPEND="virtual/glibc
+ >=net-libs/libpcap-0.6.2-r1
+ >=net-libs/libnet-1.0.2a-r3
+ <net-libs/libnet-1.1
+ postgres? ( >=dev-db/postgresql-7.2 )
+ mysql? ( >=dev-db/mysql-3.23.26 )
+ ssl? ( >=dev-libs/openssl-0.9.6b )
+ prelude? ( >=dev-libs/libprelude-0.8 )"
+# snmp? ( >=net-analyzer/net-snmp-5.0 )
+RDEPEND="virtual/glibc
+ dev-lang/perl
+ >=net-libs/libpcap-0.6.2-r1
+ postgres? ( >=dev-db/postgresql-7.2 )
+ mysql? ( >=dev-db/mysql-3.23.26 )
+ ssl? ( >=dev-libs/openssl-0.9.6b )
+ prelude? ( >=dev-libs/libprelude-0.8 )"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ #is this needed in 2.0? -Method
+ #epatch ${FILESDIR}/${P}-configure.patch
+ epatch ${FILESDIR}/${PV}-libnet-1.0.patch
+
+ # Following patch contributed in bug #18258
+ #is this needed in 2.0? -Method
+ #use alpha && epatch ${FILESDIR}/${P}-alpha.patch
+
+ sed "s:var RULE_PATH ../rules:var RULE_PATH /etc/snort:" < etc/snort.conf > etc/snort.conf.distrib
+
+ use prelude && epatch ../${P}+prelude.patch
+}
+
+src_compile() {
+# `use_with snmp` \
+ econf \
+ `use_with postgres postgresql` \
+ `use_with mysql` \
+ `use_with ssl openssl` \
+ `use_with prelude` \
+ --without-odbc \
+ --without-oracle \
+ --enable-pthreads \
+ --enable-flexresp \
+ --enable-smbalerts \
+ || die "bad ./configure"
+
+ emake || die "compile problem"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ dodir /var/log/snort
+ keepdir /var/log/snort/
+
+ insinto /usr/lib/snort/bin
+ doins contrib/{create_mysql,snortlog,*.pl}
+
+ dodoc COPYING LICENSE doc/*
+ docinto contrib ; dodoc contrib/*
+
+ insinto /etc/snort
+ doins etc/reference.config etc/classification.config rules/*.rules etc/*.map
+ doins etc/snort.conf.distrib
+
+ exeinto /etc/init.d ; newexe ${FILESDIR}/snort.rc6 snort
+ insinto /etc/conf.d ; newins ${FILESDIR}/snort.confd snort
+}
+
+pkg_postinst() {
+ enewgroup snort
+ enewuser snort -1 /dev/null /var/log/snort snort
+ usermod -d "/var/log/snort" snort || die "usermod problem"
+ usermod -g "snort" snort || die "usermod problem"
+ usermod -s "/dev/null" snort || die "usermod problem"
+ echo "ignore any message about CREATE_HOME above..."
+
+ chown snort.snort /var/log/snort
+ chmod 0770 /var/log/snort
+}