summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Góes <vanquirius@gentoo.org>2005-05-24 14:52:32 +0000
committerMarcelo Góes <vanquirius@gentoo.org>2005-05-24 14:52:32 +0000
commitbdb7740f55d8c79e9748d4500f242072fe5a22fe (patch)
tree7fad577824772eaddf891fcb0f5e8f103fa76965 /net-analyzer/pmacct
parentMigration (diff)
downloadhistorical-bdb7740f55d8c79e9748d4500f242072fe5a22fe.tar.gz
historical-bdb7740f55d8c79e9748d4500f242072fe5a22fe.tar.bz2
historical-bdb7740f55d8c79e9748d4500f242072fe5a22fe.zip
version bump
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'net-analyzer/pmacct')
-rw-r--r--net-analyzer/pmacct/files/digest-pmacct-0.8.61
-rw-r--r--net-analyzer/pmacct/pmacct-0.8.6.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/net-analyzer/pmacct/files/digest-pmacct-0.8.6 b/net-analyzer/pmacct/files/digest-pmacct-0.8.6
new file mode 100644
index 000000000000..93048815d58c
--- /dev/null
+++ b/net-analyzer/pmacct/files/digest-pmacct-0.8.6
@@ -0,0 +1 @@
+MD5 b725f7b4af335d2f668cb61621a5c2d9 pmacct-0.8.6.tar.gz 244189
diff --git a/net-analyzer/pmacct/pmacct-0.8.6.ebuild b/net-analyzer/pmacct/pmacct-0.8.6.ebuild
new file mode 100644
index 000000000000..c971a429c2c3
--- /dev/null
+++ b/net-analyzer/pmacct/pmacct-0.8.6.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pmacct/pmacct-0.8.6.ebuild,v 1.1 2005/05/24 14:52:32 vanquirius Exp $
+
+MY_P="${P%_*}"
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="A network tool to gather ip traffic informations"
+HOMEPAGE="http://www.ba.cnr.it/~paolo/pmacct/"
+SRC_URI="http://www.ba.cnr.it/~paolo/pmacct/${P/_}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE="ipv6 mmap mysql postgres"
+
+RDEPEND="virtual/libpcap
+ mysql? ( dev-db/mysql )
+ postgres? ( dev-db/postgresql )"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i "s|\(CFLAGS=\).*$|\1\"${CFLAGS}\"|g" configure || die "sed failed"
+}
+
+src_compile() {
+ econf \
+ $(use_enable mysql) \
+ $(use_enable postgres pgsql) \
+ $(use_enable mmap) \
+ $(use_enable ipv6) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc README EXAMPLES KNOWN-BUGS CONFIG-KEYS FAQS ChangeLog docs/SIGNALS \
+ docs/PLUGINS docs/INTERNALS TODO TOOLS || die "dodoc failed"
+
+ for dirname in examples sql; do
+ docinto ${dirname}
+ dodoc ${dirname}/* || die "dodoc ${dirname} failed"
+ done
+
+ newinitd ${FILESDIR}/pmacctd-init.d pmacctd || die "newinitd failed"
+ newconfd ${FILESDIR}/pmacctd-conf.d pmacctd || die "newconfd failed"
+
+ insinto /etc
+ newins ${S}/examples/pmacctd-imt.conf.example pmacctd.conf.example || \
+ die "newins failed"
+}