summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2005-09-16 19:13:11 +0000
committerMichael Januszewski <spock@gentoo.org>2005-09-16 19:13:11 +0000
commitaa2b32e49c91a0209193c83eca1ff0d0bcd70a38 (patch)
tree87da14127b4d5887bf22e9ee97d8394faa607886 /net-analyzer/nmap/nmap-3.93.ebuild
parentUpdated vmware ebuilds to now require users be in the vmware group. Also, ad... (diff)
downloadhistorical-aa2b32e49c91a0209193c83eca1ff0d0bcd70a38.tar.gz
historical-aa2b32e49c91a0209193c83eca1ff0d0bcd70a38.tar.bz2
historical-aa2b32e49c91a0209193c83eca1ff0d0bcd70a38.zip
Version bump.
Package-Manager: portage-1.589-cvs
Diffstat (limited to 'net-analyzer/nmap/nmap-3.93.ebuild')
-rw-r--r--net-analyzer/nmap/nmap-3.93.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-analyzer/nmap/nmap-3.93.ebuild b/net-analyzer/nmap/nmap-3.93.ebuild
new file mode 100644
index 000000000000..06130e04e7d7
--- /dev/null
+++ b/net-analyzer/nmap/nmap-3.93.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/nmap-3.93.ebuild,v 1.1 2005/09/16 19:13:11 spock Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="A utility for network exploration or security auditing"
+HOMEPAGE="http://www.insecure.org/nmap/"
+SRC_URI="http://download.insecure.org/nmap/dist/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc-macos ~ppc64 ~s390 ~sparc ~x86"
+IUSE="gtk ssl"
+
+DEPEND="virtual/libc
+ dev-libs/libpcre
+ gtk? ( =x11-libs/gtk+-1.2* )
+ ssl? ( dev-libs/openssl )"
+
+src_compile() {
+ use ppc-macos && filter-flags -fstrict-aliasing -O2
+ econf \
+ $(use_with gtk nmapfe) \
+ $(use_with ssl openssl) || die
+ emake -j1 || die
+}
+
+src_install() {
+ einstall -j1 nmapdatadir=${D}/usr/share/nmap install || die
+ dodoc CHANGELOG HACKING INSTALL docs/README docs/*.txt
+ dohtml docs/*.html
+}