summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Góes <vanquirius@gentoo.org>2006-01-23 02:49:43 +0000
committerMarcelo Góes <vanquirius@gentoo.org>2006-01-23 02:49:43 +0000
commit9b6c290e5257f9a1ca3638191ef5a4f4362e402c (patch)
tree334c6f4652542f78d569b46c1fa2cc7fe60152b7 /net-analyzer/netio
parentDigest corruption? (diff)
downloadhistorical-9b6c290e5257f9a1ca3638191ef5a4f4362e402c.tar.gz
historical-9b6c290e5257f9a1ca3638191ef5a4f4362e402c.tar.bz2
historical-9b6c290e5257f9a1ca3638191ef5a4f4362e402c.zip
1.26 version bump. Updated HOMEPAGE, using our mirrors for SRC_URI.
Package-Manager: portage-2.0.54
Diffstat (limited to 'net-analyzer/netio')
-rw-r--r--net-analyzer/netio/ChangeLog9
-rw-r--r--net-analyzer/netio/Manifest18
-rw-r--r--net-analyzer/netio/files/digest-netio-1.261
-rw-r--r--net-analyzer/netio/netio-1.26.ebuild56
4 files changed, 69 insertions, 15 deletions
diff --git a/net-analyzer/netio/ChangeLog b/net-analyzer/netio/ChangeLog
index 4bba23ed8218..e5c67cfc5db4 100644
--- a/net-analyzer/netio/ChangeLog
+++ b/net-analyzer/netio/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/netio
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netio/ChangeLog,v 1.9 2005/01/28 10:39:51 ka0ttic Exp $
+# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netio/ChangeLog,v 1.10 2006/01/23 02:49:43 vanquirius Exp $
+
+*netio-1.26 (23 Jan 2006)
+
+ 23 Jan 2006; Marcelo Goes <vanquirius@gentoo.org> +netio-1.26.ebuild:
+ 1.26 version bump. Updated HOMEPAGE, using our mirrors for SRC_URI.
28 Jan 2005; Aaron Walker <ka0ttic@gentoo.org> netio-1.23.ebuild:
Minor ebuild cleansing; respect CFLAGS. Also added pkg_postinst for messages
diff --git a/net-analyzer/netio/Manifest b/net-analyzer/netio/Manifest
index 510bf1858980..80990c795d69 100644
--- a/net-analyzer/netio/Manifest
+++ b/net-analyzer/netio/Manifest
@@ -1,14 +1,6 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 d937f9db3863634a79e88e29e0af66d0 netio-1.23.ebuild 1480
-MD5 faac2f7f818517292d07e09ddd4dc0db ChangeLog 4062
-MD5 f34e3c8858756da0001b12d2d3fa1af2 metadata.xml 159
+MD5 8be82a33d225e9acc94b45be77636fc5 ChangeLog 4236
MD5 e2011a67f325086737a95017b12456d1 files/digest-netio-1.23 57
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.0 (GNU/Linux)
-
-iD8DBQFB+haAEZCkKN40op4RAsgOAJoDhLhL2engnobaWQyMom+wE2LpVACgiPtY
-1J3lgz2nZhCMSrB2xRiVOK8=
-=cptX
------END PGP SIGNATURE-----
+MD5 3fe01eaca6952739673292b48fea4b62 files/digest-netio-1.26 57
+MD5 f34e3c8858756da0001b12d2d3fa1af2 metadata.xml 159
+MD5 d937f9db3863634a79e88e29e0af66d0 netio-1.23.ebuild 1480
+MD5 dd5ca5051522a589f752b5842ea70642 netio-1.26.ebuild 1548
diff --git a/net-analyzer/netio/files/digest-netio-1.26 b/net-analyzer/netio/files/digest-netio-1.26
new file mode 100644
index 000000000000..fa017fb5c292
--- /dev/null
+++ b/net-analyzer/netio/files/digest-netio-1.26
@@ -0,0 +1 @@
+MD5 e54ac24ceac94c5ea6dd143abf9752e3 netio126.zip 140402
diff --git a/net-analyzer/netio/netio-1.26.ebuild b/net-analyzer/netio/netio-1.26.ebuild
new file mode 100644
index 000000000000..a81d7aabed40
--- /dev/null
+++ b/net-analyzer/netio/netio-1.26.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netio/netio-1.26.ebuild,v 1.1 2006/01/23 02:49:43 vanquirius Exp $
+
+inherit toolchain-funcs versionator
+
+MY_P="${PN}$(get_version_component_range 1)$(get_version_component_range 2)"
+DESCRIPTION="a network benchmark for DOS, OS/2, Windows NT and Unix that measures net througput with NetBIOS and TCP/IP protocols."
+HOMEPAGE="http://www.ars.de/ars/ars.nsf/docs/netio"
+SRC_URI="mirror://gentoo/${MY_P}.zip"
+
+LICENSE="free-noncomm"
+SLOT="0"
+KEYWORDS="~ppc ~ppc-macos ~sparc ~x86"
+IUSE=""
+
+DEPEND="virtual/libc
+ app-arch/unzip
+ >=sys-apps/sed-4"
+RDEPEND="virtual/libc"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i -e 's|\(CFLAGS\)=|\1?=|g' \
+ -e 's|\(CC\)=|\1?=|g' Makefile || die "sed Makefile failed"
+}
+
+src_compile() {
+ emake linux \
+ CC="$(tc-getCC)" \
+ CFLAGS="-DUNIX ${CFLAGS}" \
+ || die "emake failed"
+}
+
+src_install() {
+ dobin netio || die "dobin failed"
+
+ # to be sure to comply with the license statement in netio.doc,
+ # just install everything included in the package to doc
+ dodoc netio.doc FILE_ID.DIZ getopt.h netb_1_c.h netbios.h netio.c \
+ netb_2_c.h netio.doc getopt.c Makefile netbios.c
+
+ # also install binaries
+ dodoc bin/os2-i386.exe bin/win32-i386.exe bin/linux-i386
+}
+
+pkg_postinst() {
+ echo
+ einfo "NOTE: all files included in the upstream zip file have"
+ einfo "been installed to /usr/share/doc/${PF}, as required by"
+ einfo "the license."
+ echo
+}