summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2006-11-02 14:04:35 +0000
committerPeter Volkov <pva@gentoo.org>2006-11-02 14:04:35 +0000
commitdd42653119006031dca9fc3442992c772d6171de (patch)
tree793ac92ae92b794606e960605a7d3ac098f27f58 /net-analyzer/metasploit
parentAdded scrollkeeper dependency. Fixed bug #153772. Thank Clark Cgable2003 at g... (diff)
downloadhistorical-dd42653119006031dca9fc3442992c772d6171de.tar.gz
historical-dd42653119006031dca9fc3442992c772d6171de.tar.bz2
historical-dd42653119006031dca9fc3442992c772d6171de.zip
Version bump. Thank Matt Drew (aetius) matt.drew at gmail.com for report. Removed old versions. Cleaned metadata.xml a bit.
Package-Manager: portage-2.1.1
Diffstat (limited to 'net-analyzer/metasploit')
-rw-r--r--net-analyzer/metasploit/ChangeLog10
-rw-r--r--net-analyzer/metasploit/files/digest-metasploit-2.73
-rw-r--r--net-analyzer/metasploit/metadata.xml23
-rw-r--r--net-analyzer/metasploit/metasploit-2.7.ebuild48
4 files changed, 72 insertions, 12 deletions
diff --git a/net-analyzer/metasploit/ChangeLog b/net-analyzer/metasploit/ChangeLog
index 3b6eaa70f2cf..2347abbf1181 100644
--- a/net-analyzer/metasploit/ChangeLog
+++ b/net-analyzer/metasploit/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-analyzer/metasploit
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/metasploit/ChangeLog,v 1.13 2006/06/14 11:13:54 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/metasploit/ChangeLog,v 1.14 2006/11/02 14:04:35 pva Exp $
+
+*metasploit-2.7 (02 Nov 2006)
+
+ 02 Nov 2006; Peter Volkov <pva@gentoo.org> metadata.xml,
+ -metasploit-2.3-r2.ebuild, -metasploit-2.4-r1.ebuild,
+ -metasploit-2.5.ebuild, +metasploit-2.7.ebuild:
+ Version bump. Thank Matt Drew (aetius) matt.drew at gmail.com for report.
+ Removed old versions. Cleaned metadata.xml a bit.
*metasploit-2.6 (14 Jun 2006)
diff --git a/net-analyzer/metasploit/files/digest-metasploit-2.7 b/net-analyzer/metasploit/files/digest-metasploit-2.7
new file mode 100644
index 000000000000..12f0acd3d977
--- /dev/null
+++ b/net-analyzer/metasploit/files/digest-metasploit-2.7
@@ -0,0 +1,3 @@
+MD5 ea592cfb006e1b2510b533cece4ecb18 framework-2.7.tar.gz 5800216
+RMD160 cfdf2705522c845bb4405413207a7df0f3873b94 framework-2.7.tar.gz 5800216
+SHA256 516952772aaa8982628460b927c9119850925f870903c5a131a9c9f0390cf77f framework-2.7.tar.gz 5800216
diff --git a/net-analyzer/metasploit/metadata.xml b/net-analyzer/metasploit/metadata.xml
index 47a79cc2767d..bc177a249041 100644
--- a/net-analyzer/metasploit/metadata.xml
+++ b/net-analyzer/metasploit/metadata.xml
@@ -2,15 +2,16 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>netmon</herd>
- <maintainer>
- <email>netmon@gentoo.org</email>
- <name>Netmon Herd</name>
- </maintainer>
- <longdescription>
-This project is a powerful tool for penetration testing, exploit development, and vulnerability research.
-The Framework is written in the Perl scripting language and includes various components written in C, assembler, and Python.
-This project can be roughly compared to commercial offerings such as Immunity's CANVAS and Core Security Technology's Impact.
-The major difference between the Framework and these commercial products is the focus; while the commercial products need to
-always provide the latest exploits and an intuitive GUI, the Framework was designed to facilitate research and experimentation with new technologies.
- </longdescription>
+ <longdescription lang="en">
+ This project is a powerful tool for penetration testing, exploit
+ development, and vulnerability research. The Framework is written in
+ the Perl scripting language and includes various components written in
+ C, assembler, and Python. This project can be roughly compared to
+ commercial offerings such as Immunity's CANVAS and Core Security
+ Technology's Impact. The major difference between the Framework and
+ these commercial products is the focus; while the commercial products
+ need to always provide the latest exploits and an intuitive GUI, the
+ Framework was designed to facilitate research and experimentation with
+ new technologies.
+</longdescription>
</pkgmetadata>
diff --git a/net-analyzer/metasploit/metasploit-2.7.ebuild b/net-analyzer/metasploit/metasploit-2.7.ebuild
new file mode 100644
index 000000000000..16185d84ddac
--- /dev/null
+++ b/net-analyzer/metasploit/metasploit-2.7.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/metasploit/metasploit-2.7.ebuild,v 1.1 2006/11/02 14:04:35 pva Exp $
+
+MY_P="${P/metasploit/framework}"
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="The Metasploit Framework is an advanced open-source platform for developing, testing, and using vulnerability exploit code."
+HOMEPAGE="http://www.metasploit.org/"
+SRC_URI="http://metasploit.com/tools/${MY_P}.tar.gz"
+
+LICENSE="GPL-2 Artistic"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/perl
+ dev-perl/Net-SSLeay
+ dev-perl/Term-ReadLine-Perl
+ dev-perl/TermReadKey"
+
+src_install() {
+ dodir /usr/lib/
+ dodir /usr/bin/
+
+ # should be as simple as copying everything into the target...
+ cp -pPR ${S} ${D}usr/lib/metasploit || die
+
+ # and creating symlinks in the /usr/bin dir
+ cd ${D}/usr/bin
+ ln -s ../lib/metasploit/msf* ./ || die
+ chown -R root:0 ${D}
+
+ newinitd ${FILESDIR}/msfweb.initd msfweb || die "newinitd failed"
+ newconfd ${FILESDIR}/msfweb.confd msfweb || die "newconfd failed"
+}
+
+pkg_postinst() {
+ elog "To update metasploit modules run:"
+ elog " # cd /usr/lib/metasploit && svn update"
+}
+
+pkg_postrm() {
+ if [[ -d /usr/lib/metasploit ]] ; then
+ ewarn "If you ever updated modules emerge will keep /var/lib/metasploit"
+ ewarn "directory. Thus to remove metasploit completely do not forgive to:"
+ ewarn " # rm -r /var/lib/metasploit"
+ fi
+}