summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2006-10-10 13:47:19 +0000
committerMarkus Ullmann <jokey@gentoo.org>2006-10-10 13:47:19 +0000
commitf8dbf9e0f4de0fce4a823e5288f66641c68ca358 (patch)
tree3f87a2951a2cea06f6676485b7abdc91d2afb235 /net-analyzer/iptraf
parentRemoved old version. (diff)
downloadhistorical-f8dbf9e0f4de0fce4a823e5288f66641c68ca358.tar.gz
historical-f8dbf9e0f4de0fce4a823e5288f66641c68ca358.tar.bz2
historical-f8dbf9e0f4de0fce4a823e5288f66641c68ca358.zip
Adding linux-headers compile fix wrt bug #144205 thanks to Bo Orsted Andresen
Package-Manager: portage-2.1.2_pre2-r6
Diffstat (limited to 'net-analyzer/iptraf')
-rw-r--r--net-analyzer/iptraf/ChangeLog8
-rw-r--r--net-analyzer/iptraf/files/iptraf-3.0.0-headerfix.patch18
-rw-r--r--net-analyzer/iptraf/files/iptraf-3.0.0-ipv6-headerfix.patch2
3 files changed, 23 insertions, 5 deletions
diff --git a/net-analyzer/iptraf/ChangeLog b/net-analyzer/iptraf/ChangeLog
index 798ae26e7e5e..d1876f06a759 100644
--- a/net-analyzer/iptraf/ChangeLog
+++ b/net-analyzer/iptraf/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/iptraf
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/iptraf/ChangeLog,v 1.40 2006/09/16 15:12:15 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/iptraf/ChangeLog,v 1.41 2006/10/10 13:47:19 jokey Exp $
+
+ 10 Oct 2006; Markus Ullmann <jokey@gentoo.org>
+ files/iptraf-3.0.0-headerfix.patch,
+ files/iptraf-3.0.0-ipv6-headerfix.patch, -iptraf-2.7.0-r2.ebuild,
+ -iptraf-3.0.0-r1.ebuild:
+ Adding linux-headers compile fix wrt bug #144205 thanks to Bo Orsted Andresen
16 Sep 2006; Markus Rothe <corsair@gentoo.org> iptraf-3.0.0-r2.ebuild:
Added ~ppc64
diff --git a/net-analyzer/iptraf/files/iptraf-3.0.0-headerfix.patch b/net-analyzer/iptraf/files/iptraf-3.0.0-headerfix.patch
index 7ce5e7c66eb9..604d63e26f17 100644
--- a/net-analyzer/iptraf/files/iptraf-3.0.0-headerfix.patch
+++ b/net-analyzer/iptraf/files/iptraf-3.0.0-headerfix.patch
@@ -1,6 +1,17 @@
-diff -urN ./iptraf-3.0.0.orig/src/tr.c ./iptraf-3.0.0/src/tr.c
---- ./iptraf-3.0.0.orig/src/tr.c 2005-09-13 08:42:54.000000000 +0200
-+++ ./iptraf-3.0.0/src/tr.c 2006-04-16 00:20:06.000000000 +0200
+diff -Naur iptraf-3.0.0-minus/src/othptab.c iptraf-3.0.0/src/othptab.c
+--- iptraf-3.0.0-minus/src/othptab.c 2006-09-27 03:30:33.000000000 +0200
++++ iptraf-3.0.0/src/othptab.c 2006-09-27 03:34:24.000000000 +0200
+@@ -17,6 +17,7 @@
+ ***/
+
+ #include <asm/types.h>
++#include <sys/types.h>
+ #include <linux/if_ether.h>
+ #include <winops.h>
+ #include "arphdr.h"
+diff -Naur iptraf-3.0.0-minus/src/tr.c iptraf-3.0.0/src/tr.c
+--- iptraf-3.0.0-minus/src/tr.c 2005-09-13 08:42:54.000000000 +0200
++++ iptraf-3.0.0/src/tr.c 2006-09-27 03:32:54.000000000 +0200
@@ -7,8 +7,8 @@
*/
@@ -11,3 +22,4 @@ diff -urN ./iptraf-3.0.0.orig/src/tr.c ./iptraf-3.0.0/src/tr.c
unsigned int get_tr_ip_offset(unsigned char *pkt)
{
+
diff --git a/net-analyzer/iptraf/files/iptraf-3.0.0-ipv6-headerfix.patch b/net-analyzer/iptraf/files/iptraf-3.0.0-ipv6-headerfix.patch
index a2ec93eb6bce..40b95f34a311 100644
--- a/net-analyzer/iptraf/files/iptraf-3.0.0-ipv6-headerfix.patch
+++ b/net-analyzer/iptraf/files/iptraf-3.0.0-ipv6-headerfix.patch
@@ -2,9 +2,9 @@ diff -urN ./iptraf-3.0.0.orig/src/othptab.c ./iptraf-3.0.0/src/othptab.c
--- ./iptraf-3.0.0.orig/src/othptab.c 2006-04-16 00:20:52.000000000 +0200
+++ ./iptraf-3.0.0/src/othptab.c 2006-04-16 00:22:01.000000000 +0200
@@ -17,9 +17,9 @@
- ***/
#include <asm/types.h>
+ #include <sys/types.h>
-#include <linux/if_ether.h>
#include <netinet/ip6.h>
#include <netinet/icmp6.h>