summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Góes <vanquirius@gentoo.org>2005-06-27 19:20:26 +0000
committerMarcelo Góes <vanquirius@gentoo.org>2005-06-27 19:20:26 +0000
commita5ed99741a46f3296c9e0e4613d17c99046b265b (patch)
treef98239ea204b344fca76ae3bea179879e613d10e /net-analyzer/dsniff
parent~amd64 (diff)
downloadhistorical-a5ed99741a46f3296c9e0e4613d17c99046b265b.tar.gz
historical-a5ed99741a46f3296c9e0e4613d17c99046b265b.tar.bz2
historical-a5ed99741a46f3296c9e0e4613d17c99046b265b.zip
Adding append-ldflags -lresolv to allow amd64 compilation, ~amd64 keyword.
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'net-analyzer/dsniff')
-rw-r--r--net-analyzer/dsniff/ChangeLog7
-rw-r--r--net-analyzer/dsniff/Manifest8
-rw-r--r--net-analyzer/dsniff/dsniff-2.3-r5.ebuild77
-rw-r--r--net-analyzer/dsniff/files/digest-dsniff-2.3-r52
4 files changed, 90 insertions, 4 deletions
diff --git a/net-analyzer/dsniff/ChangeLog b/net-analyzer/dsniff/ChangeLog
index 5ecaf1d49ffa..44adcf9d3573 100644
--- a/net-analyzer/dsniff/ChangeLog
+++ b/net-analyzer/dsniff/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/dsniff
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/dsniff/ChangeLog,v 1.16 2005/05/17 18:14:51 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/dsniff/ChangeLog,v 1.17 2005/06/27 19:20:26 vanquirius Exp $
+
+*dsniff-2.3-r5 (27 Jun 2005)
+
+ 27 Jun 2005; Marcelo Goes <vanquirius@gentoo.org> +dsniff-2.3-r5.ebuild:
+ Adding append-ldflags -lresolv to allow amd64 compilation, ~amd64 keyword.
17 May 2005; Michael Hanselmann <hansmi@gentoo.org> dsniff-2.3-r4.ebuild:
Stable on ppc.
diff --git a/net-analyzer/dsniff/Manifest b/net-analyzer/dsniff/Manifest
index 2a57d2178295..0462eba71bce 100644
--- a/net-analyzer/dsniff/Manifest
+++ b/net-analyzer/dsniff/Manifest
@@ -1,6 +1,8 @@
+MD5 33429f33cb307d7a7ff109b9dd5424d4 dsniff-2.3-r5.ebuild 2306
+MD5 2ac4fb06e3d9ccb249e595a70cf1b32b ChangeLog 2241
MD5 bb880c49bdffe94226562c9f6b06e0e7 metadata.xml 719
-MD5 0f712756bfe5bb3c7321623049b8a368 ChangeLog 2054
MD5 48eead686457507a20e6688478e2a010 dsniff-2.3-r4.ebuild 2227
-MD5 f41ad0aeacc05042ec27551b257845d3 files/2.3-makefile.patch 1531
-MD5 9206faea6a9be25f7d1aa0ac0a2ff6e3 files/2.3-libnet-1.0.patch 6110
MD5 5c5bea8cc4846925ba48ba5c9ea83341 files/digest-dsniff-2.3-r4 123
+MD5 5c5bea8cc4846925ba48ba5c9ea83341 files/digest-dsniff-2.3-r5 123
+MD5 9206faea6a9be25f7d1aa0ac0a2ff6e3 files/2.3-libnet-1.0.patch 6110
+MD5 f41ad0aeacc05042ec27551b257845d3 files/2.3-makefile.patch 1531
diff --git a/net-analyzer/dsniff/dsniff-2.3-r5.ebuild b/net-analyzer/dsniff/dsniff-2.3-r5.ebuild
new file mode 100644
index 000000000000..d9c02a730f2f
--- /dev/null
+++ b/net-analyzer/dsniff/dsniff-2.3-r5.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/dsniff/dsniff-2.3-r5.ebuild,v 1.1 2005/06/27 19:20:26 vanquirius Exp $
+
+inherit eutils flag-o-matic
+
+# dsniff needs to build it's own version of sys-libs/db, since the one
+# normally installed is for some reason unusable for dsniffs configure script.
+# The version is chosen as being the standard one around at the time i wrote
+# this ebuild, it's not set in stone.
+
+DB_VER="3.2.9"
+
+DESCRIPTION="A collection of tools for network auditing and penetration testing"
+HOMEPAGE="http://monkey.org/~dugsong/dsniff/"
+SRC_URI="http://www.sleepycat.com/update/snapshot/db-${DB_VER}.tar.gz
+ http://monkey.org/~dugsong/${PN}/${P}.tar.gz"
+
+# dsniff has it's own small license which is in the docs section
+LICENSE="DSNIFF"
+SLOT="0"
+KEYWORDS="~amd64 ~alpha ~ppc ~x86"
+IUSE=""
+
+RDEPEND="virtual/libpcap
+ <net-libs/libnet-1.1
+ >=net-libs/libnet-1.0.2a-r3
+ >=net-libs/libnids-1.18
+ >=dev-libs/openssl-0.9.6e"
+# dependencies only for building our own sys-libs/db
+DEPEND="${RDEPEND}
+ virtual/libc
+ =sys-libs/db-1*
+ sys-devel/libtool
+ sys-devel/m4"
+
+src_unpack() {
+ unpack db-${DB_VER}.tar.gz
+ unpack ${P}.tar.gz
+
+ # Making sure data files get correctly installed and that dsniff
+ # can find them
+ # Working around dsniff b0rky config script
+ # Data stuff goes into /etc/dsniff
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-libnet-1.0.patch
+ sed -i \
+ -e 's:-ldb:-ldb -lpthread:' \
+ -e "s:lib':':" \
+ configure || die "sed configure"
+ sed -i 's:-DDSNIFF_LIBDIR=\\\"$(libdir)/\\\"::' Makefile.in || die "sed makefile"
+ sed -i 's:/usr/local/lib:/etc/dsniff:' pathnames.h || die "sed pathnames"
+ epatch ${FILESDIR}/${PV}-makefile.patch
+
+ # Allow amd64 compilation
+ append-ldflags -lresolv
+}
+
+src_compile() {
+ cd ${WORKDIR}/db-${DB_VER}/dist
+ ./configure \
+ --host=${CHOST} \
+ --enable-compat185 || die "./configure of db-${DB_VER} failed"
+ emake || die "build of db-${DB_VER} failed"
+
+ # Another workaround around the crappy config script
+ cd ${S}
+ econf --with-db=../db-${DB_VER} || die
+ make || die
+}
+
+src_install() {
+ make install install_prefix=${D} || die
+ dodir /etc/dsniff
+ mv ${D}/usr/{dnsspoof.hosts,dsniff.{magic,services}} ${D}/etc/dsniff/
+ dodoc CHANGES README TODO
+}
diff --git a/net-analyzer/dsniff/files/digest-dsniff-2.3-r5 b/net-analyzer/dsniff/files/digest-dsniff-2.3-r5
new file mode 100644
index 000000000000..e1135460a43f
--- /dev/null
+++ b/net-analyzer/dsniff/files/digest-dsniff-2.3-r5
@@ -0,0 +1,2 @@
+MD5 4df5c7051b11411e0a970f6c91613942 db-3.2.9.tar.gz 2085238
+MD5 183e336a45e38013f3af840bddec44b4 dsniff-2.3.tar.gz 126797