summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-08 06:56:39 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-08 06:56:39 +0000
commit2c74a59931e0aa1122a25aa7be083b0a5f796c93 (patch)
treea6f1c15c710394e4650f73ec32634f76daf69615 /net-analyzer/dsniff
parentDEPEND fix. Version bump to close bug #46855. (diff)
downloadhistorical-2c74a59931e0aa1122a25aa7be083b0a5f796c93.tar.gz
historical-2c74a59931e0aa1122a25aa7be083b0a5f796c93.tar.bz2
historical-2c74a59931e0aa1122a25aa7be083b0a5f796c93.zip
use newer ver of libnids #43370
Diffstat (limited to 'net-analyzer/dsniff')
-rw-r--r--net-analyzer/dsniff/ChangeLog5
-rw-r--r--net-analyzer/dsniff/dsniff-2.3-r1.ebuild10
-rw-r--r--net-analyzer/dsniff/dsniff-2.3.ebuild85
-rw-r--r--net-analyzer/dsniff/files/2.3-libnet-1.0.patch59
-rw-r--r--net-analyzer/dsniff/files/digest-dsniff-2.32
5 files changed, 18 insertions, 143 deletions
diff --git a/net-analyzer/dsniff/ChangeLog b/net-analyzer/dsniff/ChangeLog
index e7a22424e9f6..19da5537bf6e 100644
--- a/net-analyzer/dsniff/ChangeLog
+++ b/net-analyzer/dsniff/ChangeLog
@@ -1,9 +1,12 @@
# ChangeLog for net-analyzer/dsniff
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/dsniff/ChangeLog,v 1.6 2003/08/26 04:20:02 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/dsniff/ChangeLog,v 1.7 2004/04/08 06:56:39 vapier Exp $
*dsniff-2.3-r1 (21 Aug 2003)
+ 08 Apr 2004; Mike Frysinger <vapier@gentoo.org> :
+ Cleanup patch so that dsniff will use a newer version of nids #43370 by Magnus Maatta.
+
26 Aug 2003; Mike Frysinger <vapier@gentoo.org> :
Add patch to fix linking order #27267.
diff --git a/net-analyzer/dsniff/dsniff-2.3-r1.ebuild b/net-analyzer/dsniff/dsniff-2.3-r1.ebuild
index 29d660549b1a..0bce731eb49f 100644
--- a/net-analyzer/dsniff/dsniff-2.3-r1.ebuild
+++ b/net-analyzer/dsniff/dsniff-2.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/dsniff/dsniff-2.3-r1.ebuild,v 1.4 2003/09/03 00:49:51 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/dsniff/dsniff-2.3-r1.ebuild,v 1.5 2004/04/08 06:56:39 vapier Exp $
inherit eutils
@@ -24,8 +24,7 @@ KEYWORDS="~x86 ~alpha"
RDEPEND=">=net-libs/libpcap-0.7.1
<net-libs/libnet-1.1
>=net-libs/libnet-1.0.2a-r3
- <net-libs/libnids-1.17
- >=net-libs/libnids-1.16-r1
+ >=net-libs/libnids-1.18
>=dev-libs/openssl-0.9.6e"
# dependencies only for building our own sys-libs/db
@@ -45,7 +44,10 @@ src_unpack() {
# Data stuff goes into /etc/dsniff
cd ${S}
epatch ${FILESDIR}/${PV}-libnet-1.0.patch
- sed -i "s:lib':':" configure || die "sed configure"
+ sed -i \
+ -e 's:-ldb:-ldb -lpthread:' \
+ -e "s:lib':':" \
+ configure || die "sed configure"
sed -i 's:-DDSNIFF_LIBDIR=\\\"$(libdir)/\\\"::' Makefile.in || die "sed makefile"
sed -i 's:/usr/local/lib:/etc/dsniff:' pathnames.h || die "sed pathnames"
epatch ${FILESDIR}/${PV}-makefile.patch
diff --git a/net-analyzer/dsniff/dsniff-2.3.ebuild b/net-analyzer/dsniff/dsniff-2.3.ebuild
deleted file mode 100644
index ea318d31f3c1..000000000000
--- a/net-analyzer/dsniff/dsniff-2.3.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/dsniff/dsniff-2.3.ebuild,v 1.6 2003/09/05 23:40:08 msterret Exp $
-
-# dsniff needs to build it's own version of sys-libs/db, since the one
-# normally installed is for some reason unusable for dsniffs configure script.
-# The version is chosen as being the standard one around at the time i wrote
-# this ebuild, it's not set in stone.
-
-DB_VER="3.2.9"
-
-DESCRIPTION="A collection of tools for network auditing and penetration testing"
-HOMEPAGE="http://monkey.org/~dugsong/dsniff/"
-
-SRC_URI="http://www.sleepycat.com/update/snapshot/db-${DB_VER}.tar.gz
- http://monkey.org/~dugsong/${PN}/${P}.tar.gz"
-
-# dsniff has it's own small license which is in the docs section
-LICENSE="DSNIFF"
-SLOT="0"
-KEYWORDS="x86 ~ppc ~alpha"
-
-RDEPEND=">=net-libs/libpcap-0.7.1
- >=net-libs/libnet-1.0.2
- >=net-libs/libnids-1.16
- >=dev-libs/openssl-0.9.6e"
-
-# dependencies only for building our own sys-libs/db
-DEPEND="${RDEPEND}
- virtual/glibc
- =sys-libs/db-1.85-r1
- sys-devel/libtool
- sys-devel/m4"
-
-S="${WORKDIR}/${P}"
-IUSE=""
-
-src_unpack() {
- unpack db-${DB_VER}.tar.gz
- unpack ${P}.tar.gz
-
- # Making sure data files get correctly installed and that dsniff
- # can find them
- # Working around dsniff b0rky config script
- # Data stuff goes into /etc/dsniff
- cd ${S}
-
- mv configure configure.orig
- sed "s:lib':':" configure.orig > configure
- chmod +x configure
-
- mv Makefile.in Makefile.in.orig
- sed 's:-DDSNIFF_LIBDIR=\\\"$(libdir)/\\\"::' Makefile.in.orig > Makefile.in
-
- mv pathnames.h pathnames.h.orig
- sed 's:/usr/local/lib:/etc/dsniff:' pathnames.h.orig > pathnames.h
-}
-
-src_compile() {
- cd ${WORKDIR}/db-${DB_VER}/dist
- ./configure \
- --host=${CHOST} \
- --enable-compat185 || die "./configure of db-${DB_VER} failed"
- emake || die "build of db-${DB_VER} failed"
-
- # Another workaround around the crappy config script
- cd ${S}
- ./configure \
- --host=${CHOST} \
- --with-db=../db-${DB_VER} \
- --exec-prefix=${D}/etc/dsniff \
- --bindir=${D}/usr/bin \
- --sbindir=${D}/usr/sbin \
- --datadir=${D}/usr/share/ \
- --infodir=${D}/usr/share/info \
- --mandir=${D}/usr/share/man || die "./configure failed"
-
- make || die
-}
-
-src_install () {
- make install || die
-
- dodoc CHANGES LICENSE README TODO
-}
diff --git a/net-analyzer/dsniff/files/2.3-libnet-1.0.patch b/net-analyzer/dsniff/files/2.3-libnet-1.0.patch
index dd1692a8a0cf..0e036f86874e 100644
--- a/net-analyzer/dsniff/files/2.3-libnet-1.0.patch
+++ b/net-analyzer/dsniff/files/2.3-libnet-1.0.patch
@@ -42,41 +42,12 @@ diff -U 0 -r dsniff-2.3.orig/configure dsniff-2.3/configure
+ elif test -f /usr/include/libnet-1.0.h; then
+ CFLAGS="$CFLAGS `libnet-1.0-config --defines`"
+ LNETLIB="-lnet-1.0"
-@@ -3115 +3115 @@
-- if test -f $withval/src/nids.h -a -f $withval/src/libnids.a; then
-+ if test -f $withval/src/nids-1.0.h -a -f $withval/src/libnids-1.0.a; then
-@@ -3119,2 +3119,2 @@
-- NIDSLIB="-L$withval/src -lnids"
-- elif test -f $withval/include/nids.h -a -f $withval/lib/libnids.a; then
-+ NIDSLIB="-L$withval/src -lnids-1.0"
-+ elif test -f $withval/include/nids-1.0.h -a -f $withval/lib/libnids-1.0.a; then
-@@ -3124 +3124 @@
-- NIDSLIB="-L$withval/lib -lnids"
-+ NIDSLIB="-L$withval/lib -lnids-1.0"
-@@ -3126 +3126 @@
-- { echo "configure: error: nids.h or libnids.a not found in $withval" 1>&2; exit 1; }
-+ { echo "configure: error: nids-1.0.h or libnids-1.0.a not found in $withval" 1>&2; exit 1; }
-@@ -3131 +3131 @@
-- if test -f ${prefix}/include/nids.h; then
-+ if test -f ${prefix}/include/nids-1.0.h; then
-@@ -3133,3 +3133,3 @@
-- NIDSLIB="-L${prefix}/lib -lnids"
-- elif test -f /usr/include/nids.h; then
-- NIDSLIB="-lnids"
-+ NIDSLIB="-L${prefix}/lib -lnids-1.0"
-+ elif test -f /usr/include/nids-1.0.h; then
-+ NIDSLIB="-lnids-1.0"
-@@ -3151 +3151 @@
--#include <nids.h>
-+#include <nids-1.0.h>
diff -U 0 -r dsniff-2.3.orig/decode_portmap.c dsniff-2.3/decode_portmap.c
--- dsniff-2.3.orig/decode_portmap.c 2000-12-15 15:13:29.000000000 -0500
+++ dsniff-2.3/decode_portmap.c 2003-08-19 14:51:56.350596720 -0400
-@@ -18,2 +18,2 @@
+@@ -18,1 +18,1 @@
-#include <libnet.h>
--#include <nids.h>
+#include <libnet-1.0.h>
-+#include <nids-1.0.h>
diff -U 0 -r dsniff-2.3.orig/dnsspoof.c dsniff-2.3/dnsspoof.c
--- dsniff-2.3.orig/dnsspoof.c 2000-11-19 14:39:40.000000000 -0500
+++ dsniff-2.3/dnsspoof.c 2003-08-19 14:51:56.183622104 -0400
@@ -86,19 +57,15 @@ diff -U 0 -r dsniff-2.3.orig/dnsspoof.c dsniff-2.3/dnsspoof.c
diff -U 0 -r dsniff-2.3.orig/dsniff.c dsniff-2.3/dsniff.c
--- dsniff-2.3.orig/dsniff.c 2000-12-01 16:27:15.000000000 -0500
+++ dsniff-2.3/dsniff.c 2003-08-19 14:51:56.352596416 -0400
-@@ -21,2 +21,2 @@
+@@ -21,1 +21,1 @@
-#include <libnet.h>
--#include <nids.h>
+#include <libnet-1.0.h>
-+#include <nids-1.0.h>
diff -U 0 -r dsniff-2.3.orig/filesnarf.c dsniff-2.3/filesnarf.c
--- dsniff-2.3.orig/filesnarf.c 2000-12-15 15:16:58.000000000 -0500
+++ dsniff-2.3/filesnarf.c 2003-08-19 14:51:56.357595656 -0400
-@@ -22,2 +22,2 @@
+@@ -22,1 +22,1 @@
-#include <libnet.h>
--#include <nids.h>
+#include <libnet-1.0.h>
-+#include <nids-1.0.h>
diff -U 0 -r dsniff-2.3.orig/macof.c dsniff-2.3/macof.c
--- dsniff-2.3.orig/macof.c 2000-11-14 10:50:55.000000000 -0500
+++ dsniff-2.3/macof.c 2003-08-19 14:51:56.192620736 -0400
@@ -108,19 +75,15 @@ diff -U 0 -r dsniff-2.3.orig/macof.c dsniff-2.3/macof.c
diff -U 0 -r dsniff-2.3.orig/mailsnarf.c dsniff-2.3/mailsnarf.c
--- dsniff-2.3.orig/mailsnarf.c 2000-11-19 14:39:41.000000000 -0500
+++ dsniff-2.3/mailsnarf.c 2003-08-19 14:51:56.361595048 -0400
-@@ -21,2 +21,2 @@
+@@ -21,1 +21,1 @@
-#include <libnet.h>
--#include <nids.h>
+#include <libnet-1.0.h>
-+#include <nids-1.0.h>
diff -U 0 -r dsniff-2.3.orig/msgsnarf.c dsniff-2.3/msgsnarf.c
--- dsniff-2.3.orig/msgsnarf.c 2000-12-15 15:12:19.000000000 -0500
+++ dsniff-2.3/msgsnarf.c 2003-08-19 14:51:56.369593832 -0400
-@@ -20,2 +20,2 @@
+@@ -20,1 +20,1 @@
-#include <libnet.h>
--#include <nids.h>
+#include <libnet-1.0.h>
-+#include <nids-1.0.h>
diff -U 0 -r dsniff-2.3.orig/record.c dsniff-2.3/record.c
--- dsniff-2.3.orig/record.c 2000-11-14 10:51:02.000000000 -0500
+++ dsniff-2.3/record.c 2003-08-19 14:51:56.206618608 -0400
@@ -154,19 +117,15 @@ diff -U 0 -r dsniff-2.3.orig/tcpnice.c dsniff-2.3/tcpnice.c
diff -U 0 -r dsniff-2.3.orig/trigger.c dsniff-2.3/trigger.c
--- dsniff-2.3.orig/trigger.c 2000-11-19 16:44:29.000000000 -0500
+++ dsniff-2.3/trigger.c 2003-08-19 14:51:56.376592768 -0400
-@@ -15,2 +15,2 @@
+@@ -15,1 +15,1 @@
-#include <libnet.h>
--#include <nids.h>
+#include <libnet-1.0.h>
-+#include <nids-1.0.h>
diff -U 0 -r dsniff-2.3.orig/urlsnarf.c dsniff-2.3/urlsnarf.c
--- dsniff-2.3.orig/urlsnarf.c 2000-12-18 21:53:36.000000000 -0500
+++ dsniff-2.3/urlsnarf.c 2003-08-19 14:51:56.378592464 -0400
-@@ -24,2 +24,2 @@
+@@ -24,1 +24,1 @@
-#include <libnet.h>
--#include <nids.h>
+#include <libnet-1.0.h>
-+#include <nids-1.0.h>
diff -U 0 -r dsniff-2.3.orig/webmitm.c dsniff-2.3/webmitm.c
--- dsniff-2.3.orig/webmitm.c 2000-12-03 00:13:28.000000000 -0500
+++ dsniff-2.3/webmitm.c 2003-08-19 14:51:56.229615112 -0400
@@ -176,8 +135,6 @@ diff -U 0 -r dsniff-2.3.orig/webmitm.c dsniff-2.3/webmitm.c
diff -U 0 -r dsniff-2.3.orig/webspy.c dsniff-2.3/webspy.c
--- dsniff-2.3.orig/webspy.c 2000-11-14 10:51:04.000000000 -0500
+++ dsniff-2.3/webspy.c 2003-08-19 14:51:56.381592008 -0400
-@@ -24,2 +24,2 @@
+@@ -24,1 +24,1 @@
-#include <libnet.h>
--#include <nids.h>
+#include <libnet-1.0.h>
-+#include <nids-1.0.h>
diff --git a/net-analyzer/dsniff/files/digest-dsniff-2.3 b/net-analyzer/dsniff/files/digest-dsniff-2.3
deleted file mode 100644
index e1135460a43f..000000000000
--- a/net-analyzer/dsniff/files/digest-dsniff-2.3
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 4df5c7051b11411e0a970f6c91613942 db-3.2.9.tar.gz 2085238
-MD5 183e336a45e38013f3af840bddec44b4 dsniff-2.3.tar.gz 126797