summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEldad Zack <eldad@gentoo.org>2004-11-21 11:50:22 +0000
committerEldad Zack <eldad@gentoo.org>2004-11-21 11:50:22 +0000
commit6d586b22c95cc5335fdf43c3f5d08c7e5ca39120 (patch)
tree6a4218b32733722f1065160c9e27166a4af4432a /net-analyzer/cnet
parentThis package has a hard dependency on libelf and will break against elfutils (diff)
downloadhistorical-6d586b22c95cc5335fdf43c3f5d08c7e5ca39120.tar.gz
historical-6d586b22c95cc5335fdf43c3f5d08c7e5ca39120.tar.bz2
historical-6d586b22c95cc5335fdf43c3f5d08c7e5ca39120.zip
bumped
Diffstat (limited to 'net-analyzer/cnet')
-rw-r--r--net-analyzer/cnet/ChangeLog9
-rw-r--r--net-analyzer/cnet/Manifest11
-rw-r--r--net-analyzer/cnet/cnet-2.0.9.ebuild44
-rw-r--r--net-analyzer/cnet/files/cnet-2.0.9-gentoo.patch50
-rw-r--r--net-analyzer/cnet/files/digest-cnet-2.0.91
5 files changed, 110 insertions, 5 deletions
diff --git a/net-analyzer/cnet/ChangeLog b/net-analyzer/cnet/ChangeLog
index ef104d7b32db..53135aba7e96 100644
--- a/net-analyzer/cnet/ChangeLog
+++ b/net-analyzer/cnet/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-analyzer/cnet
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cnet/ChangeLog,v 1.7 2004/11/21 11:41:12 eldad Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cnet/ChangeLog,v 1.8 2004/11/21 11:50:22 eldad Exp $
+
+*cnet-2.0.9 (21 Nov 2004)
+
+ 21 Nov 2004; Eldad Zack <eldad@gentoo.org> +files/cnet-2.0.9-gentoo.patch,
+ +cnet-2.0.9.ebuild:
+ Version bump. Thanks to Surakshan Mendis <bugtracker@surasoft.com>. Closes
+ #66275.
21 Nov 2004; Eldad Zack <eldad@gentoo.org> cnet-2.0.5.ebuild:
This package has a hard dependency on libelf and will break against elfutils.
diff --git a/net-analyzer/cnet/Manifest b/net-analyzer/cnet/Manifest
index e6a0a527a61c..6d47843c1f23 100644
--- a/net-analyzer/cnet/Manifest
+++ b/net-analyzer/cnet/Manifest
@@ -2,14 +2,17 @@
Hash: SHA1
MD5 d5e52cc47230e288ad40e44b0ffddbf0 cnet-2.0.5.ebuild 1159
-MD5 cd65c131a6f0ffe5cd21a7dead925755 ChangeLog 1182
+MD5 7720524b1c6bb49586242bfbb7cc7e8a cnet-2.0.9.ebuild 1154
+MD5 d1bb16b201d433be744f712a0db0b6e9 ChangeLog 1396
MD5 b4e1d959ab12c9bb69e0db9f1d66205f metadata.xml 218
MD5 5fa730e3f767e911187654f6f809257f files/digest-cnet-2.0.5 60
+MD5 1f8197488ef6fbb97976d664d345d1d0 files/digest-cnet-2.0.9 60
+MD5 86dbc35b31d6c43d3ecdfbef24ba7da7 files/cnet-2.0.9-gentoo.patch 1531
MD5 652fb332fa98e02524b07ee1561c6182 files/cnet-2.0.5-gentoo.patch 1363
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.6 (GNU/Linux)
-iD8DBQFBoH2ZT+MN7JbqCpMRAus+AJsF+4Z8j69Ev6JHhWULW23bpvXurQCePGc2
-nR74jaZ5QsgJsg/o0fMJtRY=
-=m29z
+iD8DBQFBoH+9T+MN7JbqCpMRAkMCAKCLycYooYpI0v5urKlfMghtx/NpYwCeL5r8
+iRJAMNtsw72tlUUYkVGzdoM=
+=n9tG
-----END PGP SIGNATURE-----
diff --git a/net-analyzer/cnet/cnet-2.0.9.ebuild b/net-analyzer/cnet/cnet-2.0.9.ebuild
new file mode 100644
index 000000000000..690144aade73
--- /dev/null
+++ b/net-analyzer/cnet/cnet-2.0.9.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cnet/cnet-2.0.9.ebuild,v 1.1 2004/11/21 11:50:22 eldad Exp $
+
+inherit eutils
+
+DESCRIPTION="Network simulation tool"
+SRC_URI="http://www.csse.uwa.edu.au/cnet/${P}.tgz"
+HOMEPAGE="http://www.csse.uwa.edu.au/cnet"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+# cnet will NOT work against elfutils (but it will compile!) Bug #67375. (21 Nov 2004 eldad)
+DEPEND=">=dev-lang/tk-8.3.4
+ dev-libs/libelf"
+
+#RDEPEND=""
+
+# unpacking the source
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/${P}-gentoo.patch
+ sed -i.orig -e "s/^CFLAGS.*/CFLAGS=${CFLAGS}/" ${S}/src/Makefile.linux
+}
+
+src_install() {
+ # these directories aren't created during the make install
+ # process, so we'll need to make them beforehand, or else
+ # we'll have nowhere to put the files
+ mkdir -p ${D}/usr/{bin,lib,share}
+ mkdir -p ${D}/usr/share/man/man1
+ # install with make now
+ emake PREFIX=${D}/usr install || die
+
+ #install examples
+ DOCDESTTREE=EXAMPLES
+ dodir /usr/share/doc/${PF}/${DOCDESTTREE}
+ dodoc EXAMPLES/*
+}
diff --git a/net-analyzer/cnet/files/cnet-2.0.9-gentoo.patch b/net-analyzer/cnet/files/cnet-2.0.9-gentoo.patch
new file mode 100644
index 000000000000..9817db77c684
--- /dev/null
+++ b/net-analyzer/cnet/files/cnet-2.0.9-gentoo.patch
@@ -0,0 +1,50 @@
+--- Makefile 2003-03-31 11:13:05.000000000 +0800
++++ Makefile 2004-10-04 10:41:10.292769416 +0800
+@@ -1,5 +1,5 @@
+ NAME = cnet
+-VERSION = 2.0.4
++VERSION = 2.0.9
+ SHELL = /bin/sh
+ #
+ # Change the following 5 constants to suit your local site.
+@@ -7,14 +7,14 @@
+ # It is presumed that BINDIR and MANDIR exist, so you may need
+ # to create them, and set their permissions, if necessary.
+ #
+-PREFIX = /usr/local
++PREFIX = /usr/
+ #
+ BINDIR = $(PREFIX)/bin
+-CNETDIR = $(PREFIX)/cnetlib
+-MANDIR = $(PREFIX)/man/man1
++CNETDIR = $(PREFIX)/lib/cnetlib
++MANDIR = $(PREFIX)/share/man/man1
+ MANEXT = 1
+ MANFILE = $(MANDIR)/$(NAME).$(MANEXT)
+-WEBDIR = /home/httpd/html/cnet
++WEBDIR = $(CNETDIR)/html
+
+ # ---------------------------------------------------------------------
+
+--- src/Makefile.linux 2004-05-11 03:27:19.000000000 +0800
++++ src/Makefile.linux 2004-10-04 10:24:10.000000000 +0800
+@@ -29,7 +29,7 @@
+ ANSICC = gcc -ansi
+ INCLUDES = $(LIBELFINC)
+
+-CFLAGS = -O -Wall -fPIC $(INCLUDES) $(XINCLUDES)
++CFLAGS = -march=pentium3 -O3 -pipe -fPIC $(INCLUDES) $(XINCLUDES)
+
+ LD = gcc -rdynamic
+ LIBDIRS = -L/usr/X11R6/lib $(XLIBDIRS) $(LIBELFDIR)
+--- src/config.h 2004-05-13 02:13:43.000000000 +0800
++++ src/config.h 2004-10-04 10:39:39.000000000 +0800
+@@ -169,7 +169,7 @@
+ #if defined(USE_FREEBSD)
+ #define CNETPATH "/usr/local/share/cnet:/usr/local/include:/usr/local/cnetlib"
+ #else
+-#define CNETPATH "/usr/local/cnetlib:/usr/lib/cnet:/cslinux/cnetlib"
++#define CNETPATH "/usr/lib/cnetlib:/usr/lib/cnet:"
+ #endif
+
+
diff --git a/net-analyzer/cnet/files/digest-cnet-2.0.9 b/net-analyzer/cnet/files/digest-cnet-2.0.9
new file mode 100644
index 000000000000..3e256f4b2e50
--- /dev/null
+++ b/net-analyzer/cnet/files/digest-cnet-2.0.9
@@ -0,0 +1 @@
+MD5 593b63c809773a284bc3d655dc609298 cnet-2.0.9.tgz 1165028