summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2004-04-10 14:25:05 +0000
committerMartin Holzer <mholzer@gentoo.org>2004-04-10 14:25:05 +0000
commitcfe819d34d193a317b75533d8ef67beae80a8402 (patch)
tree267e83fece74bee20c7c022f55a323e28c0078c0 /net-analyzer/cacti
parentNew package (diff)
downloadhistorical-cfe819d34d193a317b75533d8ef67beae80a8402.tar.gz
historical-cfe819d34d193a317b75533d8ef67beae80a8402.tar.bz2
historical-cfe819d34d193a317b75533d8ef67beae80a8402.zip
Version bumped.
Diffstat (limited to 'net-analyzer/cacti')
-rw-r--r--net-analyzer/cacti/ChangeLog7
-rw-r--r--net-analyzer/cacti/Manifest4
-rw-r--r--net-analyzer/cacti/cacti-0.8.5a.ebuild124
-rw-r--r--net-analyzer/cacti/files/digest-cacti-0.8.5a1
4 files changed, 134 insertions, 2 deletions
diff --git a/net-analyzer/cacti/ChangeLog b/net-analyzer/cacti/ChangeLog
index ced590c600eb..3199c5121664 100644
--- a/net-analyzer/cacti/ChangeLog
+++ b/net-analyzer/cacti/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/cacti
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/ChangeLog,v 1.20 2004/02/29 08:39:55 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/ChangeLog,v 1.21 2004/04/10 14:25:05 mholzer Exp $
+
+*cacti-0.8.5a (10 Apr 2004)
+
+ 10 Apr 2004; Martin Holzer <mholzer@gentoo.org> cacti-0.8.5a.ebuild:
+ Version bumped.
*cacti-0.8.5 (29 Feb 2004)
diff --git a/net-analyzer/cacti/Manifest b/net-analyzer/cacti/Manifest
index 4b950c020d17..ba42b2959e99 100644
--- a/net-analyzer/cacti/Manifest
+++ b/net-analyzer/cacti/Manifest
@@ -1,10 +1,12 @@
-MD5 52ff241604dc12491144a562cf07d1e5 ChangeLog 2614
+MD5 772d6c58eb421c42af13a6045d1e3d96 ChangeLog 2733
MD5 120a31fc9efb18ee5b66efb1ae76308b cacti-0.6.8a.ebuild 1494
MD5 c57a8fd9ed9c867748ccefc4e17543c6 cacti-0.8.3a.ebuild 4236
MD5 78f6e2f9be374d85e5e0df7c16521bac cacti-0.8.4.ebuild 4234
MD5 791c6842b565daf6d45d7b698a953034 cacti-0.8.5.ebuild 4239
MD5 9683bb7323c40d69b48d54ad0eb169ed metadata.xml 221
+MD5 4cec2fe709afaca8fe6eee595e66d7f2 cacti-0.8.5a.ebuild 4273
MD5 36cff775a40a01ca080d9b290109a795 files/digest-cacti-0.6.8a 64
MD5 68b23916512df61b699d43aa9f7d25a5 files/digest-cacti-0.8.3a 64
MD5 e91aa7fea352dd63395f14af9492985f files/digest-cacti-0.8.4 63
MD5 a2e0519363a384bcb8e8f4f0d35fa5f4 files/digest-cacti-0.8.5 63
+MD5 44637d48edf68b76a472c70817449cd6 files/digest-cacti-0.8.5a 64
diff --git a/net-analyzer/cacti/cacti-0.8.5a.ebuild b/net-analyzer/cacti/cacti-0.8.5a.ebuild
new file mode 100644
index 000000000000..71dec9f02f6b
--- /dev/null
+++ b/net-analyzer/cacti/cacti-0.8.5a.ebuild
@@ -0,0 +1,124 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/cacti-0.8.5a.ebuild,v 1.1 2004/04/10 14:25:05 mholzer Exp $
+
+inherit eutils webapp-apache
+
+DESCRIPTION="Cacti is a complete frondend to rrdtool"
+HOMEPAGE="http://www.raxnet.net/products/cacti/"
+SRC_URI="http://www.raxnet.net/downloads/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+IUSE="snmp mysql"
+
+DEPEND=""
+RDEPEND="net-www/apache
+ snmp? ( virtual/snmp )
+ net-analyzer/rrdtool
+ mysql? ( dev-db/mysql )
+ dev-php/php
+ dev-php/mod_php"
+
+pkg_setup() {
+ webapp-detect || NO_WEBSERVER=1
+ webapp-pkg_setup "${NO_WEBSERVER}"
+ einfo "Installing into ${ROOT}${HTTPD_ROOT}."
+}
+
+src_install() {
+ webapp-detect || NO_WEBSERVER=1
+ webapp-mkdirs
+
+ local DocumentRoot=${HTTPD_ROOT}
+ local destdir=${DocumentRoot}/${PN}
+ dodir ${destdir}
+
+ dohtml docs/{INSTALL,UPGRADE}.htm
+ dodoc docs/{CHANGELOG,CONTRIB}
+ dodoc LICENSE
+
+ rm docs/{INSTALL,UPGRADE,INSTALL-WIN32}.htm
+ rm docs/{README,CHANGELOG,CONTRIB}
+ rm LICENSE README
+
+ mv docs/manual .
+ rm -fr docs
+ rm -rf cactid
+
+ edos2unix `find -type f -name '*.php'`
+ #chown -R ${HTTPD_USER}.${HTTPD_GROUP} *
+ cp -r . ${D}/${HTTPD_ROOT}/${PN}
+ cd ${D}/${HTTPD_ROOT}
+ chown -R ${HTTPD_USER}:${HTTPD_GROUP} ${PN}
+}
+
+pkg_postinst() {
+ # check to see if we have a previous version installed
+ minor_inst="$(ls -d /var/db/pkg/net-analyzer/cacti*|head -n 1|cut -d\. -f2)"
+ rel_inst="$(ls -d /var/db/pkg/net-analyzer/cacti*|head -n 1|cut -d\. -f3)"
+ if [ ${minor_inst}${rel_inst} -lt 81 ]
+ then
+ einfo
+ einfo "The cacti has been installed to ${INSTALL_DEST}"
+ einfo
+ einfo "Before cacti works you must upgrade the cacti database:"
+ einfo "1. Backup the old cacti database:"
+ einfo " shell> mysqlhotcopy --suffix=_old cacti"
+ einfo "2. Drop the old cacti database:"
+ einfo " shell> mysqladmin -p drop cacti"
+ einfo "3. Create the new cacti database"
+ einfo " shell> mysqladmin --user=root create cacti"
+ einfo "4. Import the default cacti database:"
+ einfo " shell> mysql cacti < ${INSTALL_DEST}/cacti.sql"
+ einfo "5. Edit ${INSTALL_DEST}/include/config.php."
+ einfo " + Modify the MySQL user, password and database for your"
+ einfo " cacti configuration."
+ einfo " \$database_default = \"cacti\";"
+ einfo " \$database_hostname = \"localhost\";"
+ einfo " \$database_username = \"cactiuser\";"
+ einfo " \$database_password = \"cacti\";"
+ einfo "6. Point your web browser to: http://your-server/cacti/"
+ einfo " Select \"Upgrade\"."
+ einfo " Make sure to fill in all of the path variables carefully and"
+ einfo " correctly on the following screen."
+ einfo
+ einfo "FINALLY, you must have these settings in your php.ini:"
+ einfo " register_globals = On"
+ einfo " register_argc_argv = On"
+ einfo
+ einfo "Test your upgraded installation. When all is fine you can"
+ eingo "drop the cacti_old database like so:"
+ einfo " shell> mysqladmin -p drop cacti_old"
+ einfo
+ else
+ einfo
+ einfo "The cacti has been copied to ${INSTALL_DEST}"
+ einfo
+ einfo "Before cacti works you must:"
+ einfo "1. Create the new cacti database"
+ einfo " shell> mysqladmin --user=root create cacti"
+ einfo "2. Import the default cacti database:"
+ einfo " shell> mysql cacti < ${INSTALL_DEST}/cacti.sql"
+ einfo "3. Optional: Create a MySQL username and password for cacti."
+ einfo " shell> mysql --user=root mysql"
+ einfo " mysql> GRANT ALL ON cacti.* TO cactiuser@localhost IDENTIFIED BY 'somepassword';"
+ einfo " mysql> flush privileges;"
+ einfo "4. Edit ${INSTALL_DEST}/include/config.php."
+ einfo " + Modify the MySQL user, password and database for your"
+ einfo " cacti configuration."
+ einfo " \$database_default = \"cacti\";"
+ einfo " \$database_hostname = \"localhost\";"
+ einfo " \$database_username = \"cactiuser\";"
+ einfo " \$database_password = \"cacti\";"
+ einfo "5. Point your web browser to: http://your-server/cacti/"
+ einfo " Make sure to fill in all of the path variables carefully and"
+ einfo " correctly on the following screen."
+ einfo
+ einfo "FINALLY, you must have these settings in your php.ini:"
+ einfo " register_globals = On"
+ einfo " register_argc_argv = On"
+ einfo
+ fi
+}
diff --git a/net-analyzer/cacti/files/digest-cacti-0.8.5a b/net-analyzer/cacti/files/digest-cacti-0.8.5a
new file mode 100644
index 000000000000..7a5183477ccd
--- /dev/null
+++ b/net-analyzer/cacti/files/digest-cacti-0.8.5a
@@ -0,0 +1 @@
+MD5 2b9ef4194664d65b86cdcc9a0f126609 cacti-0.8.5a.tar.gz 986785