summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLance Albertson <ramereth@gentoo.org>2005-09-09 21:32:35 +0000
committerLance Albertson <ramereth@gentoo.org>2005-09-09 21:32:35 +0000
commit9e52daaeae5c71b1058bfd818256e11760c2c71e (patch)
tree719c0bf19ed9a2bf30ec802a061ec63a225ed8af /net-analyzer/cacti
parentno-herd instead of empty herd tag (diff)
downloadhistorical-9e52daaeae5c71b1058bfd818256e11760c2c71e.tar.gz
historical-9e52daaeae5c71b1058bfd818256e11760c2c71e.tar.bz2
historical-9e52daaeae5c71b1058bfd818256e11760c2c71e.zip
Fixed php DEPEND to use virtuals per bug #102827
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'net-analyzer/cacti')
-rw-r--r--net-analyzer/cacti/ChangeLog8
-rw-r--r--net-analyzer/cacti/cacti-0.8.6f-r2.ebuild70
-rw-r--r--net-analyzer/cacti/files/digest-cacti-0.8.6f-r212
3 files changed, 89 insertions, 1 deletions
diff --git a/net-analyzer/cacti/ChangeLog b/net-analyzer/cacti/ChangeLog
index 318b7ba9e2c2..f9de1a7aba00 100644
--- a/net-analyzer/cacti/ChangeLog
+++ b/net-analyzer/cacti/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/cacti
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/ChangeLog,v 1.52 2005/08/03 13:33:28 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/ChangeLog,v 1.53 2005/09/09 21:32:35 ramereth Exp $
+
+*cacti-0.8.6f-r2 (09 Sep 2005)
+
+ 09 Sep 2005; Lance Albertson <ramereth@gentoo.org>
+ +cacti-0.8.6f-r2.ebuild:
+ * Fixed php DEPEND to use virtuals per bug #102827
03 Aug 2005; Gustavo Zacarias <gustavoz@gentoo.org>
cacti-0.8.6f-r1.ebuild:
diff --git a/net-analyzer/cacti/cacti-0.8.6f-r2.ebuild b/net-analyzer/cacti/cacti-0.8.6f-r2.ebuild
new file mode 100644
index 000000000000..50c923b5890a
--- /dev/null
+++ b/net-analyzer/cacti/cacti-0.8.6f-r2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/cacti-0.8.6f-r2.ebuild,v 1.1 2005/09/09 21:32:35 ramereth Exp $
+
+inherit eutils webapp
+
+DESCRIPTION="Cacti is a complete frontend to rrdtool"
+HOMEPAGE="http://www.cacti.net/"
+# patches as of end of July
+UPSTREAM_PATCHES="html_mouseover_title.patch multi_field_output_script_server.patch old_net_snmp_command_options.patch poller_invalid_data_sources.patch script_server_buffer_size.patch unix_syslog_compatibility.patch graph_view_preview_mode_filter.patch poller_reindex_cache_orphans.patch safari_zoom.patch ldap_copy_user_problem.patch script_server_file_header.patch"
+SRC_URI="http://www.cacti.net/downloads/${P}.tar.gz"
+for i in $UPSTREAM_PATCHES ; do
+ SRC_URI="${SRC_URI} http://www.cacti.net/downloads/patches/${PV}/${i}"
+done
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="snmp"
+
+DEPEND=""
+
+# TODO: RDEPEND Not just apache... but there's no virtual/webserver (yet)
+
+RDEPEND="net-www/apache
+ snmp? ( net-analyzer/net-snmp )
+ net-analyzer/rrdtool
+ dev-db/mysql
+ virtual/cron
+ virtual/php
+ virtual/httpd-php"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ for i in ${UPSTREAM_PATCHES} ; do
+ EPATCH_OPTS="-p1 -d ${S} -N" epatch ${DISTDIR}/${i}
+ done ;
+}
+
+pkg_setup() {
+ webapp_pkg_setup
+ built_with_use virtual/php mysql || \
+ die "php cli sapi must be compiled with USE=mysql"
+ built_with_use virtual/httpd-php mysql || \
+ die "php apache/cgi sapi must be compiled with USE=mysql"
+}
+
+src_compile() {
+ einfo "Nothing to compile."
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc LICENSE
+ rm LICENSE README
+
+ dodoc docs/{CHANGELOG,CONTRIB,INSTALL,README,REQUIREMENTS,UPGRADE}
+ rm -rf docs
+
+ edos2unix `find -type f -name '*.php'`
+
+ dodir ${MY_HTDOCSDIR}
+ cp -r . ${D}${MY_HTDOCSDIR}
+
+ webapp_configfile ${MY_HTDOCSDIR}/include/config.php
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
+
+ webapp_src_install
+}
+
diff --git a/net-analyzer/cacti/files/digest-cacti-0.8.6f-r2 b/net-analyzer/cacti/files/digest-cacti-0.8.6f-r2
new file mode 100644
index 000000000000..6dc2c2df5183
--- /dev/null
+++ b/net-analyzer/cacti/files/digest-cacti-0.8.6f-r2
@@ -0,0 +1,12 @@
+MD5 032b8b22225f137e2a2294e89a2af2ec cacti-0.8.6f.tar.gz 1062562
+MD5 2354e383adff58725077e95ba8584dba html_mouseover_title.patch 2757
+MD5 c1b8c9d36ff5f4b11f27af8240b6ed42 multi_field_output_script_server.patch 2407
+MD5 75f7f8c59591663dd63f91830fcdb1f1 old_net_snmp_command_options.patch 1124
+MD5 5bdd1c9e4ef4479fafe73ce32e1f43b8 poller_invalid_data_sources.patch 4752
+MD5 5711e9d5f90397ac8f26c7af55d49d12 script_server_buffer_size.patch 1541
+MD5 55c1b16ebe40ea017db8d905de763ce8 unix_syslog_compatibility.patch 703
+MD5 88a34475132b77112910738a3139c01d graph_view_preview_mode_filter.patch 448
+MD5 2afd2acbd1e1b0bf4809996976620c0a poller_reindex_cache_orphans.patch 1054
+MD5 fc5579772103ed98557661866b632997 safari_zoom.patch 1274
+MD5 fe7d23776d828941fc56f72797903f3e ldap_copy_user_problem.patch 2213
+MD5 8598d1419ab589704a79986dd184756c script_server_file_header.patch 264