summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2007-01-28 14:25:12 +0000
committerPeter Volkov <pva@gentoo.org>2007-01-28 14:25:12 +0000
commit47eedad2077707534b388f695e42089b10f2dfc0 (patch)
tree3936bc27595a3d59d634919358ef888b2ad02340 /net-analyzer/cacti
parentVarious fixes (diff)
downloadhistorical-47eedad2077707534b388f695e42089b10f2dfc0.tar.gz
historical-47eedad2077707534b388f695e42089b10f2dfc0.tar.bz2
historical-47eedad2077707534b388f695e42089b10f2dfc0.zip
Upstream released ping_php_version4_snmpgetnext and tree_console_missing_hosts patches. Thank Hans Rakers <hans AT parse.nl> for report about ping problem in bug #159278.
Package-Manager: portage-2.1.1-r2
Diffstat (limited to 'net-analyzer/cacti')
-rw-r--r--net-analyzer/cacti/ChangeLog10
-rw-r--r--net-analyzer/cacti/cacti-0.8.6j-r1.ebuild90
-rw-r--r--net-analyzer/cacti/files/digest-cacti-0.8.6j-r19
3 files changed, 108 insertions, 1 deletions
diff --git a/net-analyzer/cacti/ChangeLog b/net-analyzer/cacti/ChangeLog
index 3100075aec5f..513d4e72d208 100644
--- a/net-analyzer/cacti/ChangeLog
+++ b/net-analyzer/cacti/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-analyzer/cacti
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/ChangeLog,v 1.86 2007/01/26 19:04:57 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/ChangeLog,v 1.87 2007/01/28 14:25:12 pva Exp $
+
+*cacti-0.8.6j-r1 (28 Jan 2007)
+
+ 28 Jan 2007; <pva@gentoo.org> -cacti-0.8.6j.ebuild,
+ +cacti-0.8.6j-r1.ebuild:
+ Upstream released ping_php_version4_snmpgetnext and
+ tree_console_missing_hosts patches. Thank Hans Rakers <hans AT parse.nl> for
+ report about ping problem in bug #159278.
26 Jan 2007; <pva@gentoo.org> -cacti-0.8.6h_p20060108-r2.ebuild,
-cacti-0.8.6i.ebuild:
diff --git a/net-analyzer/cacti/cacti-0.8.6j-r1.ebuild b/net-analyzer/cacti/cacti-0.8.6j-r1.ebuild
new file mode 100644
index 000000000000..293649c88f52
--- /dev/null
+++ b/net-analyzer/cacti/cacti-0.8.6j-r1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/cacti-0.8.6j-r1.ebuild,v 1.1 2007/01/28 14:25:12 pva Exp $
+
+inherit eutils webapp depend.apache depend.php
+
+# Support for _p* in version.
+MY_P=${P/_p*/}
+HAS_PATCHES=1
+
+DESCRIPTION="Cacti is a complete frontend to rrdtool"
+HOMEPAGE="http://www.cacti.net/"
+SRC_URI="http://www.cacti.net/downloads/${MY_P}.tar.gz"
+
+# patches
+if [ $HAS_PATCHES == 1 ] ; then
+ UPSTREAM_PATCHES="ping_php_version4_snmpgetnext
+ tree_console_missing_hosts"
+ for i in $UPSTREAM_PATCHES ; do
+ SRC_URI="${SRC_URI} http://www.cacti.net/downloads/patches/${PV/_p*}/${i}.patch"
+ done
+fi
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="snmp"
+
+DEPEND=""
+
+want_apache
+need_php_cli
+need_php_httpd
+
+# alpha doesn't have lighttpd keyworded yet
+# sparc doesn't have a stable keyword for lighttpd yet
+RDEPEND="!alpha? ( !sparc? ( !apache? ( !apache2? ( www-servers/lighttpd ) ) ) )
+ snmp? ( net-analyzer/net-snmp )
+ net-analyzer/rrdtool
+ virtual/mysql
+ virtual/cron"
+
+src_unpack() {
+ if [ $HAS_PATCHES == 1 ] ; then
+ unpack ${MY_P}.tar.gz
+ [ ! ${MY_P} == ${P} ] && mv ${MY_P} ${P}
+ # patches
+ for i in ${UPSTREAM_PATCHES} ; do
+ EPATCH_OPTS="-p1 -d ${S} -N" epatch "${DISTDIR}"/${i}.patch
+ done ;
+ else
+ unpack ${MY_P}.tar.gz
+ fi
+}
+
+pkg_setup() {
+ webapp_pkg_setup
+ has_php
+ if [ $PHP_VERSION = 5 ] ; then
+ require_php_with_use cli mysql xml
+ elif [ $PHP_VERSION = 4 ] ; then
+ require_php_with_use cli mysql xml expat
+ fi
+}
+
+src_compile() {
+ einfo "Nothing to compile."
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc LICENSE
+ rm LICENSE README
+
+ dodoc docs/{CHANGELOG,CONTRIB,INSTALL,README,REQUIREMENTS,UPGRADE}
+ rm -rf docs
+
+ edos2unix `find -type f -name '*.php'`
+
+ dodir ${MY_HTDOCSDIR}
+ cp -r . "${D}"${MY_HTDOCSDIR}
+
+ webapp_serverowned ${MY_HTDOCSDIR}/rra
+ webapp_serverowned ${MY_HTDOCSDIR}/log/cacti.log
+ webapp_configfile ${MY_HTDOCSDIR}/include/config.php
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}
+
diff --git a/net-analyzer/cacti/files/digest-cacti-0.8.6j-r1 b/net-analyzer/cacti/files/digest-cacti-0.8.6j-r1
new file mode 100644
index 000000000000..b5a0fb6ce505
--- /dev/null
+++ b/net-analyzer/cacti/files/digest-cacti-0.8.6j-r1
@@ -0,0 +1,9 @@
+MD5 29436be46b289d13dfce48e7618129e2 cacti-0.8.6j.tar.gz 1126337
+RMD160 981d24753d440af1d3fcfdb20cd988f73fcc44fe cacti-0.8.6j.tar.gz 1126337
+SHA256 0ddf8a740a5725de67eeea71c38433447ff75388e6e399ce92ccadc36d25bd46 cacti-0.8.6j.tar.gz 1126337
+MD5 bedf583646e59dd628d4aced7e83fdf3 ping_php_version4_snmpgetnext.patch 1262
+RMD160 94882973199b8e59c40ad43a132548862654f312 ping_php_version4_snmpgetnext.patch 1262
+SHA256 1e19110c696eb56c6de68247c926c5ec7a2e7554df222f39a663556241644170 ping_php_version4_snmpgetnext.patch 1262
+MD5 109afedcd49dc173da8c27fb23c322fe tree_console_missing_hosts.patch 771
+RMD160 d33f3916317e989b379d1188f3ed23b7d61a7a9e tree_console_missing_hosts.patch 771
+SHA256 5807bb408227b1c9f2ebecf220c048eb7c7148eee41fcd06fdc086124a206180 tree_console_missing_hosts.patch 771