summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2007-06-08 11:47:35 +0000
committerPeter Volkov <pva@gentoo.org>2007-06-08 11:47:35 +0000
commite98ff60686767171a249cc9f19524095c289f618 (patch)
tree08c1d23eb411e1c3ff4675da0c8925dcfc4e20b4 /net-analyzer/cacti/cacti-0.8.6j-r6.ebuild
parentSwap one line in the init script, thanks to Jörg Eitemüller <destotelhorus ... (diff)
downloadhistorical-e98ff60686767171a249cc9f19524095c289f618.tar.gz
historical-e98ff60686767171a249cc9f19524095c289f618.tar.bz2
historical-e98ff60686767171a249cc9f19524095c289f618.zip
Call require_php_with_use only once. Thank armin76 for the fix.
Package-Manager: portage-2.1.2.9
Diffstat (limited to 'net-analyzer/cacti/cacti-0.8.6j-r6.ebuild')
-rw-r--r--net-analyzer/cacti/cacti-0.8.6j-r6.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/net-analyzer/cacti/cacti-0.8.6j-r6.ebuild b/net-analyzer/cacti/cacti-0.8.6j-r6.ebuild
index a2c77bea0794..d3b9a0240e33 100644
--- a/net-analyzer/cacti/cacti-0.8.6j-r6.ebuild
+++ b/net-analyzer/cacti/cacti-0.8.6j-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/cacti-0.8.6j-r6.ebuild,v 1.3 2007/06/07 13:47:24 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/cacti-0.8.6j-r6.ebuild,v 1.4 2007/06/08 11:47:35 pva Exp $
inherit eutils webapp depend.apache depend.php
@@ -64,11 +64,12 @@ pkg_setup() {
webapp_pkg_setup
has_php
if [ $PHP_VERSION = 5 ] ; then
- require_php_with_use cli mysql xml
+ phpUseFlags="cli mysql xml"
elif [ $PHP_VERSION = 4 ] ; then
- require_php_with_use cli mysql xml expat
+ phpUseFlags="cli mysql xml expat"
fi
- use bundled-adodb || require_php_with_use sockets
+ use bundled-adodb || phpUseFlags="${phpUseFlags} sockets"
+ require_php_with_use ${phpUseFlags}
}
src_compile() {