summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLance Albertson <ramereth@gentoo.org>2005-05-01 22:16:56 +0000
committerLance Albertson <ramereth@gentoo.org>2005-05-01 22:16:56 +0000
commitde83e6865cfb62b78521d99a592fbe71b498fb27 (patch)
tree5e00eefaa7257759cdbeba0397012e796332fdf8 /net-analyzer/cacti-cactid
parentrepoman: Trim trailing whitespace (diff)
downloadhistorical-de83e6865cfb62b78521d99a592fbe71b498fb27.tar.gz
historical-de83e6865cfb62b78521d99a592fbe71b498fb27.tar.bz2
historical-de83e6865cfb62b78521d99a592fbe71b498fb27.zip
conf file fix from #90662
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'net-analyzer/cacti-cactid')
-rw-r--r--net-analyzer/cacti-cactid/ChangeLog8
-rw-r--r--net-analyzer/cacti-cactid/Manifest4
-rw-r--r--net-analyzer/cacti-cactid/cacti-cactid-0.8.6d-r1.ebuild48
-rw-r--r--net-analyzer/cacti-cactid/files/digest-cacti-cactid-0.8.6d-r11
4 files changed, 59 insertions, 2 deletions
diff --git a/net-analyzer/cacti-cactid/ChangeLog b/net-analyzer/cacti-cactid/ChangeLog
index 49b720034733..946f051f0b9f 100644
--- a/net-analyzer/cacti-cactid/ChangeLog
+++ b/net-analyzer/cacti-cactid/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/cacti-cactid
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti-cactid/ChangeLog,v 1.2 2005/04/10 00:32:19 ramereth Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti-cactid/ChangeLog,v 1.3 2005/05/01 22:16:56 ramereth Exp $
+
+*cacti-cactid-0.8.6d-r1 (01 May 2005)
+
+ 01 May 2005; Lance Albertson <ramereth@gentoo.org>
+ +cacti-cactid-0.8.6d-r1.ebuild:
+ conf file fix from #90662
*cacti-cactid-0.8.6d (10 Apr 2005)
diff --git a/net-analyzer/cacti-cactid/Manifest b/net-analyzer/cacti-cactid/Manifest
index 59968d57edee..cd5d3474d493 100644
--- a/net-analyzer/cacti-cactid/Manifest
+++ b/net-analyzer/cacti-cactid/Manifest
@@ -1,6 +1,8 @@
MD5 4079294855ad6943cef50a6be12cbdc8 cacti-cactid-0.8.6c.ebuild 1238
MD5 528bed3e0527d5e490f39fdd9c98daa6 metadata.xml 682
-MD5 eaa8da68787877092ab1161d393399f8 ChangeLog 564
+MD5 f7e80aafdfbf7fbc00528de7fcd8063b ChangeLog 719
MD5 e41ba3e1ab178f3d9c9c7e11af355a93 cacti-cactid-0.8.6d.ebuild 1231
+MD5 cb1eaa977fc0c68b5a37124cdad8dd3b cacti-cactid-0.8.6d-r1.ebuild 1396
MD5 ffd8c4a7927d055eacd63bdbdb0d2308 files/digest-cacti-cactid-0.8.6c 71
MD5 612a831c92034aceeb7afa0d6275c06e files/digest-cacti-cactid-0.8.6d 71
+MD5 612a831c92034aceeb7afa0d6275c06e files/digest-cacti-cactid-0.8.6d-r1 71
diff --git a/net-analyzer/cacti-cactid/cacti-cactid-0.8.6d-r1.ebuild b/net-analyzer/cacti-cactid/cacti-cactid-0.8.6d-r1.ebuild
new file mode 100644
index 000000000000..a4e3bbefa528
--- /dev/null
+++ b/net-analyzer/cacti-cactid/cacti-cactid-0.8.6d-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti-cactid/cacti-cactid-0.8.6d-r1.ebuild,v 1.1 2005/05/01 22:16:56 ramereth Exp $
+
+DESCRIPTION="Cactid is a poller for Cacti that primarily strives to be as fast
+as possible"
+HOMEPAGE="http://cacti.net/cactid_info.php"
+SRC_URI="http://www.cacti.net/downloads/cactid/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="net-analyzer/net-snmp
+ net-analyzer/rrdtool
+ dev-db/mysql
+ sys-devel/autoconf"
+RDEPEND="net-analyzer/cacti"
+
+src_unpack() {
+ unpack ${A} ; cd ${S}
+ sed -i -e 's/^bin_PROGRAMS/sbin_PROGRAMS/' Makefile.am
+ sed -i -e 's/mysqlclient/mysqlclient_r/g' configure.ac
+ sed -i -e 's/wwwroot\/cacti\/log/var\/log/g' cactid.h
+}
+
+src_compile() {
+ WANT_AUTOCONF=2.53
+ aclocal || die "aclocal failed"
+ autoconf || die "autoconf failed"
+ econf || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ exeinto usr/sbin ; doexe ${S}/cactid
+ insinto etc/ ; insopts -m0640 -o root -g apache ; doins ${S}/cactid.conf
+ dodoc CHANGELOG INSTALL README
+}
+
+pkg_postinst() {
+ einfo "Please see cacti's site for installation instructions."
+ einfo "Theres no need to change the crontab for this, just"
+ einfo "read the instructions on how to implement it"
+ einfo ""
+ einfo "http://cacti.net/cactid_install.php"
+}
diff --git a/net-analyzer/cacti-cactid/files/digest-cacti-cactid-0.8.6d-r1 b/net-analyzer/cacti-cactid/files/digest-cacti-cactid-0.8.6d-r1
new file mode 100644
index 000000000000..e9ed38be0cb2
--- /dev/null
+++ b/net-analyzer/cacti-cactid/files/digest-cacti-cactid-0.8.6d-r1
@@ -0,0 +1 @@
+MD5 8fbd96cbe73af9cd3a7dc2e5de1f0a92 cacti-cactid-0.8.6d.tar.gz 115333