summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-05-30 13:20:45 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-05-30 13:20:45 +0000
commit4acc04241b07d63a004b82af25872e4c45d79276 (patch)
tree6ff0bcdf2d9e9fcfd46ad5ececfa6809be2f03e2 /media-video
parentUpdated gtkhx to newest version (diff)
downloadhistorical-4acc04241b07d63a004b82af25872e4c45d79276.tar.gz
historical-4acc04241b07d63a004b82af25872e4c45d79276.tar.bz2
historical-4acc04241b07d63a004b82af25872e4c45d79276.zip
fix build problems if avifile and dvdread are not used
Diffstat (limited to 'media-video')
-rw-r--r--media-video/transcode/ChangeLog9
-rw-r--r--media-video/transcode/files/digest-transcode-0.6.0_pre5-r21
-rw-r--r--media-video/transcode/transcode-0.6.0_pre5-r2.ebuild96
3 files changed, 105 insertions, 1 deletions
diff --git a/media-video/transcode/ChangeLog b/media-video/transcode/ChangeLog
index 09029cc5984c..0494d4d7c95c 100644
--- a/media-video/transcode/ChangeLog
+++ b/media-video/transcode/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-video/transcode
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-video/transcode/ChangeLog,v 1.7 2002/05/26 18:16:55 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/transcode/ChangeLog,v 1.8 2002/05/30 13:20:45 azarah Exp $
+
+*transcode-0.6.0_pre5-r2 (29 May 2002)
+
+ 29 May 2002; Martin Schlemmer <azarah@gentoo.org> :
+
+ Seems as if to not want to build without avifile and dvdread
+ currently.
*transcode-0.6.0_pre5-r1 (26 May 2002)
diff --git a/media-video/transcode/files/digest-transcode-0.6.0_pre5-r2 b/media-video/transcode/files/digest-transcode-0.6.0_pre5-r2
new file mode 100644
index 000000000000..0553a057e068
--- /dev/null
+++ b/media-video/transcode/files/digest-transcode-0.6.0_pre5-r2
@@ -0,0 +1 @@
+MD5 f791b1aac090312459e3e9cec2d1fd6e transcode-0.6.0pre5.tgz 2042189
diff --git a/media-video/transcode/transcode-0.6.0_pre5-r2.ebuild b/media-video/transcode/transcode-0.6.0_pre5-r2.ebuild
new file mode 100644
index 000000000000..0dc4c598b07c
--- /dev/null
+++ b/media-video/transcode/transcode-0.6.0_pre5-r2.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Dan Armak <danarmak@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-video/transcode/transcode-0.6.0_pre5-r2.ebuild,v 1.1 2002/05/30 13:20:45 azarah Exp $
+
+MY_P=${P/_/}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="video stream processing tool"
+SRC_URI="http://www.theorie.physik.uni-goettingen.de/~ostreich/transcode/pre/${MY_P}.tgz"
+HOMEPAGE="http://www.theorie.physik.uni-goettingen.de/~ostreich/transcode"
+
+# Note: transcode can use pretty much any media-related package ever written as
+# a plugin. An exhaustive dep list would make me add about 20-30 packages to
+# portage. perhaps another time :-)
+
+DEPEND=">=media-libs/a52dec-0.7.3
+ media-libs/libdv
+ media-libs/libsdl
+ dev-lang/nasm
+ =x11-libs/gtk+-1.2*
+ X? ( virtual/x11 )
+ avi? ( >=media-video/avifile-0.7.4 )
+ dvd? ( media-libs/libdvdread )
+ mpeg? ( media-libs/libmpeg3 )
+ encode? ( >=media-sound/lame-3.89 )
+ quicktime? ( media-libs/quicktime4linux )
+ >=media-video/avifile-0.7.4
+ media-libs/libdvdread"
+# Dont want to build without these currently
+# avi? ( >=media-video/avifile-0.7.4 )
+# dvd? ( media-libs/libdvdread )"
+
+src_unpack() {
+ unpack ${A}
+
+ [ -z "${CC}" ] && CC="gcc"
+ if [ "`${CC} --version | cut -f1 -d.`" = "3" ];
+ then
+ patch -p0 < ${FILESDIR}/${P}.diff || die
+ fi
+}
+
+src_compile() {
+
+ # fix invalid paths in .la files of plugins
+ libtoolize --copy --force
+
+ local myconf=""
+
+ use mmx \
+ && myconf="${myconf} --enable-mmx"
+ use mmx || ( use 3dnow || use sse ) \
+ || myconf="${myconf} --disable-mmx"
+ # Dont disable mmx if 3dnow or sse are requested.
+
+ use sse \
+ && myconf="${myconf} --enable-sse" \
+ || myconf="${myconf} --disable-sse"
+
+# use avi \
+# && myconf="${myconf} --enable-avifile6" \
+# || myconf="${myconf} --disable-avifile6"
+#
+# use dvd \
+# && myconf="${myconf} --enable-dvdread" \
+# || myconf="${myconf} --disable-dvdread"
+# Dont currently want to build without these
+ myconf="${myconf} --enable-dvdread --enable-avifile6"
+ use encode \
+ && myconf="${myconf} --with-lame" \
+ || myconf="${myconf} --without-lame"
+
+ use mpeg \
+ && myconf="${myconf} --with-libmpeg3" \
+ || myconf="${myconf} --without-libmpeg3"
+
+ use quicktime \
+ || myconf="${myconf} --without-qt --without-openqt"
+
+ use X \
+ && myconf="${myconf} --enable-x" \
+ || myconf="${myconf} --disable-x"
+
+ econf ${myconf} || die
+
+ emake all || die
+
+}
+
+src_install () {
+
+ make \
+ DESTDIR=${D} \
+ install || die
+}
+