summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2004-02-23 08:02:12 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2004-02-23 08:02:12 +0000
commit4a214a7d1d185610d136925476634cb264e836c0 (patch)
treeb1b6fa841ea649beae61cf9236fb5f2dbb4d67ab /media-video
parentneeds ewl #42551 (diff)
downloadhistorical-4a214a7d1d185610d136925476634cb264e836c0.tar.gz
historical-4a214a7d1d185610d136925476634cb264e836c0.tar.bz2
historical-4a214a7d1d185610d136925476634cb264e836c0.zip
Initial import, see bug 38021
Diffstat (limited to 'media-video')
-rw-r--r--media-video/spca50x/ChangeLog10
-rw-r--r--media-video/spca50x/Manifest5
-rw-r--r--media-video/spca50x/files/digest-spca50x-0.301
-rw-r--r--media-video/spca50x/files/spca50x-0.30-gentoo.patch11
-rw-r--r--media-video/spca50x/metadata.xml8
-rw-r--r--media-video/spca50x/spca50x-0.30.ebuild47
6 files changed, 82 insertions, 0 deletions
diff --git a/media-video/spca50x/ChangeLog b/media-video/spca50x/ChangeLog
new file mode 100644
index 000000000000..862d33ce4111
--- /dev/null
+++ b/media-video/spca50x/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for media-video/spca50x
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/spca50x/ChangeLog,v 1.1 2004/02/23 08:02:12 phosphan Exp $
+
+*spca50x-0.30 (23 Feb 2004)
+
+ 23 Feb 2004; Patrick Kursawe <phosphan@gentoo.org> metadata.xml,
+ spca50x-0.30.ebuild, files/spca50x-0.30-gentoo.patch:
+ Initial import, see bug #38021
+
diff --git a/media-video/spca50x/Manifest b/media-video/spca50x/Manifest
new file mode 100644
index 000000000000..6aaba72f5aab
--- /dev/null
+++ b/media-video/spca50x/Manifest
@@ -0,0 +1,5 @@
+MD5 ebf92858e7cc8509921736dae501f802 ChangeLog 408
+MD5 5ef11878179d451985ee7157a416c27e metadata.xml 222
+MD5 3d8132d16187eaea014865e7210fab0c spca50x-0.30.ebuild 1111
+MD5 1232527e39e754c862301ea81cf447fd files/spca50x-0.30-gentoo.patch 354
+MD5 a6035d449aa7f7e634a4895a657a1557 files/digest-spca50x-0.30 67
diff --git a/media-video/spca50x/files/digest-spca50x-0.30 b/media-video/spca50x/files/digest-spca50x-0.30
new file mode 100644
index 000000000000..6a9f3e949047
--- /dev/null
+++ b/media-video/spca50x/files/digest-spca50x-0.30
@@ -0,0 +1 @@
+MD5 6b61dfa0794880bdaeb731b5da99966e spca50x-src-0.30.tar.gz 74320
diff --git a/media-video/spca50x/files/spca50x-0.30-gentoo.patch b/media-video/spca50x/files/spca50x-0.30-gentoo.patch
new file mode 100644
index 000000000000..93005520f666
--- /dev/null
+++ b/media-video/spca50x/files/spca50x-0.30-gentoo.patch
@@ -0,0 +1,11 @@
+--- Makefile.old 2003-03-08 11:03:17.000000000 -0300
++++ Makefile 2004-01-05 17:15:13.000000000 -0200
+@@ -69,7 +69,7 @@
+ CFLAGS += -I$(KINCLUDE) -Idrivers/usb
+
+ # Setup link flags
+-LDFLAGS = --strip-debug --relocateable
++LDFLAGS = --strip-debug -r
+
+ # Setup the list of files to be included in a distribution
+ DIST_FILES = CHANGELOG \
diff --git a/media-video/spca50x/metadata.xml b/media-video/spca50x/metadata.xml
new file mode 100644
index 000000000000..6e1d55b1eb69
--- /dev/null
+++ b/media-video/spca50x/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>video</herd>
+<maintainer>
+ <email>phosphan@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/media-video/spca50x/spca50x-0.30.ebuild b/media-video/spca50x/spca50x-0.30.ebuild
new file mode 100644
index 000000000000..cf7110fcf61d
--- /dev/null
+++ b/media-video/spca50x/spca50x-0.30.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/spca50x/spca50x-0.30.ebuild,v 1.1 2004/02/23 08:02:12 phosphan Exp $
+
+DESCRIPTION="Linux device driver for SPCA50X based USB cameras"
+HOMEPAGE="http://sourceforge.net/projects/spca50x/"
+SRC_URI="mirror://sourceforge/spca50x/${PN}-src-${PV}.tar.gz"
+
+LICENSE="GPL-1"
+SLOT="0"
+KEYWORDS="-* ~x86"
+IUSE=""
+DEPEND="virtual/glibc
+ virtual/linux-sources"
+
+inherit check-kernel
+
+pkg_setup() {
+ get_KV_info
+ einfo "Linux kernel ${KV_major}.${KV_minor}.${KV_micro}"
+ if is_2_5_kernel || is_2_6_kernel
+ then
+ eerror "This package only works with 2.4 kernels"
+ eerror "Check /usr/src/linux if you _are_ using a 2.4 kernel"
+ die "No compatible kernel detected!"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${P}-gentoo.patch
+}
+
+src_compile(){
+ cd ${WORKDIR}
+ emake || die
+}
+
+src_install() {
+ insinto /lib/modules/${KV}/kernel/drivers/usb
+ doins ${WORKDIR}/spca50x.o
+ dodoc ${WORKDIR}/README
+}
+
+pkg_postinst() {
+ /sbin/modules-update &> /dev/null
+}