summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Goller <morfic@gentoo.org>2004-06-26 01:16:22 +0000
committerDaniel Goller <morfic@gentoo.org>2004-06-26 01:16:22 +0000
commit1826b3d93dec118c534f986487f66262c264a8f3 (patch)
tree04670e8838639337875356e3760c03e598398a67 /media-video
parentLong-overdue revision bump. There may be issues in building w/ gcc-3.4.x, bu... (diff)
downloadhistorical-1826b3d93dec118c534f986487f66262c264a8f3.tar.gz
historical-1826b3d93dec118c534f986487f66262c264a8f3.tar.bz2
historical-1826b3d93dec118c534f986487f66262c264a8f3.zip
Applying 2nd patch to allow compilation with gcc-3.4.0, fixes #49457
Diffstat (limited to 'media-video')
-rw-r--r--media-video/transcode/ChangeLog7
-rw-r--r--media-video/transcode/Manifest5
-rw-r--r--media-video/transcode/files/transcode-0.6.12-gcc-3.4.patch40
-rw-r--r--media-video/transcode/transcode-0.6.12-r1.ebuild19
4 files changed, 62 insertions, 9 deletions
diff --git a/media-video/transcode/ChangeLog b/media-video/transcode/ChangeLog
index dcf4508a770b..e310644aea30 100644
--- a/media-video/transcode/ChangeLog
+++ b/media-video/transcode/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/transcode
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/transcode/ChangeLog,v 1.68 2004/06/25 00:51:14 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/transcode/ChangeLog,v 1.69 2004/06/26 01:16:22 morfic Exp $
+
+ 25 Jun 2004; Daniel Goller <morfic@gentoo.org> transcode-0.6.12-r1.ebuild:
+ Applying 2nd patch to allow compilation on gcc-3.4.0
+ Added patch Thanks to ecco@piggy.demon.nl
+ Fixes Bug #49457
09 Jun 2004; Aron Griffis <agriffis@gentoo.org> transcode-0.6.10.ebuild,
transcode-0.6.11.ebuild, transcode-0.6.12-r1.ebuild,
diff --git a/media-video/transcode/Manifest b/media-video/transcode/Manifest
index 284597045372..d85d763708e0 100644
--- a/media-video/transcode/Manifest
+++ b/media-video/transcode/Manifest
@@ -1,9 +1,10 @@
MD5 352b6e4122a34a8e8adc10f570f8463b transcode-0.6.11.ebuild 3674
MD5 4e3b80eba0e2e1c60cba7d8535f8a146 transcode-0.6.10.ebuild 3766
-MD5 c18f1b41fc496557c149754c06761f57 transcode-0.6.12-r1.ebuild 3446
+MD5 b3d7dfc3b9d8b95d59a083bdc99ca161 transcode-0.6.12-r1.ebuild 3656
MD5 01c1de259f9be1df3ec8d7b595547419 transcode-0.6.12.ebuild 2907
-MD5 4e82899dc3c18ffb1191544afba7673c ChangeLog 12920
+MD5 980fda045d1e0acd0938a71d4159eaef ChangeLog 13115
MD5 7300a7b361fa9f48e37722c6952bd432 metadata.xml 158
+MD5 b2561dbf66455c878a08afd19868dc5d files/transcode-0.6.12-gcc-3.4.patch 2503
MD5 ef79fbe94405505c11c537e07b25c669 files/digest-transcode-0.6.10 69
MD5 bc1cb5a39d56ce5216c803c74e73545d files/digest-transcode-0.6.11 69
MD5 8fde4803c96e026f6caa94fa0e42687f files/digest-transcode-0.6.12 69
diff --git a/media-video/transcode/files/transcode-0.6.12-gcc-3.4.patch b/media-video/transcode/files/transcode-0.6.12-gcc-3.4.patch
new file mode 100644
index 000000000000..43e1ca8dde34
--- /dev/null
+++ b/media-video/transcode/files/transcode-0.6.12-gcc-3.4.patch
@@ -0,0 +1,40 @@
+diff -ur transcode-0.6.12.orig/ffmpeg/libavcodec/i386/dsputil_mmx.c transcode-0.6.12/ffmpeg/libavcodec/i386/dsputil_mmx.c
+--- transcode-0.6.12.orig/ffmpeg/libavcodec/i386/dsputil_mmx.c 2003-12-30 10:02:10.000000000 +0000
++++ transcode-0.6.12/ffmpeg/libavcodec/i386/dsputil_mmx.c 2004-05-21 19:47:12.808592624 +0000
+@@ -31,8 +31,8 @@
+ static const uint64_t mm_wone __attribute__ ((aligned(8))) = 0x0001000100010001ULL;
+ static const uint64_t mm_wtwo __attribute__ ((aligned(8))) = 0x0002000200020002ULL;
+
+-static const uint64_t ff_pw_20 __attribute__ ((aligned(8))) = 0x0014001400140014ULL;
+-static const uint64_t ff_pw_3 __attribute__ ((aligned(8))) = 0x0003000300030003ULL;
++static const uint64_t ff_pw_20 __attribute__ ((aligned(8), used)) = 0x0014001400140014ULL;
++static const uint64_t ff_pw_3 __attribute__ ((aligned(8), used)) = 0x0003000300030003ULL;
+ static const uint64_t ff_pw_16 __attribute__ ((aligned(8))) = 0x0010001000100010ULL;
+ static const uint64_t ff_pw_15 __attribute__ ((aligned(8))) = 0x000F000F000F000FULL;
+
+diff -ur transcode-0.6.12.orig/ffmpeg/libavcodec/i386/motion_est_mmx.c transcode-0.6.12/ffmpeg/libavcodec/i386/motion_est_mmx.c
+--- transcode-0.6.12.orig/ffmpeg/libavcodec/i386/motion_est_mmx.c 2003-12-30 10:02:10.000000000 +0000
++++ transcode-0.6.12/ffmpeg/libavcodec/i386/motion_est_mmx.c 2004-05-21 19:44:37.969131800 +0000
+@@ -26,7 +26,7 @@
+ 0x0002000200020002ULL,
+ };
+
+-static __attribute__ ((aligned(8), unused)) uint64_t bone= 0x0101010101010101LL;
++static __attribute__ ((aligned(8), used)) uint64_t bone= 0x0101010101010101LL;
+
+ static inline void sad8_mmx(uint8_t *blk1, uint8_t *blk2, int stride, int h)
+ {
+diff -ur transcode-0.6.12.orig/ffmpeg/libavcodec/i386/simple_idct_mmx.c transcode-0.6.12/ffmpeg/libavcodec/i386/simple_idct_mmx.c
+--- transcode-0.6.12.orig/ffmpeg/libavcodec/i386/simple_idct_mmx.c 2003-12-20 11:49:12.000000000 +0000
++++ transcode-0.6.12/ffmpeg/libavcodec/i386/simple_idct_mmx.c 2004-05-21 19:48:06.594415936 +0000
+@@ -45,8 +45,8 @@
+ #define ROW_SHIFT 11
+ #define COL_SHIFT 20 // 6
+
+-static const uint64_t __attribute__((aligned(8))) wm1010= 0xFFFF0000FFFF0000ULL;
+-static const uint64_t __attribute__((aligned(8))) d40000= 0x0000000000040000ULL;
++static const uint64_t __attribute__((aligned(8), used)) wm1010= 0xFFFF0000FFFF0000ULL;
++static const uint64_t __attribute__((aligned(8), used)) d40000= 0x0000000000040000ULL;
+
+ static const int16_t __attribute__((aligned(8))) coeffs[]= {
+ 1<<(ROW_SHIFT-1), 0, 1<<(ROW_SHIFT-1), 0,
diff --git a/media-video/transcode/transcode-0.6.12-r1.ebuild b/media-video/transcode/transcode-0.6.12-r1.ebuild
index b8069d0d1b10..191715c34054 100644
--- a/media-video/transcode/transcode-0.6.12-r1.ebuild
+++ b/media-video/transcode/transcode-0.6.12-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/transcode/transcode-0.6.12-r1.ebuild,v 1.11 2004/06/25 00:51:14 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/transcode/transcode-0.6.12-r1.ebuild,v 1.12 2004/06/26 01:16:22 morfic Exp $
-inherit libtool flag-o-matic eutils
+inherit libtool flag-o-matic eutils gcc
MY_P="${P/_pre/.}"
S=${WORKDIR}/${MY_P}
@@ -38,10 +38,17 @@ DEPEND=">=media-libs/a52dec-0.7.4
theora? ( media-libs/libtheora )"
src_unpack() {
- unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/transcode-gcc34.patch
-
+
+ unpack ${A}
+ cd ${S}
+
+ #apply both patches to compile with gcc-3.4.0 closing bug #49457
+ if [ "`gcc-major-version`" -ge "3" -a "`gcc-minor-version`" -ge "4" ]
+ then
+ epatch ${FILESDIR}/transcode-gcc34.patch
+ epatch ${FILESDIR}/transcode-0.6.12-gcc-3.4.patch
+ fi
+
if has_version '>=media-libs/netpbm-9.13'
then
einfo "New netbpm (>9.12)..."