summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-07-22 23:33:09 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-07-22 23:33:09 +0000
commitb652842620b69e2abc47b9fe3d4458a0e2148709 (patch)
treef1f146385ed5870824fb2509623e4d480afc37ec /media-video/mjpegtools/files
parentold (diff)
downloadhistorical-b652842620b69e2abc47b9fe3d4458a0e2148709.tar.gz
historical-b652842620b69e2abc47b9fe3d4458a0e2148709.tar.bz2
historical-b652842620b69e2abc47b9fe3d4458a0e2148709.zip
old
Package-Manager: portage-2.2_rc33/cvs/Linux x86_64
Diffstat (limited to 'media-video/mjpegtools/files')
-rw-r--r--media-video/mjpegtools/files/mjpegtools-1.9.0_rc1-as-needed.patch21
-rw-r--r--media-video/mjpegtools/files/mjpegtools-1.9.0_rc1-lavrec-memleak.patch78
-rw-r--r--media-video/mjpegtools/files/mjpegtools-1.9.0_rc1-pkg-config.patch12
-rw-r--r--media-video/mjpegtools/files/mjpegtools-1.9.0_rc3-gcc43.patch147
4 files changed, 0 insertions, 258 deletions
diff --git a/media-video/mjpegtools/files/mjpegtools-1.9.0_rc1-as-needed.patch b/media-video/mjpegtools/files/mjpegtools-1.9.0_rc1-as-needed.patch
deleted file mode 100644
index d08ac625cbe6..000000000000
--- a/media-video/mjpegtools/files/mjpegtools-1.9.0_rc1-as-needed.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-diff -ru mjpegtools-1.8.0-orig/lavtools/Makefile.am mjpegtools-1.8.0/lavtools/Makefile.am
---- mjpegtools-1.8.0-orig/lavtools/Makefile.am 2006-08-25 15:09:51.542109878 +0200
-+++ mjpegtools-1.8.0/lavtools/Makefile.am 2006-08-25 15:11:37.920337695 +0200
-@@ -51,10 +51,17 @@
- liblavrec_la_SOURCES = liblavrec.c audiolib.c frequencies.c
- liblavrec_la_CPPFLAGS = $(AM_CPPFLAGS) # so automake doesn't complain about audiolib & frequencies
- liblavrec_la_LDFLAGS = $(LAV_ALL_LIB_OPTS)
-+liblavrec_la_LIBADD = -llavfile -llavjpeg
-+liblavrec_la_DEPENDENCIES = liblavfile.la liblavjpeg.la
-
- liblavplay_la_SOURCES = liblavplay.c audiolib.c
- liblavplay_la_CPPFLAGS = $(AM_CPPFLAGS) $(LIBDV_CFLAGS) $(X_CFLAGS)
- liblavplay_la_LDFLAGS = $(LAV_ALL_LIB_OPTS)
-+liblavplay_la_LIBADD = -llavfile $(SDL_LIBS) -llavjpeg
-+liblavplay_la_DEPENDENCIES = liblavfile.la liblavjpeg.la
-+if HAVE_X
-+ liblavplay_la_LIBADD += $(X_LIBS) -lX11
-+endif
-
- # *********************************************************************
- # The tools themselves
diff --git a/media-video/mjpegtools/files/mjpegtools-1.9.0_rc1-lavrec-memleak.patch b/media-video/mjpegtools/files/mjpegtools-1.9.0_rc1-lavrec-memleak.patch
deleted file mode 100644
index 47705044ebdb..000000000000
--- a/media-video/mjpegtools/files/mjpegtools-1.9.0_rc1-lavrec-memleak.patch
+++ /dev/null
@@ -1,78 +0,0 @@
---- mjpegtools-1.8.0/lavtools/lav_io.c 2005-08-27 13:47:20.000000000 +0200
-+++ mjpegtools-1.8.0___fixed/lavtools/lav_io.c 2006-05-14 05:45:48.000000000 +0200
-@@ -540,15 +540,12 @@
-
- int lav_write_audio(lav_file_t *lav_file, uint8_t *buff, long samps)
- {
-- int res;
-+ int res = -1;
- #ifdef HAVE_LIBQUICKTIME
- int i, j;
-- int16_t *qt_audio = (int16_t *)buff, **qt_audion;
-+ int16_t *buff16 = (int16_t *)buff, **qt_audion;
- int channels = lav_audio_channels(lav_file);
--
-- qt_audion = malloc(channels * sizeof (int16_t **));
-- for (i = 0; i < channels; i++)
-- qt_audion[i] = (int16_t *)malloc(samps * lav_file->bps);
-+ int bits = lav_audio_bits(lav_file);
- #endif
-
- video_format = lav_file->format; internal_error = 0; /* for error messages */
-@@ -557,24 +554,43 @@
- {
- case 'a':
- case 'A':
-- res = AVI_write_audio( lav_file->avi_fd, buff, samps*lav_file->bps);
-+ res = AVI_write_audio(lav_file->avi_fd, buff, samps*lav_file->bps);
- break;
- #ifdef HAVE_LIBQUICKTIME
- case 'q':
-- /* Deinterleave the audio into the two channels. */
-- for (i = 0; i < samps; i++)
-- {
-- for (j = 0; j < channels; j++)
-- qt_audion[j][i] = qt_audio[(channels*i) + j];
-- }
-- res = lqt_encode_audio_track(lav_file->qt_fd, qt_audion, NULL,samps,0);
-- for (j = 0; j < channels; j++)
-- free(qt_audion[j]);
-- free(qt_audion);
-- break;
-+ if (bits != 16 || channels > 1)
-+ {
-+ /* Deinterleave the audio into the two channels and/or convert
-+ * bits per sample to the required format.
-+ */
-+ qt_audion = malloc(channels * sizeof(*qt_audion));
-+ for (i = 0; i < channels; i++)
-+ qt_audion[i] = malloc(samps * sizeof(**qt_audion));
-+
-+ if (bits == 16)
-+ for (i = 0; i < samps; i++)
-+ for (j = 0; j < channels; j++)
-+ qt_audion[j][i] = buff16[channels * i + j];
-+ else
-+ if (bits == 8)
-+ for (i = 0; i < samps; i++)
-+ for (j = 0; j < channels; j++)
-+ qt_audion[j][i] = ((int16_t)(buff[channels * i + j]) << 8) ^ 0x8000;
-+
-+ if (bits == 8 || bits == 16)
-+ res = lqt_encode_audio_track(lav_file->qt_fd, qt_audion, NULL, samps, 0);
-+
-+ for (i = 0; i < channels; i++)
-+ free(qt_audion[i]);
-+ free(qt_audion);
-+ } else {
-+ qt_audion = &buff16;
-+ res = lqt_encode_audio_track(lav_file->qt_fd, qt_audion, NULL, samps, 0);
-+ }
-+ break;
- #endif
- default:
-- res = -1;
-+ break;
- }
-
- return res;
diff --git a/media-video/mjpegtools/files/mjpegtools-1.9.0_rc1-pkg-config.patch b/media-video/mjpegtools/files/mjpegtools-1.9.0_rc1-pkg-config.patch
deleted file mode 100644
index 512206ce060f..000000000000
--- a/media-video/mjpegtools/files/mjpegtools-1.9.0_rc1-pkg-config.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -ru mjpegtools-1.8.0-orig/configure.ac mjpegtools-1.8.0/configure.ac
---- mjpegtools-1.8.0-orig/configure.ac 2006-08-20 20:39:40.719351212 +0200
-+++ mjpegtools-1.8.0/configure.ac 2006-08-20 20:20:43.652651808 +0200
-@@ -233,6 +233,8 @@
- AC_SUBST(JPEG_LIBS)
- AC_SUBST(JPEG_CFLAGS)
-
-+PKG_PROG_PKG_CONFIG
-+
- have_libquicktime=false
- if test x$with_libquicktime != xno ; then
- PKG_CHECK_MODULES(LIBQUICKTIME, [libquicktime >= 0.9.7],
diff --git a/media-video/mjpegtools/files/mjpegtools-1.9.0_rc3-gcc43.patch b/media-video/mjpegtools/files/mjpegtools-1.9.0_rc3-gcc43.patch
deleted file mode 100644
index ae3fc901d880..000000000000
--- a/media-video/mjpegtools/files/mjpegtools-1.9.0_rc3-gcc43.patch
+++ /dev/null
@@ -1,147 +0,0 @@
-http://bugs.gentoo.org/200767
-http://sourceforge.net/tracker/index.php?func=detail&aid=1947059&group_id=5776&atid=305776
-
---- mjpegtools-1.9.0rc3/mpeg2enc/encodertypes.h
-+++ mjpegtools-1.9.0rc3/mpeg2enc/encodertypes.h
-@@ -25,6 +25,8 @@
- */
-
-
-+#include <stdlib.h>
-+
- class Parity
- {
- public:
---- mjpegtools-1.9.0rc3/mpeg2enc/macroblock.cc
-+++ mjpegtools-1.9.0rc3/mpeg2enc/macroblock.cc
-@@ -21,6 +21,7 @@
-
- #include <stdio.h>
- #include <cassert>
-+#include <limits.h>
-
- #include "macroblock.hh"
- #include "mpeg2syntaxcodes.h"
---- mjpegtools-1.9.0rc3/mpeg2enc/picturereader.cc
-+++ mjpegtools-1.9.0rc3/mpeg2enc/picturereader.cc
-@@ -23,6 +23,7 @@
- #include "picturereader.hh"
- #include "mpeg2encoder.hh"
- #include "imageplanes.hh"
-+#include <limits.h>
- //#include <stdio.h>
- //#include <stdlib.h>
- //#include <unistd.h>
---- mjpegtools-1.9.0rc3/mplex/inputstrm.cpp
-+++ mjpegtools-1.9.0rc3/mplex/inputstrm.cpp
-@@ -23,6 +23,7 @@
-
- #include <config.h>
- #include <assert.h>
-+#include <limits.h>
-
- #include "mjpeg_types.h"
- #include "inputstrm.hpp"
---- mjpegtools-1.9.0rc3/mplex/padstrm.cpp
-+++ mjpegtools-1.9.0rc3/mplex/padstrm.cpp
-@@ -24,6 +24,7 @@
- #include "config.h"
- #endif
-
-+#include <string.h>
- #include "padstrm.hpp"
-
-
---- mjpegtools-1.9.0rc3/mplex/multiplexor.cpp
-+++ mjpegtools-1.9.0rc3/mplex/multiplexor.cpp
-@@ -22,6 +22,7 @@
- #include <config.h>
- #include <math.h>
- #include <stdlib.h>
-+#include <string.h>
-
- #include <mjpeg_types.h>
- #include <mjpeg_logging.h>
---- mjpegtools-1.9.0rc3/mplex/main.cpp
-+++ mjpegtools-1.9.0rc3/mplex/main.cpp
-@@ -31,6 +31,7 @@
- #include <getopt.h>
- #endif
- #include <string>
-+#include <string.h>
- #include <memory>
- #include <sys/stat.h>
- #ifndef _WIN32
---- mjpegtools-1.9.0rc3/y4mdenoise/Set.hh
-+++ mjpegtools-1.9.0rc3/y4mdenoise/Set.hh
-@@ -23,7 +23,7 @@
- // How we implement ourselves.
-
- public:
-- typedef typename Imp::Allocator Allocator;
-+ typedef typename Imp::Allocator_t Allocator;
- // The type of allocator to use to allocate items in the set.
-
- Set (const PRED &a_rPred = PRED(),
---- mjpegtools-1.9.0rc3/y4mdenoise/SkipList.hh
-+++ mjpegtools-1.9.0rc3/y4mdenoise/SkipList.hh
-@@ -57,19 +57,19 @@
- // Will give good sorting for up to e^10 items.
-
- public:
-- typedef Allocator<Node,HEADERCHUNK> Allocator;
-+ typedef Allocator<Node,HEADERCHUNK> Allocator_t;
- // The type of node allocator to use.
-
-- static Allocator sm_oNodeAllocator;
-+ static Allocator_t sm_oNodeAllocator;
- // The default node allocator.
-
- SkipList (const PRED &a_rPred = PRED(),
-- Allocator &a_rAlloc = sm_oNodeAllocator);
-+ Allocator_t &a_rAlloc = sm_oNodeAllocator);
- // Default constructor. Must be followed by Init().
-
- SkipList (Status_t &a_reStatus, bool a_bAllowDuplicates,
- uint32_t a_nRandSeed, const PRED &a_rPred = PRED(),
-- Allocator &a_rAlloc = sm_oNodeAllocator);
-+ Allocator_t &a_rAlloc = sm_oNodeAllocator);
- // Constructor. Specify whether or not duplicates are allowed,
- // and provide a random number seed.
-
-@@ -255,7 +255,7 @@
-
- private:
-
-- Allocator &m_rNodeAllocator;
-+ Allocator_t &m_rNodeAllocator;
- // Where we get memory to allocate nodes.
-
- bool m_bAllowDuplicates;
-@@ -337,7 +337,7 @@
-
- // The default node allocator. Allocates 64K at a time.
- template <class KEY, class VALUE, class KEYFN, class PRED>
--typename SkipList<KEY,VALUE,KEYFN,PRED>::Allocator
-+typename SkipList<KEY,VALUE,KEYFN,PRED>::Allocator_t
- SkipList<KEY,VALUE,KEYFN,PRED>::sm_oNodeAllocator (65536);
-
-
-@@ -345,7 +345,7 @@
- // Default constructor. Must be followed by Init().
- template <class KEY, class VALUE, class KEYFN, class PRED>
- SkipList<KEY,VALUE,KEYFN,PRED>::SkipList (const PRED &a_rPred,
-- Allocator &a_rAlloc)
-+ Allocator_t &a_rAlloc)
- : m_rNodeAllocator (a_rAlloc), m_oPred (a_rPred)
- {
- // Set up some defaults.
-@@ -371,7 +371,7 @@
- template <class KEY, class VALUE, class KEYFN, class PRED>
- SkipList<KEY,VALUE,KEYFN,PRED>::SkipList (Status_t &a_reStatus,
- bool a_bAllowDuplicates, uint32_t a_nRandSeed,
-- const PRED &a_rPred, Allocator &a_rAlloc)
-+ const PRED &a_rPred, Allocator_t &a_rAlloc)
- : m_rNodeAllocator (a_rAlloc), m_oPred (a_rPred)
- {
- // Make sure they didn't start us off with an error.