summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-07-19 10:47:49 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-07-19 10:47:49 +0000
commite213430d5dbb35a9228739755fe208078ea4c541 (patch)
treefe84b4dff2de8971e73003aadafb1bfa717f0436 /media-video/mgavideo
parentmake cvs_src_unpack implement base_src_unpack-style autopatching. this way pa... (diff)
downloadhistorical-e213430d5dbb35a9228739755fe208078ea4c541.tar.gz
historical-e213430d5dbb35a9228739755fe208078ea4c541.tar.bz2
historical-e213430d5dbb35a9228739755fe208078ea4c541.zip
repoman'd
Diffstat (limited to 'media-video/mgavideo')
-rw-r--r--media-video/mgavideo/files/digest-mgavideo-0.1.0.61
-rw-r--r--media-video/mgavideo/mgavideo-0.1.0.6.ebuild64
-rw-r--r--media-video/mgavideo/mgavideo-0.1.0.ebuild16
3 files changed, 9 insertions, 72 deletions
diff --git a/media-video/mgavideo/files/digest-mgavideo-0.1.0.6 b/media-video/mgavideo/files/digest-mgavideo-0.1.0.6
deleted file mode 100644
index d82bb4cfdfc3..000000000000
--- a/media-video/mgavideo/files/digest-mgavideo-0.1.0.6
+++ /dev/null
@@ -1 +0,0 @@
-MD5 b2b21cb4de4084b4c64d109ad217e011 mgavideo-0.1.0-test6.tar.gz 244775
diff --git a/media-video/mgavideo/mgavideo-0.1.0.6.ebuild b/media-video/mgavideo/mgavideo-0.1.0.6.ebuild
deleted file mode 100644
index 8cd0c9c00175..000000000000
--- a/media-video/mgavideo/mgavideo-0.1.0.6.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2001 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-
-A=${PN}-0.1.0-test6.tar.gz
-S=${WORKDIR}/${PN}-0.1.0-test6/driver
-SRC_URI="mirror://sourceforge/marvel/${A}"
-DESCRIPTION="Matrox Marvel G200/G400/Rainbow Runner G-series V4L I and II drivers"
-HOMEPAGE="http://marvel.sourceforge.net"
-
-DEPEND="virtual/glibc
- virtual/linux-sources
- >=sys-apps/portage-1.9.10"
-
-RDEPEND="virtual/linux-sources"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
-
- # This allows us to compile the i2c-algo-ks.o module even if the user doesn't have
- # the i2c-core.o module, incase they want to compile that later. At the end of this
- # script we warn them if that is the case
-
- cp Makefile Makefile.orig
- sed -e '/i2c-algo-ks\.o\:/,+3c\
-i2c-algo-ks.o:\
- \$(CC) \$(CFLAGS) -c i2c-algo-ks.c' Makefile.orig > Makefile
-}
-
-src_compile() {
- check_KV
- make mjpeg
-}
-
-src_install() {
- local install_dir=/lib/modules/${KV}/kernel/drivers/mgavideo
-
- dodir ${install_dir}
- dodoc README CHANGELOG
- cp i2c-algo-ks.o ${D}/${install_dir}
- cp tuner.o ${D}/${install_dir}
- cp ks0127.o ${D}/${install_dir}
- cp msp3400.o ${D}/${install_dir}
- cp maven.o ${D}/${install_dir}
- cp mga_core.o ${D}/${install_dir}
- cp mgavideo.o ${D}/${install_dir}
- cp mgacap.o ${D}/${install_dir}
- cp zr36060.o ${D}/${install_dir}
- cp i33.o ${D}/${install_dir}
- cp mgajpg.o ${D}/${install_dir}
- cp mgagrab.o ${D}/${install_dir}
-}
-
-pkg_postinst() {
- depmod -a
- if [ ! -f /lib/modules/${KV}/kernel/drivers/i2c/i2c-core.o ] ; then
- echo
- echo '###############################################################'
- echo '## WARNING: i2c support must be compiled into your kernel ##'
- echo '## as a module for these drivers to work. ##'
- echo '###############################################################'
- echo
- fi
-}
diff --git a/media-video/mgavideo/mgavideo-0.1.0.ebuild b/media-video/mgavideo/mgavideo-0.1.0.ebuild
index 89e062e976a2..efade209dcd8 100644
--- a/media-video/mgavideo/mgavideo-0.1.0.ebuild
+++ b/media-video/mgavideo/mgavideo-0.1.0.ebuild
@@ -1,18 +1,20 @@
-# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/media-video/mgavideo/mgavideo-0.1.0.ebuild,v 1.2 2002/07/19 10:47:49 seemant Exp $
-A=${PN}-0.1.0.tar.gz
-S=${WORKDIR}/${PN}-0.1.0/driver
-SRC_URI="http://telia.dl.sourceforge.net/marvel/${A}"
+S=${WORKDIR}/${P}/driver
DESCRIPTION="Matrox Marvel G200/G400/Rainbow Runner G-series V4L I and II
drivers"
HOMEPAGE="http://marvel.sourceforge.net"
+SRC_URI="mirror://sourceforge/marvel/${P}.tar.gz"
-DEPEND="virtual/glibc
- virtual/kernel"
-
+DEPEND="virtual/glibc"
RDEPEND="virtual/kernel"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
src_unpack() {
unpack ${A}
cd ${S}