summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2014-11-04 09:48:48 +0000
committerAlexis Ballier <aballier@gentoo.org>2014-11-04 09:48:48 +0000
commita9a54abe307582003ca1f5fed39e88330d916b64 (patch)
treeac1d9967c8577e619ba57d67eb821b2cb006c459 /media-video/ffmpeg/ffmpeg-9999.ebuild
parentSet RESTRICT=test (bug #276687). (diff)
downloadhistorical-a9a54abe307582003ca1f5fed39e88330d916b64.tar.gz
historical-a9a54abe307582003ca1f5fed39e88330d916b64.tar.bz2
historical-a9a54abe307582003ca1f5fed39e88330d916b64.zip
give preference to -mcpu then -mtune then -march for setting cpu, this should match better the precision of the flags
Signed-off-by: aballier@gentoo.org Package-Manager: portage-2.2.14/cvs/Linux x86_64 Manifest-Sign-Key: 0x160F534A
Diffstat (limited to 'media-video/ffmpeg/ffmpeg-9999.ebuild')
-rw-r--r--media-video/ffmpeg/ffmpeg-9999.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/media-video/ffmpeg/ffmpeg-9999.ebuild b/media-video/ffmpeg/ffmpeg-9999.ebuild
index eb52a537c5cc..e925dce4e483 100644
--- a/media-video/ffmpeg/ffmpeg-9999.ebuild
+++ b/media-video/ffmpeg/ffmpeg-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-9999.ebuild,v 1.175 2014/11/04 09:20:04 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-9999.ebuild,v 1.176 2014/11/04 09:48:43 aballier Exp $
EAPI="5"
@@ -289,7 +289,7 @@ multilib_src_configure() {
# We need to do this so that features of that CPU will be better used
# If they contain an unknown CPU it will not hurt since ffmpeg's configure
# will just ignore it.
- for i in $(get-flag march) $(get-flag mcpu) $(get-flag mtune) ; do
+ for i in $(get-flag mcpu) $(get-flag mtune) $(get-flag march) ; do
[[ ${i} = native ]] && i="host" # bug #273421
myconf+=( --cpu=${i} )
break