summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2003-04-27 14:29:03 +0000
committerMartin Schlemmer <azarah@gentoo.org>2003-04-27 14:29:03 +0000
commita7c83817d4fee56388b6f8318160f77f05a06353 (patch)
tree5bcc8ebdd9a2846993ed3b707dc473a7d7983b15 /media-video/drip
parentBump (diff)
downloadhistorical-a7c83817d4fee56388b6f8318160f77f05a06353.tar.gz
historical-a7c83817d4fee56388b6f8318160f77f05a06353.tar.bz2
historical-a7c83817d4fee56388b6f8318160f77f05a06353.zip
new version; bugfixes to dripgetdvd.sh
Diffstat (limited to 'media-video/drip')
-rw-r--r--media-video/drip/Manifest6
-rw-r--r--media-video/drip/drip-0.9.0_alpha3.ebuild92
-rw-r--r--media-video/drip/files/digest-drip-0.9.0_alpha31
-rw-r--r--media-video/drip/files/dripgetdvd.sh71
4 files changed, 159 insertions, 11 deletions
diff --git a/media-video/drip/Manifest b/media-video/drip/Manifest
index 776e743247ac..77831cbe5eb2 100644
--- a/media-video/drip/Manifest
+++ b/media-video/drip/Manifest
@@ -1,12 +1,12 @@
-MD5 74c220b4a55fd56eeeab0d84f8d41c9c ChangeLog 2354
+MD5 fef9ad93df91ea6b3499c34e0e51f54b ChangeLog 2353
MD5 e1b8d72f195ec1a8a327622d77f8ca46 drip-0.8.1-r5.ebuild 3118
MD5 b4245e90968cd364cba5d03c0c1d9941 drip-0.8.2_pre1.ebuild 2560
-MD5 e6e2c148c3f95c49502c146dd95fe579 drip-0.9.0_alpha3.ebuild 2297
+MD5 17a21163298a21562e1a30ff7d58060c drip-0.9.0_alpha3.ebuild 2298
MD5 39f83fd93ac2e8bb8b9b89afcbcaedcd files/digest-drip-0.8.1-r5 62
MD5 da7ca55731988f1a5a0ece5cbcbf0de1 files/digest-drip-0.8.2_pre1 66
MD5 636fd81a0bb66385faca9b7c72cb1cbc files/drip-0.8.1-fix-dvd-symlink.patch 1305
MD5 e85fdab29910541239d107476ff1a592 files/drip-0.8.1-gcc-3.1.patch 546
MD5 030a52bd54594455f9d77f959575036d files/drip-0.8.1-missing-stdio.patch 567
MD5 89536060720610232d7c3306761d93eb files/drip.desktop 119
-MD5 7afc4d422b34bd5a87ac63f083076499 files/dripgetdvd.sh 1249
+MD5 c0b2dc8cb5d74a89921e18556161dcbb files/dripgetdvd.sh 1348
MD5 23432e9d253629f04e963b5f9ad807c9 files/digest-drip-0.9.0_alpha3 66
diff --git a/media-video/drip/drip-0.9.0_alpha3.ebuild b/media-video/drip/drip-0.9.0_alpha3.ebuild
new file mode 100644
index 000000000000..3d6bc875e675
--- /dev/null
+++ b/media-video/drip/drip-0.9.0_alpha3.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/drip/drip-0.9.0_alpha3.ebuild,v 1.1 2003/04/27 14:27:36 azarah Exp $
+
+inherit eutils libtool
+
+MY_P="${P/_}"
+MY_P="${MY_P/alpha/cvs}"
+S="${WORKDIR}/${PN}"
+DESCRIPTION="Drip - A DVD to DIVX convertor frontend"
+SRC_URI="http://drip.sourceforge.net/files/${MY_P}.tar.gz"
+HOMEPAGE="http://drip.sourceforge.net/"
+
+RDEPEND="gnome-base/gnome-libs
+ >=media-video/avifile-0.7.22
+ >=media-libs/a52dec-0.7.3
+ >=media-libs/divx4linux-20020418
+ >=media-libs/libdvdcss-1.2.2
+ >=media-libs/libdvdread-0.9.3
+ >=media-libs/libmpeg2-0.3.1
+ media-libs/gdk-pixbuf
+ dev-libs/libxml2
+ sys-apps/eject"
+
+DEPEND="${RDEPEND}
+ dev-lang/nasm
+ >=sys-devel/automake-1.5-r1"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+src_unpack() {
+
+ unpack ${A}
+
+ # Fix the problem that if the /dev/dvd symlink is not absolute,
+ # drip fails to start. We do this by tring to figure what the
+ # absolute path to the block device of a dvd drive is with help
+ # from the dripgetdvd.sh script.
+ # <azarah@gentoo.org>
+ cd ${S} ; epatch ${FILESDIR}/${PN}-0.8.1-fix-dvd-symlink.patch
+
+ # Remove stale script ... "automake --add-missing" will add it again
+ einfo "Rerunnig autoconf/automake..."
+ cd ${S} ; rm -f ${S}/missing
+ export WANT_AUTOMAKE_1_5=1
+ aclocal -I macros
+ automake --add-missing
+ autoconf
+}
+
+src_compile() {
+
+ elibtoolize
+
+ local myconf=
+
+ use nls || myconf="${myconf} --disable-nls"
+
+ # Do not use custom CFLAGS !!!
+ unset CFLAGS CXXFLAGS
+
+ econf ${myconf} || die
+
+ make || die
+}
+
+src_install() {
+
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ localstatedir=${D}/var/lib \
+ sysconfdir=${D}/etc \
+ drip_helpdir=${D}/usr/share/gnome/help/drip/C \
+ drip_pixmapdir=${D}/usr/share/pixmaps \
+ pixdir=${D}/usr/share/pixmaps/drip \
+ install || die
+
+ # Custom script for drip to get the *real* dvd device
+ # It is a bit rough around the edges, but hopefully will do the trick.
+ dobin ${FILESDIR}/dripgetdvd.sh
+
+ insinto /usr/share/pixmaps
+ newins ${S}/pixmaps/drip_logo.jpg drip.jpg
+ insinto /usr/share/gnome/apps/Multimedia
+ doins ${FILESDIR}/drip.desktop
+
+ dodoc AUTHORS BUG-REPORT.TXT COPYING ChangeLog NEWS README TODO
+}
+
diff --git a/media-video/drip/files/digest-drip-0.9.0_alpha3 b/media-video/drip/files/digest-drip-0.9.0_alpha3
new file mode 100644
index 000000000000..6c6d46e5a2f0
--- /dev/null
+++ b/media-video/drip/files/digest-drip-0.9.0_alpha3
@@ -0,0 +1 @@
+MD5 02ab5f4a78f17c7c46266741d962dd41 drip-0.9.0cvs3.tar.gz 887447
diff --git a/media-video/drip/files/dripgetdvd.sh b/media-video/drip/files/dripgetdvd.sh
index 3e07b9c39940..6dd3d3be40cb 100644
--- a/media-video/drip/files/dripgetdvd.sh
+++ b/media-video/drip/files/dripgetdvd.sh
@@ -1,20 +1,75 @@
#!/bin/sh
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Martin Schlemmer <azarah@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-video/drip/files/dripgetdvd.sh,v 1.2 2003/04/27 14:27:37 azarah Exp $
+
+# This basically resolves a symlink in /dev to the block device node. If
+# $1 is a absolute path, and that do not exist, we also check /etc/fstab
+# if there is an entry, if not we check for an entry of `basename $1`.
if test -z "$1"
then
exit 1
fi
-DVD="`grep $1 /etc/fstab | awk '{print $1}'`"
+DVD="$1"
+
+check_device() {
+ local DVD="$1"
+ local NEWDVD=
+
+ while test -L "${DVD}"
+ do
+ NEWDVD="$(readlink "${DVD}")"
+
+ if test -z "$(echo "${NEWDVD}" | grep -e "^/dev")"
+ then
+ DVD="${DVD%/*}/${NEWDVD}"
+ else
+ DVD="${NEWDVD}"
+ fi
+ done
+
+ echo "${DVD}"
+}
+
+get_fstab_entry() {
+ test -z "$1" && return 1
+
+ echo "$(grep "$1" /etc/fstab | awk '$0 !~ /^[[:space:]]*#/ {print $1}')"
+}
+
+if ! test -L "${DVD}" && ! test -b "${DVD}"
+then
+ NEWDVD="$(get_fstab_entry "${DVD}")"
-while test -L "${DVD}"
-do
- NEWDVD="`readlink ${DVD}`"
- if test -z "`echo ${NEWDVD} |grep -e "^/dev"`"
+ if test -z "${NEWDVD}"
then
- DVD="${DVD%/*}/${NEWDVD}"
+ NEWDVD="$(get_fstab_entry $(basename "${DVD}"))"
fi
-done
-echo ${DVD}
+ if test -z "${NEWDVD}"
+ then
+ exit 1
+ else
+ DVD="${NEWDVD}"
+ fi
+fi
+
+DVD="$(check_device "${DVD}")"
+
+if test -z "${DVD}"
+then
+ exit 1
+fi
+
+if test -b "${DVD}"
+then
+ echo "$(echo ${DVD} | sed -e 's://:/:g')"
+else
+ exit 1
+fi
+
+exit 0