summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Weiler <pylon@gentoo.org>2005-07-09 17:54:00 +0000
committerLars Weiler <pylon@gentoo.org>2005-07-09 17:54:00 +0000
commitdce1dd0f4c48f0d11cc1a8c7f78962009b680579 (patch)
tree37ce35840943052637f8dd6093251cc17d2c2134 /media-tv/nxtvepg/nxtvepg-2.7.5.ebuild
parentQA: Cleaner einfo, ewarn, eerror and echo usage (diff)
downloadhistorical-dce1dd0f4c48f0d11cc1a8c7f78962009b680579.tar.gz
historical-dce1dd0f4c48f0d11cc1a8c7f78962009b680579.tar.bz2
historical-dce1dd0f4c48f0d11cc1a8c7f78962009b680579.zip
Version bump. Previous version stable on x86 and ppc.
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'media-tv/nxtvepg/nxtvepg-2.7.5.ebuild')
-rw-r--r--media-tv/nxtvepg/nxtvepg-2.7.5.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/media-tv/nxtvepg/nxtvepg-2.7.5.ebuild b/media-tv/nxtvepg/nxtvepg-2.7.5.ebuild
new file mode 100644
index 000000000000..b108216d7876
--- /dev/null
+++ b/media-tv/nxtvepg/nxtvepg-2.7.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/nxtvepg/nxtvepg-2.7.5.ebuild,v 1.1 2005/07/09 17:54:00 pylon Exp $
+
+inherit eutils
+
+DESCRIPTION="receive and browse free TV programme listings via bttv for tv networks in Europe"
+HOMEPAGE="http://nxtvepg.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE=""
+
+RDEPEND=">=dev-lang/tcl-8.0
+ >=dev-lang/tk-8.0"
+
+DEPEND="${RDEPEND}
+ sys-apps/sed"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/nxtvepg-db.patch
+}
+
+src_compile() {
+ make prefix="/usr" || die "make failed"
+}
+
+src_install() {
+ make install ROOT=${D} prefix="/usr" || die "install failed"
+ dodoc README COPYRIGHT CHANGES TODO
+ dohtml manual.html
+}