summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-06-08 02:05:09 +0000
committerAron Griffis <agriffis@gentoo.org>2004-06-08 02:05:09 +0000
commitf891c9522bb6fe5c9c7d92f86c524db7e911fe74 (patch)
treea0de42a8d6f048676ff90911041ebd1e248d1288 /media-tv/mythfrontend
parentfinish trimming out the old (diff)
downloadhistorical-f891c9522bb6fe5c9c7d92f86c524db7e911fe74.tar.gz
historical-f891c9522bb6fe5c9c7d92f86c524db7e911fe74.tar.bz2
historical-f891c9522bb6fe5c9c7d92f86c524db7e911fe74.zip
Fix use invocation
Diffstat (limited to 'media-tv/mythfrontend')
-rw-r--r--media-tv/mythfrontend/ChangeLog6
-rw-r--r--media-tv/mythfrontend/mythfrontend-0.13.ebuild12
-rw-r--r--media-tv/mythfrontend/mythfrontend-0.14-r1.ebuild18
-rw-r--r--media-tv/mythfrontend/mythfrontend-0.15.1.ebuild22
4 files changed, 31 insertions, 27 deletions
diff --git a/media-tv/mythfrontend/ChangeLog b/media-tv/mythfrontend/ChangeLog
index a0ff869a437e..ff31d328e933 100644
--- a/media-tv/mythfrontend/ChangeLog
+++ b/media-tv/mythfrontend/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-tv/mythfrontend
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythfrontend/ChangeLog,v 1.16 2004/06/02 21:45:18 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythfrontend/ChangeLog,v 1.17 2004/06/08 02:02:04 agriffis Exp $
+
+ 07 Jun 2004; Aron Griffis <agriffis@gentoo.org> mythfrontend-0.13.ebuild,
+ mythfrontend-0.14-r1.ebuild, mythfrontend-0.15.1.ebuild:
+ Fix use invocation
02 Jun 2004; Daniel Ahlberg <aliz@gentoo.org> mythfrontend-0.15.1.ebuild:
+ Added check for OpenGL implementation, closing #52722.
diff --git a/media-tv/mythfrontend/mythfrontend-0.13.ebuild b/media-tv/mythfrontend/mythfrontend-0.13.ebuild
index 2cbb21c7d7f5..3c5a8f89f5b5 100644
--- a/media-tv/mythfrontend/mythfrontend-0.13.ebuild
+++ b/media-tv/mythfrontend/mythfrontend-0.13.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythfrontend/mythfrontend-0.13.ebuild,v 1.3 2004/04/26 04:07:44 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythfrontend/mythfrontend-0.13.ebuild,v 1.4 2004/06/08 02:02:04 agriffis Exp $
inherit flag-o-matic
@@ -53,27 +53,27 @@ src_compile() {
sed -e "s:pentiumpro:${cpu}:g" -i "settings.pro" || die "sed failed"
fi
- if [ "`use alsa`" ] ; then
+ if use alsa ; then
sed -e "s:#CONFIG += using_alsa:CONFIG += using_alsa:" \
-e "s:#ALSA_LIBS = -lasound:ALSA_LIBS = -lasound:" \
-i "settings.pro" || die "enable alsa sed failed"
fi
- if [ "`use lcd`" ] ; then
+ if use lcd ; then
sed -e "s:#DEFINES += LCD_DEVICE:DEFINES += LCD_DEVICE:" \
-i "settings.pro" || die "enable lcd sed failed"
fi
- if [ "`use lirc`" ] ; then
+ if use lirc ; then
sed -e "s:#CONFIG += using_lirc:CONFIG += using_lirc:" \
-e "s:#LIRC_LIBS = -llirc_client:LIRC_LIBS = -llirc_client:" \
-i "settings.pro" || die "enable lirc sed failed"
fi
- if [ "`use nvidia`" ] ; then
+ if use nvidia ; then
sed -e "s:#CONFIG += using_xvmc:CONFIG += using_xvmc:" \
-e "s:#EXTRA_LIBS += -lXvMCNVIDIA:EXTRA_LIBS += -lXvMCNVIDIA:" \
-i "settings.pro" || die "enable xvmc sed failed"
fi
# Needs a VIA supported kernel driver.
- #if [ "`use via`" ] ; then
+ #if use via ; then
# sed -e "s:#CONFIG += using_via:CONFIG += using_via:"
# -e "s:#EXTRA_LIBS += -lddmpeg:EXTRA_LIBS += -lddmpeg:"
# -i "settings.pro" || die "enable lirc sed failed"
diff --git a/media-tv/mythfrontend/mythfrontend-0.14-r1.ebuild b/media-tv/mythfrontend/mythfrontend-0.14-r1.ebuild
index 2b55e94a6564..1c26288c46a8 100644
--- a/media-tv/mythfrontend/mythfrontend-0.14-r1.ebuild
+++ b/media-tv/mythfrontend/mythfrontend-0.14-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythfrontend/mythfrontend-0.14-r1.ebuild,v 1.3 2004/04/26 18:36:23 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythfrontend/mythfrontend-0.14-r1.ebuild,v 1.4 2004/06/08 02:02:04 agriffis Exp $
inherit flag-o-matic
@@ -64,12 +64,12 @@ src_compile() {
fi
fi
- if [ "`use alsa`" ] ; then
+ if use alsa ; then
sed -e 's:#CONFIG += using_alsa:CONFIG += using_alsa:' \
-e 's:#ALSA_LIBS = -lasound:ALSA_LIBS = -lasound:' \
-i 'settings.pro' || die "enable alsa sed failed"
fi
- if [ "`use arts`" ] ; then
+ if use arts ; then
sed -e 's:artsc/artsc.h:artsc.h:' \
-i "libs/libmyth/audiooutputarts.h" || die "sed failed"
sed -e 's:#CONFIG += using_arts:CONFIG += using_arts:' \
@@ -78,34 +78,34 @@ src_compile() {
-e 's:#INCLUDEPATH += /opt/.*:QMAKE_CXXFLAGS += `artsc-config --cflags`:' \
-i 'settings.pro' || die "enable arts sed failed"
fi
- if [ "`use directfb`" ] ; then
+ if use directfb ; then
sed -e 's:#CONFIG += using_directfb:CONFIG += using_directfb:' \
-e 's:#EXTRA_LIBS += `directfb:EXTRA_LIBS += `directfb:' \
-e 's:#QMAKE_CXXFLAGS += `directfb:QMAKE_CXXFLAGS += `directfb:' \
-i 'settings.pro' || die "enable arts sed failed"
fi
- if [ "`use dvb`" ] ; then
+ if use dvb ; then
sed -e 's:#CONFIG += using_dvb:CONFIG += using_dvb:' \
-e 's:#DEFINES += USING_DVB:DEFINES += USING_DVB:' \
-e 's:#INCLUDEPATH += /usr/src/.*:INCLUDEPATH += /usr/include:' \
-i 'settings.pro' || die "enable dvb sed failed"
fi
- if [ "`use lcd`" ] ; then
+ if use lcd ; then
sed -e 's:#DEFINES += LCD_DEVICE:DEFINES += LCD_DEVICE:' \
-i 'settings.pro' || die "enable lcd sed failed"
fi
- if [ "`use lirc`" ] ; then
+ if use lirc ; then
sed -e 's:#CONFIG += using_lirc:CONFIG += using_lirc:' \
-e 's:#LIRC_LIBS = -llirc_client:LIRC_LIBS = -llirc_client:' \
-i 'settings.pro' || die "enable lirc sed failed"
fi
- if [ "`use nvidia`" ] ; then
+ if use nvidia ; then
sed -e 's:#CONFIG += using_xvmc:CONFIG += using_xvmc:' \
-e 's:#DEFINES += USING_XVMC:DEFINES += USING_XVMC:' \
-e 's:#EXTRA_LIBS += -lXvMCNVIDIA:EXTRA_LIBS += -lXvMCNVIDIA:' \
-i 'settings.pro' || die "enable xvmc sed failed"
fi
- if [ "`use cle266`" ] ; then
+ if use cle266 ; then
sed -e 's:#CONFIG += using_viahwslice:CONFIG += using_viahwslice:' \
-e 's:#DEFINES += USING_VIASLICE:DEFINES += USING_VIASLICE:' \
-e 's:#EXTRA_LIBS += -lddmpeg:EXTRA_LIBS += -lddmpeg:' \
diff --git a/media-tv/mythfrontend/mythfrontend-0.15.1.ebuild b/media-tv/mythfrontend/mythfrontend-0.15.1.ebuild
index 9776d81e44b5..583eac16b9e9 100644
--- a/media-tv/mythfrontend/mythfrontend-0.15.1.ebuild
+++ b/media-tv/mythfrontend/mythfrontend-0.15.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythfrontend/mythfrontend-0.15.1.ebuild,v 1.2 2004/06/02 21:45:18 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythfrontend/mythfrontend-0.15.1.ebuild,v 1.3 2004/06/08 02:02:04 agriffis Exp $
inherit flag-o-matic eutils
@@ -41,7 +41,7 @@ pkg_setup() {
die "Qt needs MySQL support"
fi
- if [ `use opengl` ] ; then
+ if use opengl ; then
local gl_implementation="$( opengl-update --get-implementation )"
if [ "$gl_implementation" == "xfree" ] || [ "$gl_implementation" == "xorg-x11" ] ; then
return 0
@@ -78,12 +78,12 @@ src_compile() {
fi
fi
- if [ "`use alsa`" ] ; then
+ if use alsa ; then
sed -e 's:#CONFIG += using_alsa:CONFIG += using_alsa:' \
-e 's:#ALSA_LIBS = -lasound:ALSA_LIBS = -lasound:' \
-i 'settings.pro' || die "enable alsa sed failed"
fi
- if [ "`use arts`" ] ; then
+ if use arts ; then
sed -e 's:artsc/artsc.h:artsc.h:' \
-i "libs/libmyth/audiooutputarts.h" || die "sed failed"
sed -e 's:#CONFIG += using_arts:CONFIG += using_arts:' \
@@ -92,40 +92,40 @@ src_compile() {
-e 's:#INCLUDEPATH += /opt/.*:QMAKE_CXXFLAGS += `artsc-config --cflags`:' \
-i 'settings.pro' || die "enable arts sed failed"
fi
- if [ "`use directfb`" ] ; then
+ if use directfb ; then
sed -e 's:#CONFIG += using_directfb:CONFIG += using_directfb:' \
-e 's:#EXTRA_LIBS += `directfb:EXTRA_LIBS += `directfb:' \
-e 's:#QMAKE_CXXFLAGS += `directfb:QMAKE_CXXFLAGS += `directfb:' \
-i 'settings.pro' || die "enable arts sed failed"
fi
- if [ "`use dvb`" ] ; then
+ if use dvb ; then
sed -e 's:#CONFIG += using_dvb:CONFIG += using_dvb:' \
-e 's:#DEFINES += USING_DVB:DEFINES += USING_DVB:' \
-e 's:#INCLUDEPATH += /usr/src/.*:INCLUDEPATH += /usr/include:' \
-i 'settings.pro' || die "enable dvb sed failed"
fi
- if [ "`use lcd`" ] ; then
+ if use lcd ; then
sed -e 's:#DEFINES += LCD_DEVICE:DEFINES += LCD_DEVICE:' \
-i 'settings.pro' || die "enable lcd sed failed"
fi
- if [ "`use lirc`" ] ; then
+ if use lirc ; then
sed -e 's:#CONFIG += using_lirc:CONFIG += using_lirc:' \
-e 's:#LIRC_LIBS = -llirc_client:LIRC_LIBS = -llirc_client:' \
-i 'settings.pro' || die "enable lirc sed failed"
fi
- if [ "`use nvidia`" ] ; then
+ if use nvidia ; then
sed -e 's:#CONFIG += using_xvmc:CONFIG += using_xvmc:' \
-e 's:#DEFINES += USING_XVMC:DEFINES += USING_XVMC:' \
-e 's:#EXTRA_LIBS += -lXvMCNVIDIA:EXTRA_LIBS += -lXvMCNVIDIA:' \
-i 'settings.pro' || die "enable xvmc sed failed"
fi
- if [ "`use cle266`" ] ; then
+ if use cle266 ; then
sed -e 's:#CONFIG += using_viahwslice:CONFIG += using_viahwslice:' \
-e 's:#DEFINES += USING_VIASLICE:DEFINES += USING_VIASLICE:' \
-e 's:#EXTRA_LIBS += -lddmpeg:EXTRA_LIBS += -lddmpeg:' \
-i 'settings.pro' || die "enable lirc sed failed"
fi
- if [ "`use opengl`" ] ; then
+ if use opengl ; then
sed -e 's:#DEFINES += USING_OPENGL_VSYNC:DEFINES += USING_OPENGL_VSYNC:' \
-e 's:#EXTRA_LIBS += -lGL -lGLU:EXTRA_LIBS += -lGL -lGLU:' \
-i 'settings.pro' || die "enable opgenl sed failed"