summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2009-02-14 20:13:50 +0000
committerCarsten Lohrke <carlo@gentoo.org>2009-02-14 20:13:50 +0000
commit886b9c9a468e7908679de9c43cef0fe869337195 (patch)
tree8d80b7889179f3adefb9e25e8ac5f457f8795420 /media-tv/mtvg
parentDon't use custom src_install function. Fix improper split KDE ebuild dependen... (diff)
downloadhistorical-886b9c9a468e7908679de9c43cef0fe869337195.tar.gz
historical-886b9c9a468e7908679de9c43cef0fe869337195.tar.bz2
historical-886b9c9a468e7908679de9c43cef0fe869337195.zip
Wipe bogus kde_src_install function. Add missing kde.eclass function calls. Get rid of invalid aRts dependency. Fix desktop file.
Package-Manager: portage-2.2_rc23/cvs/Linux i686
Diffstat (limited to 'media-tv/mtvg')
-rw-r--r--media-tv/mtvg/ChangeLog11
-rw-r--r--media-tv/mtvg/files/mtvg-7.3.2-desktop-file.diff26
-rw-r--r--media-tv/mtvg/mtvg-7.3.2-r1.ebuild47
3 files changed, 82 insertions, 2 deletions
diff --git a/media-tv/mtvg/ChangeLog b/media-tv/mtvg/ChangeLog
index ccd8f41fead2..6ec9f7d03e19 100644
--- a/media-tv/mtvg/ChangeLog
+++ b/media-tv/mtvg/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-tv/mtvg
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mtvg/ChangeLog,v 1.5 2007/05/01 00:28:44 genone Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mtvg/ChangeLog,v 1.6 2009/02/14 20:13:49 carlo Exp $
+
+*mtvg-7.3.2-r1 (14 Feb 2009)
+
+ 14 Feb 2009; Carsten Lohrke <carlo@gentoo.org>
+ +files/mtvg-7.3.2-desktop-file.diff, +mtvg-7.3.2-r1.ebuild:
+ Wipe bogus kde_src_install function. Add missing kde.eclass function calls.
+ Get rid of invalid aRts dependency. Fix desktop file.
01 May 2007; Marius Mauch <genone@gentoo.org> mtvg-6.2.18-r1.ebuild,
mtvg-7.3.2.ebuild:
diff --git a/media-tv/mtvg/files/mtvg-7.3.2-desktop-file.diff b/media-tv/mtvg/files/mtvg-7.3.2-desktop-file.diff
new file mode 100644
index 000000000000..4701c892babe
--- /dev/null
+++ b/media-tv/mtvg/files/mtvg-7.3.2-desktop-file.diff
@@ -0,0 +1,26 @@
+--- src/Makefile.am.orig 2009-02-14 19:59:49.000000000 +0100
++++ src/Makefile.am 2009-02-14 20:00:11.000000000 +0100
+@@ -35,7 +35,7 @@
+ maxemumtvguide_LDADD = $(LIB_KDEUI) -lkio
+
+ # this is where the desktop file will go
+-shelldesktopdir = $(kde_appsdir)/Utilities
++shelldesktopdir = $(xdg_appsdir)
+ shelldesktop_DATA = maxemumtvguide.desktop
+
+ # this is where the shell's XML-GUI resource file goes
+--- src/maxemumtvguide.desktop.o 2009-02-14 19:59:04.000000000 +0100
++++ src/maxemumtvguide.desktop 2009-02-14 19:59:19.000000000 +0100
+@@ -1,6 +1,5 @@
+ [Desktop Entry]
+ X-SuSE-translate=true
+-Encoding=UTF-8
+ Name=Maxemum TV-Guide
+ Name[xx]=xxmaxemumtvguidexx
+ Exec=maxemumtvguide
+@@ -32,4 +31,4 @@
+ Comment[xx]=xxA simple KDE Applicationxx
+ Comment[zh_CN]=一个简单的KDE应用程序
+ GenericName=TV Guide
+-Categories=Qt;KDE;Utility;AudioVideo;Video;TV
++Categories=Qt;KDE;Utility;AudioVideo;Video;TV;
diff --git a/media-tv/mtvg/mtvg-7.3.2-r1.ebuild b/media-tv/mtvg/mtvg-7.3.2-r1.ebuild
new file mode 100644
index 000000000000..34bbf052708f
--- /dev/null
+++ b/media-tv/mtvg/mtvg-7.3.2-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mtvg/mtvg-7.3.2-r1.ebuild,v 1.1 2009/02/14 20:13:49 carlo Exp $
+
+ARTS_REQUIRED="never"
+
+inherit kde
+
+S="${WORKDIR}/maxemumtvguide-${PV}"
+
+DESCRIPTION="KDE TV-guide to display XMLTV listings."
+HOMEPAGE="http://mtvg.sourceforge.net/"
+SRC_URI="mirror://sourceforge/mtvg/maxemumtvguide-${PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="xml"
+DEPEND=""
+RDEPEND="xml? ( media-tv/xmltv )"
+
+need-kde 3.5
+
+PATCHES=(
+ "${FILESDIR}/mtvg-7.3.2-desktop-file.diff"
+ )
+
+src_unpack() {
+ kde_src_unpack
+ rm -f "${S}"/configure
+}
+
+pkg_setup() {
+ kde_pkg_setup
+
+ if ! use xml; then
+ echo
+ ewarn "Support for XMLTV disabled. Add the 'xml' USE flag if you"
+ ewarn "need to pull TV listings."
+ echo
+ fi
+}
+
+pkg_postinst() {
+ kde_pkg_postinst
+
+ elog "The binary to run mtvg is 'maxemumtvguide'"
+}