summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn J. Ellis <jje@gentoo.org>2003-05-17 03:18:19 +0000
committerJohn J. Ellis <jje@gentoo.org>2003-05-17 03:18:19 +0000
commitec0620317df69bbf2fb4fb1fa1aff553fef47df6 (patch)
treec6111633cd5c7293429061ac40368c3b78488a45 /media-sound
parentFix for #20647 (~x86 masked). (diff)
downloadhistorical-ec0620317df69bbf2fb4fb1fa1aff553fef47df6.tar.gz
historical-ec0620317df69bbf2fb4fb1fa1aff553fef47df6.tar.bz2
historical-ec0620317df69bbf2fb4fb1fa1aff553fef47df6.zip
Fix for #20647 (~x86 masked).
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/xmms/Manifest4
-rw-r--r--media-sound/xmms/files/digest-xmms-1.2.7-r212
-rw-r--r--media-sound/xmms/xmms-1.2.7-r21.ebuild195
3 files changed, 199 insertions, 2 deletions
diff --git a/media-sound/xmms/Manifest b/media-sound/xmms/Manifest
index 7de72938945c..a4d54edc3e67 100644
--- a/media-sound/xmms/Manifest
+++ b/media-sound/xmms/Manifest
@@ -1,6 +1,6 @@
-MD5 28e48b2b1683e202cb12823266b2a21b ChangeLog 8894
+MD5 7404c8bd16083938f25a99a4ff9347fb ChangeLog 8890
MD5 3d146665b50d0a405957dc7870db7a31 xmms-1.2.7-r20.ebuild 5170
-MD5 361ef4c7a7b50847c4349cd151d8b04a xmms-1.2.7-r21.ebuild 5290
+MD5 3e1023b68b9cb1f7e179e881ad53f50c xmms-1.2.7-r21.ebuild 5286
MD5 f31117e5ecc351b3ec071222cca257dc xmms-1.2.7-r19.ebuild 5093
MD5 a03fa7e2151194a6db4850897d16d128 files/xmms-1.2.7-mpg123j.patch 9333
MD5 3268d7f38e954fd7ab541fa9e6f385ca files/digest-xmms-1.2.7-r20 130
diff --git a/media-sound/xmms/files/digest-xmms-1.2.7-r21 b/media-sound/xmms/files/digest-xmms-1.2.7-r21
new file mode 100644
index 000000000000..89cc7eba5fd4
--- /dev/null
+++ b/media-sound/xmms/files/digest-xmms-1.2.7-r21
@@ -0,0 +1,2 @@
+MD5 8aa14a305d1eeb1bb53dba2197ba695a xmms-1.2.7.tar.gz 2860908
+MD5 daea40648c3ae296597dcd3e78500279 xmms-1.2.7-mmx.patch.gz 14990
diff --git a/media-sound/xmms/xmms-1.2.7-r21.ebuild b/media-sound/xmms/xmms-1.2.7-r21.ebuild
new file mode 100644
index 000000000000..dbfba3b7a363
--- /dev/null
+++ b/media-sound/xmms/xmms-1.2.7-r21.ebuild
@@ -0,0 +1,195 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/xmms/xmms-1.2.7-r21.ebuild,v 1.1 2003/05/17 03:18:06 jje Exp $
+
+IUSE="xml nls esd gnome opengl mmx oggvorbis 3dnow mikmod directfb ipv6 cjk"
+
+inherit libtool flag-o-matic eutils
+
+filter-flags "-fforce-addr"
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="X MultiMedia System"
+SRC_URI="http://www.xmms.org/files/1.2.x/${P}.tar.gz
+ mmx? ( http://members.jcom.home.ne.jp/jacobi/linux/etc/${P}-mmx.patch.gz )"
+HOMEPAGE="http://www.xmms.org/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+DEPEND="app-arch/unzip
+ =x11-libs/gtk+-1.2*
+ mikmod? ( >=media-libs/libmikmod-3.1.6 )
+ esd? ( >=media-sound/esound-0.2.22 )
+ xml? ( >=dev-libs/libxml-1.8.15 )
+ gnome? ( <gnome-base/gnome-panel-1.5.0 )
+ opengl? ( virtual/opengl )
+ oggvorbis? ( >=media-libs/libvorbis-1.0_beta4 )"
+
+
+RDEPEND="${DEPEND}
+ directfb? ( dev-libs/DirectFB )
+ nls? ( dev-util/intltool )"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+
+ cd ${S}
+
+ # Patch to allow external programmes to have the "jump to" dialog box
+ epatch ${FILESDIR}/xmms-jump.patch
+
+ # Save playlist, etc on SIGTERM and SIGINT, bug #13604.
+ epatch ${FILESDIR}/xmms-sigterm.patch
+
+ # The following optimisations are ONLY for x86 platform
+ use x86 && ( \
+ # For mmx/3dnow enabled CPUs, this patch adds mmx/3dnow optimisations
+ #
+ # ( use mmx || use 3dnow ) && \
+ # cat ${DISTDIR}/${P}-mmx.patch.gz | gunzip -c | patch -p1 || die
+ #
+ # For you guys who favour this kind of USE flag checking ... this
+ # is exactly why I do NOT like it, because the actual
+ # "cat ${DISTDIR}/${P}-mmx.patch.gz | gunzip -c | patch -p1 || die"
+ # was not in a subshell, it would ALWAYS fail to build if "mmx" or
+ # "3dnow" was not in USE, because of the || die at the end. So
+ # PLEASE, PLEASE test things with all possible USE flags if you use
+ # this style!!!! Then, if in a subshell, it do not detect if the
+ # command fails :/
+ #
+ # Azarah - 30 Jun 2002
+ #
+ if use mmx || use 3dnow
+ then
+ epatch ${DISTDIR}/${P}-mmx.patch.gz
+ use ipv6 && epatch ${FILESDIR}/xmms-ipv6-20020408-mmx.patch
+ else
+ use ipv6 && epatch ${FILESDIR}/xmms-ipv6-20020408-nommx.patch
+ fi
+ )
+
+ # Patch for mpg123 to convert Japanese character code of MP3 tag info
+ if use cjk; then
+ epatch ${FILESDIR}/${P}-mpg123j.patch
+ fi
+
+ [ ! -f ${S}/config.rpath ] && ( \
+ touch ${S}/config.rpath
+ chmod +x ${S}/config.rpath
+ )
+
+ # We run automake and autoconf here else we get a lot of warning/errors.
+ # I have tested this with gcc-2.95.3 and gcc-3.1.
+ elibtoolize
+ echo ">>> Reconfiguring..."
+ for x in ${S} ${S}/libxmms
+ do
+ cd ${x}
+ aclocal
+ export WANT_AUTOCONF_2_5=1
+ automake --gnu --add-missing --include-deps Makefile || die
+ autoconf || die
+ done
+}
+
+src_compile() {
+ local myconf=""
+
+ use gnome \
+ && myconf="${myconf} --with-gnome" \
+ || myconf="${myconf} --without-gnome"
+
+ use 3dnow || use mmx \
+ && myconf="${myconf} --enable-simd" \
+ || myconf="${myconf} --disable-simd"
+
+ use esd \
+ && myconf="${myconf} --enable-esd --enable-esdtest" \
+ || myconf="${myconf} --disable-esd --disable-esdtest"
+
+ use mikmod \
+ && myconf="${myconf} --enable-mikmod --enable-mikmodtest \
+ --with-libmikmod" \
+ || myconf="${myconf} --disable-mikmod --disable-mikmodtest \
+ --without-libmikmod"
+
+ use opengl \
+ && myconf="${myconf} --enable-opengl" \
+ || myconf="${myconf} --disable-opengl"
+
+ use oggvorbis \
+ && myconf="${myconf} --enable-vorbis --enable-oggtest \
+ --enable-vorbistest --with-ogg" \
+ || myconf="${myconf} --disable-vorbis --disable-oggtest \
+ --disable-vorbistest --without-ogg"
+
+ use xml \
+ || myconf="${myconf} --disable-cdindex"
+
+ use nls \
+ || myconf="${myconf} --disable-nls"
+
+ use ipv6 && myconf="${myconf} --enable-ipv6"
+
+ # this is here for people who boot with gentoo=nodevfs
+ # see #20647 for details.
+ if [ -e /dev/sound ]
+ then
+ myconf="${myconf} \
+ --with-dev-dsp=/dev/sound/dsp \
+ --with-dev-mixer=/dev/sound/mixer"
+ fi
+
+ econf ${myconf} || die
+
+ ### emake seems to break some compiles, please keep @ make
+ make || die
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ datadir=${D}/usr/share \
+ incdir=${D}/usr/include \
+ infodir=${D}/usr/share/info \
+ localstatedir=${D}/var/lib \
+ mandir=${D}/usr/share/man \
+ sysconfdir=${D}/etc \
+ sysdir=${D}/usr/share/applets/Multimedia \
+ GNOME_SYSCONFDIR=${D}/etc install || die "FOO"
+
+ dodoc AUTHORS ChangeLog COPYING FAQ NEWS README TODO
+
+ dodir /usr/share/xmms/Skins
+ insinto /usr/share/pixmaps/
+ donewins gnomexmms/gnomexmms.xpm xmms.xpm
+ doins xmms/xmms_logo.xpm
+ insinto /usr/share/pixmaps/mini
+ doins xmms/xmms_mini.xpm
+
+ insinto /etc/X11/wmconfig
+ donewins xmms/xmms.wmconfig xmms
+
+ use gnome && ( \
+ insinto /usr/share/gnome/apps/Multimedia
+ doins xmms/xmms.desktop
+ dosed "s:xmms_mini.xpm:mini/xmms_mini.xpm:" \
+ /usr/share/gnome/apps/Multimedia/xmms.desktop
+ ) || ( \
+ rm ${D}/usr/share/man/man1/gnomexmms*
+ )
+
+ # causes segfaults for ppc users #10309 and after talking
+ # to xmms dev's, they've punted this from the src tree anyways ...
+ rm -rf ${D}/usr/lib/xmms/Input/libidcin.so
+}
+
+pkg_postrm() {
+
+ if [ -x ${ROOT}/usr/bin/xmms ] && [ ! -d ${ROOT}/usr/share/xmms/Skins ]
+ then
+ mkdir -p ${ROOT}/usr/share/xmms/Skins
+ fi
+}
+