summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-06-01 17:58:40 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-06-01 17:58:40 +0000
commitfbe04a685759af1cd38d615ef3f529b1714ce66f (patch)
tree6bafd154a809a6b1bf57f8ae61dc06ceaac6acfe /media-sound/xwax
parentAdd kde as backup herd as this is clearly a KDE 3.5 pkg. (diff)
downloadhistorical-fbe04a685759af1cd38d615ef3f529b1714ce66f.tar.gz
historical-fbe04a685759af1cd38d615ef3f529b1714ce66f.tar.bz2
historical-fbe04a685759af1cd38d615ef3f529b1714ce66f.zip
Fix repoman warning
Package-Manager: portage-2.1.6.13/cvs/Linux x86_64
Diffstat (limited to 'media-sound/xwax')
-rw-r--r--media-sound/xwax/xwax-0.4.ebuild31
1 files changed, 11 insertions, 20 deletions
diff --git a/media-sound/xwax/xwax-0.4.ebuild b/media-sound/xwax/xwax-0.4.ebuild
index e27e32d78d44..7788f727d5b8 100644
--- a/media-sound/xwax/xwax-0.4.ebuild
+++ b/media-sound/xwax/xwax-0.4.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/xwax/xwax-0.4.ebuild,v 1.2 2008/09/15 17:32:52 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/xwax/xwax-0.4.ebuild,v 1.3 2009/06/01 17:58:40 ssuominen Exp $
+EAPI=2
inherit eutils
DESCRIPTION="Digital vinyl emulation software"
@@ -13,38 +14,28 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="alsa"
-DEPEND="media-libs/libsdl
+RDEPEND="media-libs/libsdl
media-libs/sdl-ttf
media-fonts/ttf-bitstream-vera
alsa? ( media-libs/alsa-lib )"
+DEPEND="${RDEPEND}"
-DOCS="README"
-
-src_unpack() {
- unpack ${A}
-
- cd "${S}"
+src_prepare() {
# Fix fonts directory in source
epatch "${FILESDIR}/${P}-fonts.patch"
# Remove the 'CFLAGS += -Wall -03' line from Makefile
# Add LDFLAGS to Makefile
sed -i -e 's:^CFLAGS:#CFLAGS:' \
-e 's:\($(CC) .* $(DEVICE_LIBS)\):\1 $(LDFLAGS):' \
- Makefile
+ Makefile || die "sed failed"
}
-src_compile() {
- econf $(use_enable alsa) || die "econf failed"
-
- emake || die "emake failed"
+src_configure() {
+ econf \
+ $(use_enable alsa)
}
src_install() {
- # Manually install into ${D}/usr/bin
- exeinto "/usr/bin"
-
- doexe xwax
- doexe xwax_import
- # Install documentation
- dodoc ${DOCS}
+ dobin xwav xwav_import
+ dodoc README
}