summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTilman Klar <phoenix@gentoo.org>2002-07-14 10:31:26 +0000
committerTilman Klar <phoenix@gentoo.org>2002-07-14 10:31:26 +0000
commitb22f8c456c5b6135d6c135750307e68a126895fc (patch)
treeb970f9390734dcd1443a8e34a5d9ddd2857a5420 /media-sound/umix
parentmissing digest (diff)
downloadhistorical-b22f8c456c5b6135d6c135750307e68a126895fc.tar.gz
historical-b22f8c456c5b6135d6c135750307e68a126895fc.tar.bz2
historical-b22f8c456c5b6135d6c135750307e68a126895fc.zip
New package: umix.
Diffstat (limited to 'media-sound/umix')
-rw-r--r--media-sound/umix/ChangeLog18
-rw-r--r--media-sound/umix/umix-0.9.1.ebuild38
2 files changed, 56 insertions, 0 deletions
diff --git a/media-sound/umix/ChangeLog b/media-sound/umix/ChangeLog
new file mode 100644
index 000000000000..9fc73945f8ba
--- /dev/null
+++ b/media-sound/umix/ChangeLog
@@ -0,0 +1,18 @@
+# ChangeLog for app-games/ytin
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/umix/ChangeLog,v 1.1 2002/07/14 10:31:26 phoenix Exp $
+
+*ytin-1.83.5.ebuild (14 July 2002)
+
+ 14 Jul 2002; phoen][x <phoenix@gentoo.org> ChangeLog, umix-0.9.1.ebuild,
+ files/digest-umix-0.9.1 :
+
+ Initial cvs commit. Ebuild contributed Sakari Lehtonen <sakari@ionstream.fi>.
+ Thanks for the contribution.
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
+
diff --git a/media-sound/umix/umix-0.9.1.ebuild b/media-sound/umix/umix-0.9.1.ebuild
new file mode 100644
index 000000000000..c81d5a3e115f
--- /dev/null
+++ b/media-sound/umix/umix-0.9.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Sakari Lehtonen <sakari@ionstream.fi>
+# $Header: /var/cvsroot/gentoo-x86/media-sound/umix/umix-0.9.1.ebuild,v 1.1 2002/07/14 10:31:26 phoenix Exp $
+
+DESCRIPTION="Program for adjusting soundcard volumes"
+SRC_URI="http://www.ionstream.fi/sakari/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.ionstream.fi/sakari/umix/"
+SLOT="0"
+KEYWORDS="x86"
+LICENSE="GPL-2"
+
+DEPEND="virtual/glibc
+ ncurses? ( >=sys-libs/ncurses-5.2 )
+ gtk? ( >=x11-libs/gtk+-2.0.0 )"
+
+src_compile() {
+
+ local myopts
+ use ncurses || myopts="--disable-ncurses"
+ use gtk || myopts="${myopts} --disable-gtk"
+
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/man \
+ --host=${CHOST} \
+ ${myopts} || die
+
+ emake || die
+}
+
+src_install() {
+
+ make DESTDIR=${D} install
+
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}