summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2003-09-06 12:01:48 +0000
committerMarinus Schraal <foser@gentoo.org>2003-09-06 12:01:48 +0000
commit653d48f76eb6de7c5373999dbbcf22ac5dd24b32 (patch)
treea27cd280c108b7a1b69d54726b230b24201f4d51 /media-sound/esound/esound-0.2.32.ebuild
parentnew version (diff)
downloadhistorical-653d48f76eb6de7c5373999dbbcf22ac5dd24b32.tar.gz
historical-653d48f76eb6de7c5373999dbbcf22ac5dd24b32.tar.bz2
historical-653d48f76eb6de7c5373999dbbcf22ac5dd24b32.zip
new version
Diffstat (limited to 'media-sound/esound/esound-0.2.32.ebuild')
-rw-r--r--media-sound/esound/esound-0.2.32.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/media-sound/esound/esound-0.2.32.ebuild b/media-sound/esound/esound-0.2.32.ebuild
new file mode 100644
index 000000000000..9b5146ce5bb3
--- /dev/null
+++ b/media-sound/esound/esound-0.2.32.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/esound/esound-0.2.32.ebuild,v 1.1 2003/09/06 12:01:38 foser Exp $
+
+IUSE="tcpd alsa ipv6"
+
+inherit libtool gnome.org
+
+DESCRIPTION="The Enlightened Sound Daemon"
+
+HOMEPAGE="http://www.tux.org/~ricdude/EsounD.html"
+SLOT="0"
+LICENSE="GPL-2 LGPL-2"
+KEYWORDS="~x86 ~sparc ~ppc ~alpha ~hppa ~amd64"
+
+DEPEND=">=media-libs/audiofile-0.1.5
+ alsa? ( >=media-libs/alsa-lib-0.5.10b )
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6-r2 )"
+
+src_compile() {
+ elibtoolize
+
+ econf \
+ `use_with tcpd libwrap` \
+ `use_enable alsa` \
+ `use_enable ipv6` \
+ --sysconfdir=/etc/esd \
+ ${myconf} || die
+
+ make || die
+}
+
+src_install() {
+ einstall \
+ sysconfdir=${D}/etc/esd \
+ || die
+
+ dodoc AUTHORS COPYING* ChangeLog README TODO NEWS TIPS
+ dodoc docs/esound.ps
+
+ dohtml -r docs/html
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/esound.conf.d esound
+
+ exeinto /etc/init.d
+ extradepend=""
+ use tcpd && extradepend=" portmap"
+ use alsa && extradepend="$extradepend alsasound"
+ sed "s/@extradepend@/$extradepend/" <${FILESDIR}/esound.init.d >${T}/esound
+ doexe ${T}/esound
+
+}
+
+pkg_postinst() {
+ # rebuild init deps to include deps on esound
+ /etc/init.d/depscan.sh
+}
+
+pkg_postrm() {
+ # rebuild init deps to remove deps on esound
+ /etc/init.d/depscan.sh
+}