summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKito Danya Dietrich <kito@gentoo.org>2005-04-21 21:36:41 +0000
committerKito Danya Dietrich <kito@gentoo.org>2005-04-21 21:36:41 +0000
commit991a7fa63abe81a1e7f833929f480336d2a15301 (patch)
treedd289194af0c5cc3927ea8894d60dda20f97c5dc /media-sound/ecasound
parentPackage-Manager: portage-2.0.51.19 (diff)
downloadhistorical-991a7fa63abe81a1e7f833929f480336d2a15301.tar.gz
historical-991a7fa63abe81a1e7f833929f480336d2a15301.tar.bz2
historical-991a7fa63abe81a1e7f833929f480336d2a15301.zip
version bump. closes Bug #87392
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'media-sound/ecasound')
-rw-r--r--media-sound/ecasound/ChangeLog7
-rw-r--r--media-sound/ecasound/Manifest16
-rw-r--r--media-sound/ecasound/ecasound-2.4.1.ebuild94
-rw-r--r--media-sound/ecasound/files/digest-ecasound-2.4.11
4 files changed, 105 insertions, 13 deletions
diff --git a/media-sound/ecasound/ChangeLog b/media-sound/ecasound/ChangeLog
index 3485ea14f29d..9117dd397d48 100644
--- a/media-sound/ecasound/ChangeLog
+++ b/media-sound/ecasound/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/ecasound
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/ecasound/ChangeLog,v 1.27 2005/03/29 09:16:16 luckyduck Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ecasound/ChangeLog,v 1.28 2005/04/21 21:36:41 kito Exp $
+
+*ecasound-2.4.1 (21 Apr 2005)
+
+ 21 Apr 2005; Kito <kito@gentoo.org> +ecasound-2.4.1.ebuild:
+ version bump. closes Bug #87392
*ecasound-2.4.0 (29 Mar 2005)
diff --git a/media-sound/ecasound/Manifest b/media-sound/ecasound/Manifest
index af658e26361e..4f0327313c83 100644
--- a/media-sound/ecasound/Manifest
+++ b/media-sound/ecasound/Manifest
@@ -1,18 +1,10 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 e2dde7f7b26f4a5ca5197827737fdf69 ecasound-2.3.3.ebuild 2810
+MD5 645ef3a7395b7d275bba7fecde7ea5ea ChangeLog 4572
MD5 30e1470186dc77519efe49f24e57034d ecasound-2.3.2.ebuild 2761
+MD5 e2dde7f7b26f4a5ca5197827737fdf69 ecasound-2.3.3.ebuild 2810
MD5 965b9d8fa98e77692e62daf704bbf244 ecasound-2.4.0.ebuild 2812
-MD5 fc039bb35d21f4807522268a15fc7a73 ChangeLog 4449
+MD5 b74be50f2a83731b8295a5f19f1b5b8b ecasound-2.4.1.ebuild 2884
MD5 eadab3941f136b871837953c9d1472d5 metadata.xml 753
MD5 e68dadbc41193dfa31762ee90a4b2271 files/digest-ecasound-2.3.2 66
MD5 92bd0b879f6e514225f5db2a2d474688 files/digest-ecasound-2.3.3 66
MD5 6a3363beab079c4f667c48d887782a04 files/digest-ecasound-2.4.0 66
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.0 (GNU/Linux)
-
-iD8DBQFCSRzv06ebR+OMO78RAlkbAKCXpovUFT2+1rCjNwAuP1zolvC7NwCgiipB
-WJNzrVJdPbkNi25NGAsdy2U=
-=qku7
------END PGP SIGNATURE-----
+MD5 a17b7c260bfe07eb12d6b70ffcfbe01b files/digest-ecasound-2.4.1 67
diff --git a/media-sound/ecasound/ecasound-2.4.1.ebuild b/media-sound/ecasound/ecasound-2.4.1.ebuild
new file mode 100644
index 000000000000..f73b795fb7d4
--- /dev/null
+++ b/media-sound/ecasound/ecasound-2.4.1.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ecasound/ecasound-2.4.1.ebuild,v 1.1 2005/04/21 21:36:41 kito Exp $
+
+IUSE="ncurses arts alsa python oss mikmod oggvorbis jack audiofile"
+
+DESCRIPTION="A package for multitrack audio processing"
+SRC_URI="http://ecasound.seul.org/download/${P}.tar.gz"
+HOMEPAGE="http://eca.cx/"
+LICENSE="GPL-2"
+
+SLOT="1"
+KEYWORDS="~x86 ~sparc ~ppc ~amd64 ~ppc-macos"
+
+DEPEND="jack? ( media-sound/jack-audio-connection-kit )
+ media-libs/ladspa-sdk
+ audiofile? ( media-libs/audiofile )
+ alsa? ( media-libs/alsa-lib )
+ oggvorbis? ( media-libs/libvorbis )
+ arts? ( kde-base/arts )
+ mikmod? ( media-libs/libmikmod )
+ python? ( dev-lang/python )
+ ncurses? ( sys-libs/ncurses )"
+
+# We don't make RDEPEND for vorbis-tools, mpg123/mpg321, timidity++ or lame -- no
+# use flags for them.
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ sed -i 's:map.h:map:g' configure
+}
+
+src_compile () {
+ local myconf
+
+ use jack || myconf="$myconf --disable-jack"
+ use alsa || myconf="$myconf --disable-alsa"
+ use arts || myconf="$myconf --disable-arts"
+ use ncurses || myconf="$myconf --disable-ncurses"
+ use audiofile || myconf="$myconf --disable-audiofile"
+ use oss || myconf="$myconf --disable-oss"
+
+ use amd64 && myconf="${myconf} --with-pic"
+
+ if use python; then
+ #
+ # ecasound is braindead about finding python includes/libdirs and
+ # about where to install modules. Luckily, it allows us to specify
+ # all this.
+ #
+ local python_version python_prefix python_includes python_modules
+ python_version="`python -c 'import sys; print sys.version[:3]'`"
+ python_prefix="`python -c 'import sys; print sys.prefix'`"
+
+ python_includes="$python_prefix/include/python$python_version"
+ python_modules="$python_prefix/lib/python$python_version"
+
+ myconf="$myconf --with-python-includes=$python_includes"
+ myconf="$myconf --with-python-modules=$python_modules"
+ else
+ myconf="$myconf --disable-pyecasound"
+ fi
+
+ einfo "configuring with ${myconf}"
+ econf ${myconf} || die "configure failed"
+ make || die "build failed"
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ if use python; then
+ cd pyecasound || die
+ python -c "import compileall; compileall.compile_dir('.')" || die
+ python -O -c "import compileall; compileall.compile_dir('.')" || die
+ python_sitepkgsdir="`python -c "import sys; print (sys.prefix + '/lib/python' + sys.version[:3] + '/site-packages/')"`"
+ install *.pyc *.pyo "${D}/${python_sitepkgsdir}"
+ cd ..
+ fi
+
+ dodoc INSTALL FAQ BUGS COPYING NEWS README TODO
+ dohtml `find Documentation -name "*.html"`
+ dodoc Documentation/edi-list.txt
+}
+
+pkg_postinst() {
+ if use arts; then
+ ewarn "WARNING: You have requested ecasound ARTS support, "
+ ewarn "this is no longer supported and may go away in "
+ ewarn "future releases. "
+ fi
+}
diff --git a/media-sound/ecasound/files/digest-ecasound-2.4.1 b/media-sound/ecasound/files/digest-ecasound-2.4.1
new file mode 100644
index 000000000000..038cd056ae3c
--- /dev/null
+++ b/media-sound/ecasound/files/digest-ecasound-2.4.1
@@ -0,0 +1 @@
+MD5 48b75215252d21dddf5216cae27a5f4b ecasound-2.4.1.tar.gz 1103065