summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2005-12-25 13:03:50 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2005-12-25 13:03:50 +0000
commit0edda02b91bfd941337d7006ff60174539d1aab9 (patch)
tree521e16213db60d56311f78949a105f73480884ed /media-sound/amarok
parentfix bug 114549 for latest stable too (diff)
downloadhistorical-0edda02b91bfd941337d7006ff60174539d1aab9.tar.gz
historical-0edda02b91bfd941337d7006ff60174539d1aab9.tar.bz2
historical-0edda02b91bfd941337d7006ff60174539d1aab9.zip
Add patch to fix lyrics display, thanks to Ian Monroe for letting me know.
Package-Manager: portage-2.1_pre2
Diffstat (limited to 'media-sound/amarok')
-rw-r--r--media-sound/amarok/ChangeLog8
-rw-r--r--media-sound/amarok/Manifest15
-rw-r--r--media-sound/amarok/amarok-1.3.7-r1.ebuild103
-rw-r--r--media-sound/amarok/files/amarok-1.3.7-lyrc.patch15
-rw-r--r--media-sound/amarok/files/digest-amarok-1.3.7-r11
5 files changed, 140 insertions, 2 deletions
diff --git a/media-sound/amarok/ChangeLog b/media-sound/amarok/ChangeLog
index 9fd7432caaa7..ce72f12a4bc6 100644
--- a/media-sound/amarok/ChangeLog
+++ b/media-sound/amarok/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/amarok
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/ChangeLog,v 1.92 2005/12/24 15:57:41 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/ChangeLog,v 1.93 2005/12/25 13:03:50 flameeyes Exp $
+
+*amarok-1.3.7-r1 (25 Dec 2005)
+
+ 25 Dec 2005; Diego Pettenò <flameeyes@gentoo.org>
+ +files/amarok-1.3.7-lyrc.patch, +amarok-1.3.7-r1.ebuild:
+ Add patch to fix lyrics display, thanks to Ian Monroe for letting me know.
24 Dec 2005; Michael Hanselmann <hansmi@gentoo.org> amarok-1.3.6.ebuild:
Stable on ppc.
diff --git a/media-sound/amarok/Manifest b/media-sound/amarok/Manifest
index 1a386cb40cb2..5d59eed5e041 100644
--- a/media-sound/amarok/Manifest
+++ b/media-sound/amarok/Manifest
@@ -1,9 +1,22 @@
-MD5 124d8d2b331cc5c8cc27fc8b06cf536f ChangeLog 14598
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 e6ca4975b672ac00057ec272451bbce7 ChangeLog 14823
MD5 fae91b0167ef3ca3233931dbb86a52e9 amarok-1.2.4.ebuild 2385
MD5 e2b134909d4ab6144cf63677a3675894 amarok-1.3.6.ebuild 3208
+MD5 bf6ccd5ec77ae77629233b7f3d9ce921 amarok-1.3.7-r1.ebuild 3353
MD5 596553f12c5536b39214465e6223fae0 amarok-1.3.7.ebuild 3309
+MD5 540d52ae55cc72876ea41f14032b6abf files/amarok-1.3.7-lyrc.patch 869
MD5 32030194ea3f2079d1db17aa160f63a2 files/amarok-gcc4.gz 522
MD5 9966964d087dd7c05b7fa2efeff9b1ac files/digest-amarok-1.2.4 66
MD5 d8cfb3a78866379e2ac9b439de887551 files/digest-amarok-1.3.6 66
MD5 cbac7ded5054d6932dda9754aa7d8aa7 files/digest-amarok-1.3.7 66
+MD5 cbac7ded5054d6932dda9754aa7d8aa7 files/digest-amarok-1.3.7-r1 66
MD5 b23600108f12c98a4fd574d3487ee598 metadata.xml 175
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.2 (GNU/Linux)
+
+iD8DBQFDrpjJAiZjviIA2XgRAh67AKDfbg5BPUec9CgvIbXPsA74b466uACg3C7k
+tmwi5g1w/InWvBj6W8t5Ot0=
+=Jqce
+-----END PGP SIGNATURE-----
diff --git a/media-sound/amarok/amarok-1.3.7-r1.ebuild b/media-sound/amarok/amarok-1.3.7-r1.ebuild
new file mode 100644
index 000000000000..8fa009ae8e93
--- /dev/null
+++ b/media-sound/amarok/amarok-1.3.7-r1.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/amarok-1.3.7-r1.ebuild,v 1.1 2005/12/25 13:03:50 flameeyes Exp $
+
+inherit kde eutils flag-o-matic
+
+MY_P="${P/_rc/-rc}"
+S="${WORKDIR}/${P/_rc*//}"
+
+DESCRIPTION="amaroK - the audio player for KDE."
+HOMEPAGE="http://amarok.kde.org/"
+SRC_URI="mirror://sourceforge/amarok/${MY_P}.tar.bz2"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="arts flac gstreamer kde mp3 mysql noamazon opengl postgres xine xmms
+visualization vorbis musicbrainz"
+# kde: enables compilation of the konqueror sidebar plugin
+
+DEPEND="kde? ( || ( kde-base/konqueror kde-base/kdebase ) )
+ arts? ( kde-base/arts
+ || ( kde-base/kdemultimedia-arts kde-base/kdemultimedia ) )
+ xine? ( >=media-libs/xine-lib-1_rc4 )
+ gstreamer? ( =media-libs/gstreamer-0.8*
+ =media-libs/gst-plugins-0.8* )
+ musicbrainz? ( =media-libs/tunepimp-0.3* )
+ >=media-libs/taglib-1.4
+ mysql? ( >=dev-db/mysql-4.0.16 )
+ postgres? ( dev-db/postgresql )
+ opengl? ( virtual/opengl )
+ xmms? ( >=media-sound/xmms-1.2 )
+ visualization? ( media-libs/libsdl
+ >=media-plugins/libvisual-plugins-0.2 )"
+
+RDEPEND="${DEPEND}
+ gstreamer? ( mp3? ( =media-plugins/gst-plugins-mad-0.8* )
+ vorbis? ( =media-plugins/gst-plugins-ogg-0.8*
+ =media-plugins/gst-plugins-vorbis-0.8* )
+ flac? ( =media-plugins/gst-plugins-flac-0.8* ) )"
+
+DEPEND="${DEPEND}
+ >=dev-util/pkgconfig-0.9.0"
+
+PATCHES="${FILESDIR}/${P}-lyrc.patch"
+
+need-kde 3.3
+
+pkg_setup() {
+ if use arts && ! use xine && ! use gstreamer; then
+ ewarn "aRts support is deprecated, if you have problems please consider"
+ ewarn "enabling support for Xine (preferred) or GStreamer"
+ ewarn "(emerge amarok again with USE=\"xine\" or USE=\"gstreamer\")."
+ ebeep 2
+ fi
+
+ if ! use arts && ! use xine && ! use gstreamer; then
+ eerror "amaroK needs either aRts (deprecated), Xine (preferred) or GStreamer to work,"
+ eerror "please try again with USE=\"arts\", USE=\"xine\" or USE=\"gstreamer\"."
+ die
+ fi
+
+ # check whether kdelibs was compiled with arts support
+ kde_pkg_setup
+
+ append-flags -fno-inline
+}
+
+src_compile() {
+ # amarok does not respect kde coding standards, and makes a lot of
+ # assuptions regarding its installation directory. For this reason,
+ # it must be installed in the KDE install directory.
+ PREFIX="${KDEDIR}"
+
+ # Extra, unsupported engines are forcefully disabled.
+ local myconf="$(use_with arts) $(use_with xine) $(use_with gstreamer)
+ $(use_enable mysql) $(use_enable postgres postgresql)
+ $(use_with opengl) $(use_with xmms)
+ $(use_with visualization libvisual)
+ $(use_enable !noamazon amazon)
+ $(use_with musicbrainz)
+ --without-helix
+ --without-mas
+ --without-nmm"
+
+ kde_src_compile
+}
+
+src_install() {
+ kde_src_install
+
+ # Workaround to use amaroK from outside KDE
+
+ # move the desktop file in /usr/share
+ dodir /usr/share/applications/kde
+ mv ${D}${KDEDIR}/share/applications/kde/amarok.desktop \
+ ${D}/usr/share/applications/kde/amarok.desktop || die
+ # move icons, too
+ dodir /usr/share/icons
+ mv ${D}${KDEDIR}/share/icons/hicolor \
+ ${D}/usr/share/icons || die
+}
+
diff --git a/media-sound/amarok/files/amarok-1.3.7-lyrc.patch b/media-sound/amarok/files/amarok-1.3.7-lyrc.patch
new file mode 100644
index 000000000000..7fa6f6a5a2e9
--- /dev/null
+++ b/media-sound/amarok/files/amarok-1.3.7-lyrc.patch
@@ -0,0 +1,15 @@
+--- branches/stable/extragear/multimedia/amarok/src/contextbrowser.cpp 2005/10/24 00:55:23 473539
++++ branches/stable/extragear/multimedia/amarok/src/contextbrowser.cpp 2005/12/15 19:57:48 488756
+@@ -2534,9 +2534,10 @@
+ m_lyrics.replace( QRegExp("<[iI][mM][gG][^>]*>"), QString::null );
+ m_lyrics.replace( QRegExp("<[sS][cC][rR][iI][pP][tT][^>]*>[^<]*(<!--[^>]*>)*[^<]*</[sS][cC][rR][iI][pP][tT]>"), QString::null );
+
+- if ( m_lyrics.find( "<font size='2'>" ) != -1 )
++ int lyricsPos = m_lyrics.find( QRegExp( "<[fF][oO][nN][tT][ ]*[sS][iI][zZ][eE][ ]*='2'[ ]*>" ) );
++ if ( lyricsPos != -1 )
+ {
+- m_lyrics = m_lyrics.mid( m_lyrics.find( "<font size='2'>" ) );
++ m_lyrics = m_lyrics.mid( lyricsPos );
+ if ( m_lyrics.find( "<p><hr" ) != -1 )
+ m_lyrics = m_lyrics.mid( 0, m_lyrics.find( "<p><hr" ) );
+ else
diff --git a/media-sound/amarok/files/digest-amarok-1.3.7-r1 b/media-sound/amarok/files/digest-amarok-1.3.7-r1
new file mode 100644
index 000000000000..5c1c70976b8f
--- /dev/null
+++ b/media-sound/amarok/files/digest-amarok-1.3.7-r1
@@ -0,0 +1 @@
+MD5 e2297042070643c105f8bb0e524c73ad amarok-1.3.7.tar.bz2 8591963