summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-02-12 11:47:42 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-02-12 11:47:42 +0000
commitf666428cacc14e6c8240aba1ac18909ff93d76de (patch)
treed21343b11a8e233740d23a1a0deffcda2f315680 /media-plugins/xmms-mp3cue
parentAdded Plastik theme to close bug #29122. Stable on x86 (diff)
downloadhistorical-f666428cacc14e6c8240aba1ac18909ff93d76de.tar.gz
historical-f666428cacc14e6c8240aba1ac18909ff93d76de.tar.bz2
historical-f666428cacc14e6c8240aba1ac18909ff93d76de.zip
adds cue file support to XMMS. Cue files store information (Artist, Title, Time) describing smaller tracks within a large audio file. Ebuild submitted by Alexandre Veyrenc <veyrenc@wanadoo.fr> in bug #33143.
Diffstat (limited to 'media-plugins/xmms-mp3cue')
-rw-r--r--media-plugins/xmms-mp3cue/ChangeLog12
-rw-r--r--media-plugins/xmms-mp3cue/Manifest5
-rw-r--r--media-plugins/xmms-mp3cue/files/digest-xmms-mp3cue-0.941
-rw-r--r--media-plugins/xmms-mp3cue/files/xmms-mp3cue-0.94-import-cue-bug.patch11
-rw-r--r--media-plugins/xmms-mp3cue/metadata.xml5
-rw-r--r--media-plugins/xmms-mp3cue/xmms-mp3cue-0.94.ebuild39
6 files changed, 73 insertions, 0 deletions
diff --git a/media-plugins/xmms-mp3cue/ChangeLog b/media-plugins/xmms-mp3cue/ChangeLog
new file mode 100644
index 000000000000..3c0fbb1c5dd4
--- /dev/null
+++ b/media-plugins/xmms-mp3cue/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for media-plugins/xmms-mp3cue
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/xmms-mp3cue/ChangeLog,v 1.1 2004/02/12 11:47:42 eradicator Exp $
+
+*xmms-mp3cue-0.94 (12 Feb 2004)
+
+ 12 Feb 2004; Jeremy Huddleston <eradicator@gentoo.org> metadata.xml,
+ xmms-mp3cue-0.94.ebuild:
+ adds cue file support to XMMS. Cue files store information (Artist, Title,
+ Time) describing smaller tracks within a large audio file. Ebuild submitted by
+ Alexandre Veyrenc <veyrenc@wanadoo.fr> in bug #33143.
+
diff --git a/media-plugins/xmms-mp3cue/Manifest b/media-plugins/xmms-mp3cue/Manifest
new file mode 100644
index 000000000000..553607bb5552
--- /dev/null
+++ b/media-plugins/xmms-mp3cue/Manifest
@@ -0,0 +1,5 @@
+MD5 0c0b2ff60ce1a2e702416348397de186 xmms-mp3cue-0.94.ebuild 881
+MD5 93a48ad1cffa3f061b7b3269fc1ed4d7 ChangeLog 582
+MD5 a1eaeb2ae801daeb712c90c060e922dc metadata.xml 158
+MD5 a999c9cc61b7b3870eeb0563c19777b3 files/xmms-mp3cue-0.94-import-cue-bug.patch 305
+MD5 da4013df13aba0eb6fcf0610a6686418 files/digest-xmms-mp3cue-0.94 67
diff --git a/media-plugins/xmms-mp3cue/files/digest-xmms-mp3cue-0.94 b/media-plugins/xmms-mp3cue/files/digest-xmms-mp3cue-0.94
new file mode 100644
index 000000000000..cce5b1f1259c
--- /dev/null
+++ b/media-plugins/xmms-mp3cue/files/digest-xmms-mp3cue-0.94
@@ -0,0 +1 @@
+MD5 d6f93194a60a2d9e8985e3939777c1c6 XMMS-mp3cue-0.94.tar.gz 38962
diff --git a/media-plugins/xmms-mp3cue/files/xmms-mp3cue-0.94-import-cue-bug.patch b/media-plugins/xmms-mp3cue/files/xmms-mp3cue-0.94-import-cue-bug.patch
new file mode 100644
index 000000000000..e7baeb1efeca
--- /dev/null
+++ b/media-plugins/xmms-mp3cue/files/xmms-mp3cue-0.94-import-cue-bug.patch
@@ -0,0 +1,11 @@
+--- cuesheet.c.orig 2003-10-22 10:23:00.000000000 +0200
++++ cuesheet.c 2004-01-27 14:33:23.000000000 +0100
+@@ -99,6 +99,8 @@
+ {
+ gchar *cue_name, *temp;
+
++ if (o_fname==NULL) return NULL;
++
+ //find the extension
+ for(temp = o_fname+strlen(o_fname)-1; *temp != '.' && temp != o_fname; temp--);
+
diff --git a/media-plugins/xmms-mp3cue/metadata.xml b/media-plugins/xmms-mp3cue/metadata.xml
new file mode 100644
index 000000000000..e1774e3d9ad7
--- /dev/null
+++ b/media-plugins/xmms-mp3cue/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sound</herd>
+</pkgmetadata>
diff --git a/media-plugins/xmms-mp3cue/xmms-mp3cue-0.94.ebuild b/media-plugins/xmms-mp3cue/xmms-mp3cue-0.94.ebuild
new file mode 100644
index 000000000000..64f9509645c9
--- /dev/null
+++ b/media-plugins/xmms-mp3cue/xmms-mp3cue-0.94.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/xmms-mp3cue/xmms-mp3cue-0.94.ebuild,v 1.1 2004/02/12 11:47:42 eradicator Exp $
+
+DESCRIPTION="cue file support for XMMS"
+HOMEPAGE="http://brianvictor.tripod.com/mp3cue.htm"
+SRC_URI="http://brianvictor.tripod.com/XMMS-mp3cue-${PV}.tar.gz"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+IUSE="debug"
+
+S=${WORKDIR}/XMMS-mp3cue-${PV}
+
+DEPEND=">=media-sound/xmms-1.2.7-r20
+ sys-apps/sed"
+
+RDEPEND=">=media-sound/xmms-1.2.7-r20"
+
+DOCS="Changelog INSTALL README TODO"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S};
+
+ if use debug; then
+ sed -i 's/DEBUG := n/DEBUG := y/g' Makefile.in
+ fi
+
+ epatch ${FILESDIR}/${P}-import-cue-bug.patch
+}
+
+src_install() {
+ exeinto `xmms-config --general-plugin-dir`
+ doexe libmp3cue.so
+
+ dodoc ${DOCS}
+}