summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-01-10 08:24:33 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-01-10 08:24:33 +0000
commit9a0a0712ee8997e883afea2d838a26e0b2c67778 (patch)
tree0670e88f6200774b9f27318b6bebbf02f9044ecc /media-plugins/swh-lv2/swh-lv2-1.0.15.ebuild
parentversion bump (diff)
downloadhistorical-9a0a0712ee8997e883afea2d838a26e0b2c67778.tar.gz
historical-9a0a0712ee8997e883afea2d838a26e0b2c67778.tar.bz2
historical-9a0a0712ee8997e883afea2d838a26e0b2c67778.zip
version bump
Package-Manager: portage-2.1.4_rc14
Diffstat (limited to 'media-plugins/swh-lv2/swh-lv2-1.0.15.ebuild')
-rw-r--r--media-plugins/swh-lv2/swh-lv2-1.0.15.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/media-plugins/swh-lv2/swh-lv2-1.0.15.ebuild b/media-plugins/swh-lv2/swh-lv2-1.0.15.ebuild
new file mode 100644
index 000000000000..850c921e3327
--- /dev/null
+++ b/media-plugins/swh-lv2/swh-lv2-1.0.15.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/swh-lv2/swh-lv2-1.0.15.ebuild,v 1.1 2008/01/10 08:24:32 aballier Exp $
+
+inherit toolchain-funcs multilib
+
+DESCRIPTION="Large collection of LV2 audio plugins/effects"
+HOMEPAGE="http://plugin.org.uk/"
+SRC_URI="http://plugin.org.uk/lv2/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="=sci-libs/fftw-3*"
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ dev-util/pkgconfig"
+
+src_compile() {
+ emake CC=$(tc-getCC) || die "make failed"
+}
+
+src_install() {
+ emake INSTALL_DIR="${D}/usr/$(get_libdir)/lv2" install-system || die "failed to install"
+ dodoc README
+}