summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Loeser <halcy0n@gentoo.org>2006-06-06 03:36:50 +0000
committerMark Loeser <halcy0n@gentoo.org>2006-06-06 03:36:50 +0000
commitb3b6ae5cd3b94efe724ec1fc3bd3f066555cf00e (patch)
tree37ce0c54a4c458ca26c37e0bdf97f9ed835e84a5 /media-plugins/mythphone
parentRe-added support for links (bug #134894). (diff)
downloadhistorical-b3b6ae5cd3b94efe724ec1fc3bd3f066555cf00e.tar.gz
historical-b3b6ae5cd3b94efe724ec1fc3bd3f066555cf00e.tar.bz2
historical-b3b6ae5cd3b94efe724ec1fc3bd3f066555cf00e.zip
Add patch to fix compilation with gcc-4.1 by Stephen Bridges <widget AT stdin DOT co DOT uk>; bug #132453
Package-Manager: portage-2.1_rc3-r2
Diffstat (limited to 'media-plugins/mythphone')
-rw-r--r--media-plugins/mythphone/ChangeLog7
-rw-r--r--media-plugins/mythphone/files/mythphone-0.19-gcc41.patch22
-rw-r--r--media-plugins/mythphone/mythphone-0.19.ebuild9
3 files changed, 35 insertions, 3 deletions
diff --git a/media-plugins/mythphone/ChangeLog b/media-plugins/mythphone/ChangeLog
index b485e5039425..145d2a5c7f28 100644
--- a/media-plugins/mythphone/ChangeLog
+++ b/media-plugins/mythphone/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-plugins/mythphone
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythphone/ChangeLog,v 1.12 2006/05/29 06:03:24 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythphone/ChangeLog,v 1.13 2006/06/06 03:36:27 halcy0n Exp $
+
+ 06 Jun 2006; Mark Loeser <halcy0n@gentoo.org>
+ +files/mythphone-0.19-gcc41.patch, mythphone-0.19.ebuild:
+ Add patch to fix compilation with gcc-4.1 by Stephen Bridges <widget AT
+ stdin DOT co DOT uk>; bug #132453
29 May 2006; Doug Goldstein <cardoe@gentoo.org> -mythphone-0.18.1.ebuild:
getting rid of old stuff
diff --git a/media-plugins/mythphone/files/mythphone-0.19-gcc41.patch b/media-plugins/mythphone/files/mythphone-0.19-gcc41.patch
new file mode 100644
index 000000000000..62469573ec5f
--- /dev/null
+++ b/media-plugins/mythphone/files/mythphone-0.19-gcc41.patch
@@ -0,0 +1,22 @@
+--- mythplugins-0.19/mythphone/mythphone/sipfsm.orig.h 2006-05-06 15:00:23.000000000 +0100
++++ mythplugins-0.19/mythphone/mythphone/sipfsm.h 2006-05-06 15:00:58.000000000 +0100
+@@ -618,7 +618,7 @@
+ SipWatcher *CreateWatcherFsm(QString Url);
+ SipIM *CreateIMFsm(QString Url="", QString callIdStr="");
+ void StopWatchers();
+- void SipFsm::KickWatcher(SipUrl *Url);
++ void KickWatcher(SipUrl *Url);
+ void SendIM(QString destUrl, QString CallId, QString imMsg);
+ int numCalls();
+ int getPrimaryCall() { return primaryCall; };
+--- mythplugins-0.19/mythphone/mythphone/vxml.orig.h 2006-05-06 15:01:16.000000000 +0100
++++ mythplugins-0.19/mythphone/mythphone/vxml.h 2006-05-06 15:01:33.000000000 +0100
+@@ -10,7 +10,7 @@
+ {
+ public:
+ vxmlVariable(QString N, QString V);
+- vxmlVariable::vxmlVariable(QString N, short *wav, int S);
++ vxmlVariable(QString N, short *wav, int S);
+ virtual ~vxmlVariable() {};
+ bool isType(QString t) { return (t == Type); };
+ QString getName() { return Name; };
diff --git a/media-plugins/mythphone/mythphone-0.19.ebuild b/media-plugins/mythphone/mythphone-0.19.ebuild
index 1ab2b52b7dfa..2cfee2c9426e 100644
--- a/media-plugins/mythphone/mythphone-0.19.ebuild
+++ b/media-plugins/mythphone/mythphone-0.19.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythphone/mythphone-0.19.ebuild,v 1.1 2006/02/12 10:36:17 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythphone/mythphone-0.19.ebuild,v 1.2 2006/06/06 03:36:27 halcy0n Exp $
-inherit mythtv-plugins
+inherit eutils mythtv-plugins
DESCRIPTION="Phone and video calls with SIP."
HOMEPAGE="http://www.mythtv.org/"
@@ -16,3 +16,8 @@ RDEPEND="festival? ( app-accessibility/festival )"
DEPEND="${DEPEND}"
MTVCONF=$(use_enable festival)
+
+src_unpack() {
+ mythtv-plugins_src_unpack
+ epatch "${FILESDIR}"/${P}-gcc41.patch
+}