summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Loeser <halcy0n@gentoo.org>2006-06-06 03:36:50 +0000
committerMark Loeser <halcy0n@gentoo.org>2006-06-06 03:36:50 +0000
commitb3b6ae5cd3b94efe724ec1fc3bd3f066555cf00e (patch)
tree37ce0c54a4c458ca26c37e0bdf97f9ed835e84a5 /media-plugins/mythgame
parentRe-added support for links (bug #134894). (diff)
downloadhistorical-b3b6ae5cd3b94efe724ec1fc3bd3f066555cf00e.tar.gz
historical-b3b6ae5cd3b94efe724ec1fc3bd3f066555cf00e.tar.bz2
historical-b3b6ae5cd3b94efe724ec1fc3bd3f066555cf00e.zip
Add patch to fix compilation with gcc-4.1 by Stephen Bridges <widget AT stdin DOT co DOT uk>; bug #132453
Package-Manager: portage-2.1_rc3-r2
Diffstat (limited to 'media-plugins/mythgame')
-rw-r--r--media-plugins/mythgame/ChangeLog7
-rw-r--r--media-plugins/mythgame/files/mythgame-0.19-gcc41.patch11
-rw-r--r--media-plugins/mythgame/mythgame-0.19.ebuild9
3 files changed, 24 insertions, 3 deletions
diff --git a/media-plugins/mythgame/ChangeLog b/media-plugins/mythgame/ChangeLog
index 67b0be0d5f12..622f548e46a7 100644
--- a/media-plugins/mythgame/ChangeLog
+++ b/media-plugins/mythgame/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-plugins/mythgame
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythgame/ChangeLog,v 1.31 2006/05/29 06:05:46 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythgame/ChangeLog,v 1.32 2006/06/06 03:35:57 halcy0n Exp $
+
+ 06 Jun 2006; Mark Loeser <halcy0n@gentoo.org>
+ +files/mythgame-0.19-gcc41.patch, mythgame-0.19.ebuild:
+ Add patch to fix compilation with gcc-4.1 by Stephen Bridges <widget AT
+ stdin DOT co DOT uk>; bug #132453
29 May 2006; Doug Goldstein <cardoe@gentoo.org> -mythgame-0.18.1.ebuild:
getting rid of old stuff
diff --git a/media-plugins/mythgame/files/mythgame-0.19-gcc41.patch b/media-plugins/mythgame/files/mythgame-0.19-gcc41.patch
new file mode 100644
index 000000000000..f4e465b05ee9
--- /dev/null
+++ b/media-plugins/mythgame/files/mythgame-0.19-gcc41.patch
@@ -0,0 +1,11 @@
+--- mythplugins-0.19/mythgame/mythgame/gamehandler.h.orig 2006-05-06 10:33:44.000000000 +0100
++++ mythplugins-0.19/mythgame/mythgame/gamehandler.h 2006-05-06 10:33:59.000000000 +0100
+@@ -106,7 +106,7 @@
+
+ protected:
+ static GameHandler* GetHandler(RomInfo *rominfo);
+- static GameHandler* GameHandler::GetHandlerByName(QString systemname);
++ static GameHandler* GetHandlerByName(QString systemname);
+
+ bool rebuild;
+ int spandisks;
diff --git a/media-plugins/mythgame/mythgame-0.19.ebuild b/media-plugins/mythgame/mythgame-0.19.ebuild
index d6b36904576c..e434cb3aeec1 100644
--- a/media-plugins/mythgame/mythgame-0.19.ebuild
+++ b/media-plugins/mythgame/mythgame-0.19.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythgame/mythgame-0.19.ebuild,v 1.2 2006/02/12 10:32:10 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythgame/mythgame-0.19.ebuild,v 1.3 2006/06/06 03:35:57 halcy0n Exp $
-inherit mythtv-plugins
+inherit eutils mythtv-plugins
DESCRIPTION="Game emulator module for MythTV."
HOMEPAGE="http://www.mythtv.org/"
@@ -15,6 +15,11 @@ KEYWORDS="~amd64 ~ppc ~x86"
RDEPEND="sys-libs/zlib"
DEPEND="${RDEPEND}"
+src_unpack() {
+ mythtv-plugins_src_unpack
+ epatch "${FILESDIR}"/${P}-gcc41.patch
+}
+
src_install () {
mythtv-plugins_src_install || die "install failed"