summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-09-27 23:29:54 +0000
committerMike Frysinger <vapier@gentoo.org>2005-09-27 23:29:54 +0000
commitdba2b6984eee3e87007b412257fb8c2a9a29357b (patch)
treeebbbb342304948165bb5fc8c702cfd73b6e0a3c3 /media-libs
parentmake sure build system parses $LINUXSVGALIB correctly #107346 (diff)
downloadhistorical-dba2b6984eee3e87007b412257fb8c2a9a29357b.tar.gz
historical-dba2b6984eee3e87007b412257fb8c2a9a29357b.tar.bz2
historical-dba2b6984eee3e87007b412257fb8c2a9a29357b.zip
force --disable-nasm when USE=pic
Package-Manager: portage-2.0.52-r1 http://www.bash.org/?136501
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libsdl/Manifest10
-rw-r--r--media-libs/libsdl/libsdl-1.2.8-r1.ebuild12
-rw-r--r--media-libs/libsdl/libsdl-1.2.9.ebuild12
3 files changed, 19 insertions, 15 deletions
diff --git a/media-libs/libsdl/Manifest b/media-libs/libsdl/Manifest
index 29b0b8f26b7f..f7c00089cab9 100644
--- a/media-libs/libsdl/Manifest
+++ b/media-libs/libsdl/Manifest
@@ -2,10 +2,10 @@
Hash: SHA1
MD5 baaaa69f33ef9027dac84ee4ff02773b metadata.xml 974
-MD5 261c3293614de324ddf1cba93df5532d libsdl-1.2.9.ebuild 4354
+MD5 96168a25267b9eb1915d1a65f7c66239 libsdl-1.2.9.ebuild 4412
MD5 7f079469132865bdd25780277639f098 libsdl-1.2.7-r3.ebuild 3960
MD5 cbbab78f5125f834ffb0f83be4957736 libsdl-1.2.6-r3.ebuild 3013
-MD5 dbdeaeeccb0fc56ff9637bdfa9096406 libsdl-1.2.8-r1.ebuild 4946
+MD5 4e4caa64c5b89522b2f0e284282eafe6 libsdl-1.2.8-r1.ebuild 5004
MD5 46e5fda293379b677832beab230dacd4 ChangeLog 13447
MD5 4f1ce33c931d461bed06277f60341085 files/1.2.8-nobuggy-X.patch 568
MD5 e0c6c6ffc15475282fc864b8f52f0abf files/1.2.8-linux26.patch 1268
@@ -35,7 +35,7 @@ MD5 206ddd08dd3e33819d03245d11af3014 files/1.2.7-gcc34.patch 8196
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)
-iD8DBQFDH3XDgIKl8Uu19MoRAqiVAJ4nTgKsJtFFoJGYFezHBtPxaeAeCgCeLB1u
-0GrWcsdMYmAZ7EbJw/SzUpg=
-=Lm1L
+iD8DBQFDOdYsgIKl8Uu19MoRAnMkAJ4iysOGfad+dJYsogd6pJSYXfi0wACfbarp
+vi2u7aQ9TWSR+52ADWgEGQY=
+=wPl0
-----END PGP SIGNATURE-----
diff --git a/media-libs/libsdl/libsdl-1.2.8-r1.ebuild b/media-libs/libsdl/libsdl-1.2.8-r1.ebuild
index 9a2ebfbb8091..835c9a4913a8 100644
--- a/media-libs/libsdl/libsdl-1.2.8-r1.ebuild
+++ b/media-libs/libsdl/libsdl-1.2.8-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.8-r1.ebuild,v 1.20 2005/09/07 23:19:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.8-r1.ebuild,v 1.21 2005/09/27 23:29:54 vapier Exp $
inherit flag-o-matic toolchain-funcs eutils
@@ -78,10 +78,12 @@ src_unpack() {
src_compile() {
local myconf=
- if use x86 ; then
- # silly bundled asm triggers TEXTREL ... maybe someday
- # i'll fix this properly, but for now hide with USE=pic
- use pic || myconf="${myconf} $(use_enable x86 nasm)"
+ # silly bundled asm triggers TEXTREL ... maybe someday
+ # i'll fix this properly, but for now hide with USE=pic
+ if [[ $(tc-arch) != "x86" ]] || use pic ; then
+ myconf="${myconf} --disable-nasm"
+ else
+ myconf="${myconf} $(use_enable x86 nasm)"
fi
use noflagstrip || strip-flags
use noaudio && myconf="${myconf} --disable-audio"
diff --git a/media-libs/libsdl/libsdl-1.2.9.ebuild b/media-libs/libsdl/libsdl-1.2.9.ebuild
index 3db8bc34108a..731782b009bc 100644
--- a/media-libs/libsdl/libsdl-1.2.9.ebuild
+++ b/media-libs/libsdl/libsdl-1.2.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.9.ebuild,v 1.4 2005/09/07 23:19:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.9.ebuild,v 1.5 2005/09/27 23:29:54 vapier Exp $
inherit flag-o-matic toolchain-funcs eutils
@@ -68,10 +68,12 @@ src_unpack() {
src_compile() {
local myconf=
- if use x86 ; then
- # silly bundled asm triggers TEXTREL ... maybe someday
- # i'll fix this properly, but for now hide with USE=pic
- use pic || myconf="${myconf} $(use_enable x86 nasm)"
+ # silly bundled asm triggers TEXTREL ... maybe someday
+ # i'll fix this properly, but for now hide with USE=pic
+ if [[ $(tc-arch) != "x86" ]] || use pic ; then
+ myconf="${myconf} --disable-nasm"
+ else
+ myconf="${myconf} $(use_enable x86 nasm)"
fi
use noflagstrip || strip-flags
use noaudio && myconf="${myconf} --disable-audio"