summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2003-03-15 04:30:04 +0000
committerLuca Barbato <lu_zero@gentoo.org>2003-03-15 04:30:04 +0000
commit29268ef4009871a90167d8d559b82c72ec1fd330 (patch)
tree7149267ab34b62657c0ad643c0fefdebd5ea5aa4 /media-libs/tse3/tse3-0.2.7.ebuild
parentpeace out glibc2.3.2, i pwn j00...errno is fixed... (diff)
downloadhistorical-29268ef4009871a90167d8d559b82c72ec1fd330.tar.gz
historical-29268ef4009871a90167d8d559b82c72ec1fd330.tar.bz2
historical-29268ef4009871a90167d8d559b82c72ec1fd330.zip
New Version
Diffstat (limited to 'media-libs/tse3/tse3-0.2.7.ebuild')
-rw-r--r--media-libs/tse3/tse3-0.2.7.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/media-libs/tse3/tse3-0.2.7.ebuild b/media-libs/tse3/tse3-0.2.7.ebuild
new file mode 100644
index 000000000000..13fbf3c2159a
--- /dev/null
+++ b/media-libs/tse3/tse3-0.2.7.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/media-libs/tse3/tse3-0.2.7.ebuild,v 1.1 2003/03/15 04:30:04 lu_zero Exp $
+
+S="${WORKDIR}/${P}"
+IUSE="alsa oss arts"
+DESCRIPTION="TSE3 Sequencer library"
+SRC_URI="mirror://sourceforge/tse3/${P}.tar.gz"
+HOMEPAGE="http://TSE3.sourceforge.net/"
+SLOT="0"
+KEYWORDS="~x86"
+LICENSE="GPL-2"
+
+DEPEND="alsa? ( media-libs/alsa-lib )
+ arts? ( kde-base/arts )"
+
+src_compile() {
+ local myconf=""
+
+ use arts || myconf="$myconf --without-arts"
+ use alsa || myconf="$myconf --without-alsa"
+ use oss || myconf="$myconf --without-oss"
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ $myconf || die "./configure failed"
+ make || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS ChangeLog COPYING INSTALL NEWS README THANKS TODO Version
+}