summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2001-11-14 16:39:12 +0000
committerMikael Hallendal <hallski@gentoo.org>2001-11-14 16:39:12 +0000
commitca414230e367126ee85cb1c6e8c52a8bbe909640 (patch)
treec74691325fa17ba66e37e342f1732ec007c5fda3 /media-libs/tiff
parentUpdated version of mpg321. Prompted by out-of-place man-pages, bogus (diff)
downloadhistorical-ca414230e367126ee85cb1c6e8c52a8bbe909640.tar.gz
historical-ca414230e367126ee85cb1c6e8c52a8bbe909640.tar.bz2
historical-ca414230e367126ee85cb1c6e8c52a8bbe909640.zip
A=-fix, space->tab, fixed a problem causing it not to install when having agriffins patch to portage applied, this due to the fact that this package had it's own install.sh script with other flags
Diffstat (limited to 'media-libs/tiff')
-rw-r--r--media-libs/tiff/files/digest-tiff-3.5.6_beta-r11
-rw-r--r--media-libs/tiff/tiff-3.5.6_beta-r1.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/media-libs/tiff/files/digest-tiff-3.5.6_beta-r1 b/media-libs/tiff/files/digest-tiff-3.5.6_beta-r1
new file mode 100644
index 000000000000..55ff8f592304
--- /dev/null
+++ b/media-libs/tiff/files/digest-tiff-3.5.6_beta-r1
@@ -0,0 +1 @@
+MD5 aa74b76536f4b2d540857680877b34e0 tiff-v3.5.6-beta.tar.gz 913408
diff --git a/media-libs/tiff/tiff-3.5.6_beta-r1.ebuild b/media-libs/tiff/tiff-3.5.6_beta-r1.ebuild
new file mode 100644
index 000000000000..91418f564c42
--- /dev/null
+++ b/media-libs/tiff/tiff-3.5.6_beta-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-libs/tiff/tiff-3.5.6_beta-r1.ebuild,v 1.1 2001/11/14 16:39:12 hallski Exp $
+
+P=${PN}-v3.5.6-beta
+S=${WORKDIR}/${P}
+DESCRIPTION="libtiff"
+SRC_URI="http://www.libtiff.org/${P}.tar.gz"
+HOMEPAGE="http://www.libtiff.org/"
+
+DEPEND=">=media-libs/jpeg-6b >=sys-libs/zlib-1.1.3-r2"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ cp ${FILESDIR}/config.site-${PV} config.site
+ echo "DIR_HTML="${D}/usr/share/doc/${PF}/html"" >> config.site
+}
+
+src_compile() {
+ ./configure --noninteractive || die
+
+ emake OPTIMIZER="${CFLAGS}" || die
+}
+
+src_install() {
+ dodir /usr/{bin,lib,share/man,share/doc/${PF}/html}
+ dodir /usr/share/doc/${PF}/html
+ make INSTALL="/bin/sh ${S}/port/install.sh" install || die
+ prepalldocs
+
+ preplib /usr
+ dodoc COPYRIGHT README TODO VERSION
+}