summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Gavin <pete@gentoo.org>2001-05-22 01:27:07 +0000
committerPeter Gavin <pete@gentoo.org>2001-05-22 01:27:07 +0000
commitbf74e889e2d6ac7620e9869db22dcfb904a3429b (patch)
tree6591e90235cb88b2adbe588abc151185719be1c3 /media-libs/sdl-mixer
parentAdded the --autoclean parameter (diff)
downloadhistorical-bf74e889e2d6ac7620e9869db22dcfb904a3429b.tar.gz
historical-bf74e889e2d6ac7620e9869db22dcfb904a3429b.tar.bz2
historical-bf74e889e2d6ac7620e9869db22dcfb904a3429b.zip
added media-libs/libsdl-1.2.0, media-libs/sdl-mixer-1.2.0, media-libs/sdl-net-1.2.0
Diffstat (limited to 'media-libs/sdl-mixer')
-rw-r--r--media-libs/sdl-mixer/files/digest-sdl-mixer-1.2.01
-rw-r--r--media-libs/sdl-mixer/sdl-mixer-1.2.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/media-libs/sdl-mixer/files/digest-sdl-mixer-1.2.0 b/media-libs/sdl-mixer/files/digest-sdl-mixer-1.2.0
new file mode 100644
index 000000000000..f84d9bb7b552
--- /dev/null
+++ b/media-libs/sdl-mixer/files/digest-sdl-mixer-1.2.0
@@ -0,0 +1 @@
+MD5 3348f6b971b9acf54dbc74d5c57abc63 SDL_mixer-1.2.0.tar.gz
diff --git a/media-libs/sdl-mixer/sdl-mixer-1.2.0.ebuild b/media-libs/sdl-mixer/sdl-mixer-1.2.0.ebuild
new file mode 100644
index 000000000000..fd3339d84595
--- /dev/null
+++ b/media-libs/sdl-mixer/sdl-mixer-1.2.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-mixer/sdl-mixer-1.2.0.ebuild,v 1.1 2001/05/22 01:27:07 pete Exp $
+
+A=SDL_mixer-${PV}.tar.gz
+S=${WORKDIR}/SDL_mixer-${PV}
+DESCRIPTION="Simple Direct Media Layer Network Support Library"
+SRC_URI="http://www.libsdl.org/projects/SDL_mixer/release/${A}"
+HOMEPAGE="http://www.libsdl.org/projects/SDL_mixer/index.html"
+
+DEPEND="virtual/glibc
+ >=media-libs/libsdl-1.2.0
+ >=media-libs/smpeg-0.4.3
+ >=media-libs/libvorbis-1.0_beta4
+ >=media-sound/timidity++-2.10.4"
+
+src_compile() {
+ try ./configure --host=${CHOST} --prefix=/usr --mandir=/usr/share/man
+ try make
+}
+
+src_install() {
+ cd ${S}
+ try make DESTDIR=${D} install
+ preplib /usr
+ dodoc CHANGES COPYING README
+}
+
+pkg_postinst() {
+ ldconfig -r ${ROOT}
+}
+
+
+