summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-08-12 00:36:08 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-08-12 00:36:08 +0000
commit21ff782a6eb3b9d4350ecbf91b8ec4254f2632fc (patch)
tree93279fe1a0a50879231160e44d56e136aee6c1cf /media-libs/sdl-image/sdl-image-1.2.3-r1.ebuild
parentgnuconfig_update in src_unpack (diff)
downloadhistorical-21ff782a6eb3b9d4350ecbf91b8ec4254f2632fc.tar.gz
historical-21ff782a6eb3b9d4350ecbf91b8ec4254f2632fc.tar.bz2
historical-21ff782a6eb3b9d4350ecbf91b8ec4254f2632fc.zip
always gnuconfig_update; tidy
Diffstat (limited to 'media-libs/sdl-image/sdl-image-1.2.3-r1.ebuild')
-rw-r--r--media-libs/sdl-image/sdl-image-1.2.3-r1.ebuild23
1 files changed, 11 insertions, 12 deletions
diff --git a/media-libs/sdl-image/sdl-image-1.2.3-r1.ebuild b/media-libs/sdl-image/sdl-image-1.2.3-r1.ebuild
index cf49df61e835..8b7447aa9003 100644
--- a/media-libs/sdl-image/sdl-image-1.2.3-r1.ebuild
+++ b/media-libs/sdl-image/sdl-image-1.2.3-r1.ebuild
@@ -1,10 +1,9 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-image/sdl-image-1.2.3-r1.ebuild,v 1.3 2004/08/09 03:30:20 tgall Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-image/sdl-image-1.2.3-r1.ebuild,v 1.4 2004/08/12 00:36:08 mr_bones_ Exp $
inherit gnuconfig
-IUSE="gif jpeg tiff png"
MY_P="${P/sdl-/SDL_}"
S=${WORKDIR}/${MY_P}
@@ -12,9 +11,10 @@ DESCRIPTION="image file loading library"
HOMEPAGE="http://www.libsdl.org/projects/SDL_image/index.html"
SRC_URI="http://www.libsdl.org/projects/SDL_image/release/${MY_P}.tar.gz"
-SLOT="0"
LICENSE="LGPL-2"
+SLOT="0"
KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~mips ~amd64 ppc64"
+IUSE="gif jpeg tiff png"
DEPEND="sys-libs/zlib
>=media-libs/libsdl-1.2.4
@@ -25,16 +25,17 @@ DEPEND="sys-libs/zlib
src_unpack() {
unpack ${A}
- use ppc64 && gnuconfig_update
+ cd ${S}
+ gnuconfig_update
}
src_compile() {
econf \
- `use_enable gif` \
- `use_enable jpeg jpg` \
- `use_enable tiff tif` \
- `use_enable png` \
- `use_enable png pnm` \
+ $(use_enable gif) \
+ $(use_enable jpeg jpg) \
+ $(use_enable tiff tif) \
+ $(use_enable png) \
+ $(use_enable png pnm) \
--enable-bmp \
--enable-lbm \
--enable-pcx \
@@ -42,13 +43,11 @@ src_compile() {
--enable-xcf \
--enable-xpm \
|| die
-
emake || die
}
src_install() {
- make DESTDIR=${D} install || die "make install failed"
-
+ make DESTDIR="${D}" install || die "make install failed"
into /usr
dobin .libs/showimage
dodoc CHANGES README