summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2002-02-10 22:06:36 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2002-02-10 22:06:36 +0000
commit1b548d83a7889c443b693c89794597516177f899 (patch)
treeba447df20dcdc035c2eec31d3c1d7029c1744483 /media-libs/qhull/qhull-3.1.ebuild
parenta few little tweaks that don't affect functionality (diff)
downloadhistorical-1b548d83a7889c443b693c89794597516177f899.tar.gz
historical-1b548d83a7889c443b693c89794597516177f899.tar.bz2
historical-1b548d83a7889c443b693c89794597516177f899.zip
qhull - library for computing properties of geometric hulls
Diffstat (limited to 'media-libs/qhull/qhull-3.1.ebuild')
-rw-r--r--media-libs/qhull/qhull-3.1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/media-libs/qhull/qhull-3.1.ebuild b/media-libs/qhull/qhull-3.1.ebuild
new file mode 100644
index 000000000000..c7634c4fed27
--- /dev/null
+++ b/media-libs/qhull/qhull-3.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Tools Team <tools@gentoo.org>
+# Author: Karl Trygve Kalleberg <karltk@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-libs/qhull/qhull-3.1.ebuild,v 1.1 2002/02/10 22:06:36 karltk Exp $
+
+S=${WORKDIR}/qhull3.1
+DESCRIPTION="Geometry library"
+SRC_URI="http://www.geom.umn.edu/software/qhull/qhull3.1.tgz"
+HOMEPAGE="http://www.geom.umn.edu/software/qhull/"
+
+DEPEND=""
+#RDEPEND=""
+
+src_compile() {
+ cd src
+ make -f Makefile.txt
+
+}
+
+src_install () {
+
+ cd src
+
+ dolib libqhull.a
+ dobin qconvex
+ dobin qdelaunay
+ dobin qhalf
+ dobin qhull
+ dobin qvoronoi
+ dobin rbox
+
+ dodir /usr/include/qhull
+ insinto /usr/include/qhull
+ doins *.h
+
+ cd ${S}
+ dodoc Announce.txt COPYING.txt File_id.diz README.txt REGISTER.txt
+
+ cd html
+
+ rename .htm .html *.htm
+ rename .man .1 *.man
+
+ dohtml -a html,gif *
+
+ doman *.1
+}