summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-05-19 03:16:49 +0000
committerMike Frysinger <vapier@gentoo.org>2005-05-19 03:16:49 +0000
commitcd6b2e053ad49e1683e5e90c97ee4406481df532 (patch)
tree2bc58028ad4929d204462410b2a4fc2f100cd817 /media-libs/libsdl
parentdont run if no devices exist (diff)
downloadhistorical-cd6b2e053ad49e1683e5e90c97ee4406481df532.tar.gz
historical-cd6b2e053ad49e1683e5e90c97ee4406481df532.tar.bz2
historical-cd6b2e053ad49e1683e5e90c97ee4406481df532.zip
hide asm behind PIC for textrels #90382
Diffstat (limited to 'media-libs/libsdl')
-rw-r--r--media-libs/libsdl/Manifest2
-rw-r--r--media-libs/libsdl/libsdl-1.2.8-r1.ebuild6
2 files changed, 4 insertions, 4 deletions
diff --git a/media-libs/libsdl/Manifest b/media-libs/libsdl/Manifest
index 72067588f79a..6355e6e15c3d 100644
--- a/media-libs/libsdl/Manifest
+++ b/media-libs/libsdl/Manifest
@@ -2,7 +2,7 @@ MD5 3b4836a77e8f6df045028f84e89dd9b8 ChangeLog 12012
MD5 cbbab78f5125f834ffb0f83be4957736 libsdl-1.2.6-r3.ebuild 3013
MD5 7f079469132865bdd25780277639f098 libsdl-1.2.7-r3.ebuild 3960
MD5 baaaa69f33ef9027dac84ee4ff02773b metadata.xml 974
-MD5 08bd1fa826e6443229bd2f4d682344d7 libsdl-1.2.8-r1.ebuild 4646
+MD5 3bb259dc61e516198e60f60f2fe2ace7 libsdl-1.2.8-r1.ebuild 4678
MD5 0c2020ec3ce37ea0612064c52d1014b1 files/1.2.6-alsa-1.0.0.patch 557
MD5 60ecfde6cc7b734ef03b93357c537674 files/1.2.8-keyrepeat.patch 598
MD5 803844293dc7df2bb7d2323c03977b71 files/1.2.7-libcaca.patch 23266
diff --git a/media-libs/libsdl/libsdl-1.2.8-r1.ebuild b/media-libs/libsdl/libsdl-1.2.8-r1.ebuild
index 8e19b834eea1..653d5d61e2f3 100644
--- a/media-libs/libsdl/libsdl-1.2.8-r1.ebuild
+++ b/media-libs/libsdl/libsdl-1.2.8-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.8-r1.ebuild,v 1.11 2005/05/15 18:22:07 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.8-r1.ebuild,v 1.12 2005/05/19 03:16:49 vapier Exp $
inherit flag-o-matic toolchain-funcs eutils gnuconfig
@@ -11,7 +11,7 @@ SRC_URI="http://www.libsdl.org/release/SDL-${PV}.tar.gz"
LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 arm hppa ia64 ~mips ~ppc ~ppc64 ~ppc-macos sparc x86"
-IUSE="oss alsa esd arts nas X dga xv xinerama fbcon directfb ggi svga aalib opengl libcaca noaudio novideo nojoystick"
+IUSE="oss alsa esd arts nas X dga xv xinerama fbcon directfb ggi svga aalib opengl libcaca pic noaudio novideo nojoystick"
# if you disable audio/video/joystick and something breaks, you pick up the pieces
RDEPEND=">=media-libs/audiofile-0.1.9
@@ -80,6 +80,7 @@ src_compile() {
fi
if use x86 ; then
filter-flags -fforce-addr #87077
+ use pic || myconf="${myconf} $(use_enable x86 nasm)"
fi
use noaudio && myconf="${myconf} --disable-audio"
use novideo \
@@ -122,7 +123,6 @@ src_compile() {
$(use_enable esd) \
$(use_enable arts) \
$(use_enable nas) \
- $(use_enable x86 nasm) \
$(use_enable X video-x11) \
$(use_enable dga) \
$(use_enable xv video-x11-xv) \