summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-01-17 21:41:27 +0000
committerAchim Gottinger <achim@gentoo.org>2001-01-17 21:41:27 +0000
commit88e33d6bf5aca27ab7940134c4eb9c8778cf9f6d (patch)
tree85f098bdb719001505e9f69aad70cd2d54da7f3e /media-libs/libsdl
parent*** empty log message *** (diff)
downloadhistorical-88e33d6bf5aca27ab7940134c4eb9c8778cf9f6d.tar.gz
historical-88e33d6bf5aca27ab7940134c4eb9c8778cf9f6d.tar.bz2
historical-88e33d6bf5aca27ab7940134c4eb9c8778cf9f6d.zip
*** empty log message ***
Diffstat (limited to 'media-libs/libsdl')
-rw-r--r--media-libs/libsdl/files/digest-libsdl-1.1.71
-rw-r--r--media-libs/libsdl/libsdl-1.1.7.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/media-libs/libsdl/files/digest-libsdl-1.1.7 b/media-libs/libsdl/files/digest-libsdl-1.1.7
new file mode 100644
index 000000000000..ec15a935a707
--- /dev/null
+++ b/media-libs/libsdl/files/digest-libsdl-1.1.7
@@ -0,0 +1 @@
+MD5 fc2042c4578d24d5a68424d206229fa8 SDL-1.1.7.tar.gz
diff --git a/media-libs/libsdl/libsdl-1.1.7.ebuild b/media-libs/libsdl/libsdl-1.1.7.ebuild
new file mode 100644
index 000000000000..f160f0eef3cc
--- /dev/null
+++ b/media-libs/libsdl/libsdl-1.1.7.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.1.7.ebuild,v 1.1 2001/01/17 21:41:27 achim Exp $
+
+A=SDL-${PV}.tar.gz
+S=${WORKDIR}/SDL-${PV}
+DESCRIPTION="Simple Direct Media Layer"
+SRC_URI="http://www.libsdl.org/release/"${A}
+HOMEPAGE="http://www.libsdl.org/"
+
+DEPEND=">=sys-apps/bash-2.04
+ >=sys-libs/glibc-2.1.3
+ >=dev-lang/nasm-0.98
+ >=media-libs/alsa-lib-0.5.9
+ >=media-libs/audiofile-0.1.9
+ >=media-sound/esound-0.2.19
+ >=x11-base/xfree-4.0.1"
+
+src_unpack() {
+ unpack ${A}
+}
+
+src_compile() {
+ cd ${S}
+ try ./configure --host=${CHOST} --prefix=/usr
+ try make
+}
+
+src_install() {
+ cd ${S}
+ try make DESTDIR=${D} install
+ preplib /usr
+ dodoc BUGS COPYING CREDITS README* TODO WhatsNew
+ docinto html
+ dodoc *.html
+ docinto html/docs
+ dodoc docs/*.html
+
+}
+pkg_postinst() {
+
+ ldconfig -r ${ROOT}
+
+}
+
+
+