summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris White <chriswhite@gentoo.org>2004-08-19 22:46:18 +0000
committerChris White <chriswhite@gentoo.org>2004-08-19 22:46:18 +0000
commit7a14e55674714bd0163f265eabe9a9590971b68d (patch)
tree0db7440ef324b00c0e18e9bab6c3348a0e10d4d6 /media-libs/libdsp
parentdep fix & longdescr (diff)
downloadhistorical-7a14e55674714bd0163f265eabe9a9590971b68d.tar.gz
historical-7a14e55674714bd0163f265eabe9a9590971b68d.tar.bz2
historical-7a14e55674714bd0163f265eabe9a9590971b68d.zip
Moved from media-sound/libdsp to media-libs/libdsp.
Diffstat (limited to 'media-libs/libdsp')
-rw-r--r--media-libs/libdsp/ChangeLog20
-rw-r--r--media-libs/libdsp/Manifest5
-rw-r--r--media-libs/libdsp/files/Makefile.patch53
-rw-r--r--media-libs/libdsp/files/digest-libdsp-4.9.22
-rw-r--r--media-libs/libdsp/libdsp-4.9.2.ebuild61
-rw-r--r--media-libs/libdsp/metadata.xml8
6 files changed, 149 insertions, 0 deletions
diff --git a/media-libs/libdsp/ChangeLog b/media-libs/libdsp/ChangeLog
new file mode 100644
index 000000000000..c0d8e2896d86
--- /dev/null
+++ b/media-libs/libdsp/ChangeLog
@@ -0,0 +1,20 @@
+# ChangeLog for media-sound/libdsp
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libdsp/ChangeLog,v 1.1 2004/08/19 22:46:18 chriswhite Exp $
+
+*libdsp-4.9.2 (20 Aug 2004)
+
+ 20 Aug 2004; Chris White <chriswhite@gentoo.org> +metadata.xml,
+ +files/Makefile.patch, +libdsp-4.9.2.ebuild:
+ Moved from media-sound/libdsp to media-libs/libdsp.
+
+ 29 Jul 2004; Chris White <chriswhite@gentoo.org> libdsp-4.9.2.ebuild:
+ Somehow the DEPEND got deleted, added it back.
+
+*libdsp-4.9.2 (29 Jul 2004)
+
+ 29 Jul 2004; Chris White <chriswhite@gentoo.org> +metadata.xml,
+ +files/Makefile.patch, +libdsp-4.9.2.ebuild:
+ Initial commit. Thanks to Ed Wildgoose <gentoo@wildgooses.com> for the bug
+ report (Bug #58587). Added myself as maintainer.
+
diff --git a/media-libs/libdsp/Manifest b/media-libs/libdsp/Manifest
new file mode 100644
index 000000000000..576a98937be4
--- /dev/null
+++ b/media-libs/libdsp/Manifest
@@ -0,0 +1,5 @@
+MD5 d2596bad63ed83f18cb6aeb41fbd72b0 libdsp-4.9.2.ebuild 1527
+MD5 dbafe0153b3ee5f599d5dbeac4aa3210 metadata.xml 224
+MD5 d4e42cb20550df460c5211c6a2ef7257 ChangeLog 606
+MD5 0f21eaa6e644359d7a33dad21b8f330d files/Makefile.patch 2012
+MD5 7026d7f1b8c75423ecfad3ceaf859760 files/digest-libdsp-4.9.2 136
diff --git a/media-libs/libdsp/files/Makefile.patch b/media-libs/libdsp/files/Makefile.patch
new file mode 100644
index 000000000000..b4a69d176b60
--- /dev/null
+++ b/media-libs/libdsp/files/Makefile.patch
@@ -0,0 +1,53 @@
+--- libDSP/Makefile.old 2004-07-29 14:11:11.843296616 +0900
++++ libDSP/Makefile 2004-07-29 14:50:34.059185216 +0900
+@@ -29,14 +29,9 @@
+ #CFLAGS = -march=athlon-tbird -mcpu=athlon-xp -m3dnow # -msse -mfpmath=sse
+ #CFLAGS = -march=pentium3 -mcpu=pentium3 -msse -mfpmath=sse
+ #CFLAGS = -march=pentium4 -mcpu=pentium4 -msse2 -mfpmath=sse -m128bit-long-double
+-CFLAGS += -O3 -ffast-math -funroll-loops -fprefetch-loop-arrays -Wall -Werror #-g
+-CFLAGS += -ftracer
+-OPTCFLAGS = -march=pentium2 -mcpu=pentium4 -mmmx
+ #OPTCFLAGS = -march=athlon-tbird -mcpu=athlon-xp -m3dnow
+ #OPTCFLAGS = -march=pentium3 -mcpu=pentium3 -msse
+ #OPTCFLAGS = -march=pentium4 -mcpu=pentium4 -msse2 -m128bit-long-double
+-OPTCFLAGS += -O3 -ffast-math -funroll-loops -fprefetch-loop-arrays -Wall -Werror #-g
+-OPTCFLAGS += -ftracer
+ CXXFLAGS = $(CFLAGS)
+
+ # thread safety
+@@ -52,7 +47,7 @@
+ # define for Intel Integrated Performance Primitives support
+ #DEFS += -DDSP_IPP
+
+-INCS = -I. #-I/usr/local/include
++INCS = -I. -I../Inlines #-I/usr/local/include
+ #INCS += `pkg-config --cflags fftw3f fftw3`
+ #INCS += -I/opt/intel/ipp/include
+
+@@ -154,7 +149,7 @@
+ $(LIBTOOL) --mode=compile $(CXX) $(CXXFLAGS) $(DEFS) $(INCS) -c $<
+
+ X86.$(OBJ): X86.$(CSRC)
+- $(LIBTOOL) --mode=compile $(CC) $(OPTCFLAGS) $(DEFS) $(INCS) -c $<
++ $(LIBTOOL) --mode=compile $(CC) $(CFLAGS) $(DEFS) $(INCS) -c $<
+
+ libdsp.la: $(OBJS)
+ $(LIBTOOL) --mode=link $(CXX) $(LDFLAGS) -rpath $(TGPREFIX)/lib -version-info $(VERSION) -o libdsp.la $(LOBJS) $(LIBS)
+--- DynThreads/Makefile.old 2004-07-29 14:14:35.034406872 +0900
++++ DynThreads/Makefile 2004-07-29 14:51:14.760997600 +0900
+@@ -21,7 +21,7 @@
+ CXXFLAGS = -march=pentium2 -mcpu=athlon-xp -O2 -Wall -Werror #-ggdb
+ DEFS = -D_REENTRANT -D_THREAD_SAFE
+ #DEFS += -DUSE_NPTL
+-INCS = #-I/usr/local/include
++INCS = -I. -I../Inlines #-I/usr/local/include
+ LIBS = -lpthread
+
+ PREFIX = /usr/local
+@@ -57,6 +57,3 @@
+
+ DynThreads.dep: $(SRCS)
+ $(CXX) -MM $(DEFS) $(INCS) $(SRCS) >DynThreads.dep
+-
+-include DynThreads.dep
+-
diff --git a/media-libs/libdsp/files/digest-libdsp-4.9.2 b/media-libs/libdsp/files/digest-libdsp-4.9.2
new file mode 100644
index 000000000000..d341d2f15883
--- /dev/null
+++ b/media-libs/libdsp/files/digest-libdsp-4.9.2
@@ -0,0 +1,2 @@
+MD5 91ff67c7d4c25e73ab7166f0ebf873e6 libdsp-src-4.9.2.tar.gz 324883
+MD5 bd51911d22b7f67bf7c67277f73c6f5c libdsp-doc-html.tar.gz 1299174
diff --git a/media-libs/libdsp/libdsp-4.9.2.ebuild b/media-libs/libdsp/libdsp-4.9.2.ebuild
new file mode 100644
index 000000000000..de61544259cc
--- /dev/null
+++ b/media-libs/libdsp/libdsp-4.9.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libdsp/libdsp-4.9.2.ebuild,v 1.1 2004/08/19 22:46:18 chriswhite Exp $
+
+IUSE="doc"
+
+inherit eutils
+
+DESCRIPTION="C++ class library of common digital signal processing functions."
+HOMEPAGE="http://libdsp.sf.net"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-src-${PV}.tar.gz
+ doc? mirror://sourceforge/${PN}/${PN}-doc-html.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+DEPEND=""
+
+S=${WORKDIR}/${PN}-src-${PV}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+}
+
+src_compile() {
+ # fixes some Makefile weirdness
+ epatch ${FILESDIR}/Makefile.patch
+
+ # use our CFLAGS/CXXFLAGS instead
+ sed -e "s:^CFLAGS.*:CFLAGS = ${CFLAGS}:" -i libDSP/Makefile
+ sed -e "s:^CXXFLAGS.*:CXXFLAGS = ${CXXFLAGS}:" -i DynThreads/Makefile
+
+ # use our PREFIX too
+ sed -e "s:^PREFIX.*:PREFIX = ${D}/usr:" -i libDSP/Makefile
+ sed -e "s:^PREFIX.*:PREFIX = ${D}/usr:" -i DynThreads/Makefile
+
+ # libtool only supports the --tag option from v1.5 onwards
+ if ! has_version >= sys-devel/libtool-1.5.0; then
+ sed -e "s/^LIBTOOL = libtool --tag=CXX/LIBTOOL = libtool/" -i libDSP/Makefile
+ fi
+
+ cd ${S}/DynThreads
+ emake || die "DynThreads make failed!"
+
+ cd ${S}/libDSP
+ emake || die "libDSP make failed!"
+}
+
+src_install() {
+
+ cd ${S}/DynThreads
+ make install || die "DynThreads install failed!"
+
+ cd ${S}/libDSP
+ make install || die "libDSP install failed!"
+
+ if use doc; then
+ dohtml ${WORKDIR}/${PN}-doc-html/*
+ fi
+}
diff --git a/media-libs/libdsp/metadata.xml b/media-libs/libdsp/metadata.xml
new file mode 100644
index 000000000000..ec6a427b666f
--- /dev/null
+++ b/media-libs/libdsp/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sound</herd>
+<maintainer>
+ <email>chriswhite@gentoo.org</email>
+</maintainer>
+</pkgmetadata>