summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZaheer Abbas Merali <zaheerm@gentoo.org>2006-12-07 12:01:28 +0000
committerZaheer Abbas Merali <zaheerm@gentoo.org>2006-12-07 12:01:28 +0000
commitdcc258a6ae5e98bde17a1eef97153a710f53fed6 (patch)
tree1d5cc759288b3aea387221e38a1cf0811e6c8e83 /media-libs/gst-plugins-base/gst-plugins-base-0.10.11.ebuild
parentversion bump (diff)
downloadhistorical-dcc258a6ae5e98bde17a1eef97153a710f53fed6.tar.gz
historical-dcc258a6ae5e98bde17a1eef97153a710f53fed6.tar.bz2
historical-dcc258a6ae5e98bde17a1eef97153a710f53fed6.zip
version bump
Package-Manager: portage-2.1.1_pre3-r5
Diffstat (limited to 'media-libs/gst-plugins-base/gst-plugins-base-0.10.11.ebuild')
-rw-r--r--media-libs/gst-plugins-base/gst-plugins-base-0.10.11.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/media-libs/gst-plugins-base/gst-plugins-base-0.10.11.ebuild b/media-libs/gst-plugins-base/gst-plugins-base-0.10.11.ebuild
new file mode 100644
index 000000000000..e2d74bf1cf79
--- /dev/null
+++ b/media-libs/gst-plugins-base/gst-plugins-base-0.10.11.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-base/gst-plugins-base-0.10.11.ebuild,v 1.1 2006/12/07 12:01:28 zaheerm Exp $
+
+# order is important, gnome2 after gst-plugins
+inherit gst-plugins-base gst-plugins10 gnome2 eutils flag-o-matic libtool
+
+DESCRIPTION="Basepack of plugins for gstreamer"
+HOMEPAGE="http://gstreamer.net/"
+SRC_URI="http://gstreamer.freedesktop.org/src/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~x86"
+IUSE="alsa esd oss X xv"
+
+RDEPEND=">=dev-libs/glib-2.8
+ >=media-libs/gstreamer-0.10.10
+ >=dev-libs/liboil-0.3.8"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/gettext-0.11.5
+ >=dev-util/pkgconfig-0.9"
+
+PDEPEND="oss? ( >=media-plugins/gst-plugins-oss-0.10 )
+ alsa? ( >=media-plugins/gst-plugins-alsa-0.10 )
+ esd? ( >=media-plugins/gst-plugins-esd-0.10 )
+ X? ( >=media-plugins/gst-plugins-x-0.10 )
+ xv? ( >=media-plugins/gst-plugins-xvideo-0.10 )"
+
+src_compile() {
+
+ elibtoolize
+
+ # gst doesnt handle optimisations well
+ strip-flags
+ replace-flags "-O3" "-O2"
+ filter-flags "-fprefetch-loop-arrays" # see bug 22249
+ if use alpha || use amd64 || use ia64 || use hppa; then
+ append-flags -fPIC
+ fi
+
+ gst-plugins-base_src_configure
+
+ emake || die
+
+}
+
+# override eclass
+src_install() {
+
+ gnome2_src_install
+
+}
+
+DOCS="AUTHORS INSTALL README RELEASE TODO"