summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Crête <tester@gentoo.org>2009-03-30 04:41:56 +0000
committerOlivier Crête <tester@gentoo.org>2009-03-30 04:41:56 +0000
commit04e08770b008c90f9f96cb412348fb4e5bb27455 (patch)
treef8f10562226711a6ac9b443add35df5e0a9971be /media-libs/gst-plugins-bad
parentRemove +nls to make solar happy (but you really want nls) (diff)
downloadhistorical-04e08770b008c90f9f96cb412348fb4e5bb27455.tar.gz
historical-04e08770b008c90f9f96cb412348fb4e5bb27455.tar.bz2
historical-04e08770b008c90f9f96cb412348fb4e5bb27455.zip
Version bump
Package-Manager: portage-2.1.6.7/cvs/Linux i686
Diffstat (limited to 'media-libs/gst-plugins-bad')
-rw-r--r--media-libs/gst-plugins-bad/ChangeLog10
-rw-r--r--media-libs/gst-plugins-bad/gst-plugins-bad-0.10.11.ebuild44
2 files changed, 52 insertions, 2 deletions
diff --git a/media-libs/gst-plugins-bad/ChangeLog b/media-libs/gst-plugins-bad/ChangeLog
index 1722870f12ea..94ff2170dff5 100644
--- a/media-libs/gst-plugins-bad/ChangeLog
+++ b/media-libs/gst-plugins-bad/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/gst-plugins-bad
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-bad/ChangeLog,v 1.24 2008/12/26 12:48:38 ssuominen Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-bad/ChangeLog,v 1.25 2009/03/30 04:39:59 tester Exp $
+
+*gst-plugins-bad-0.10.11 (30 Mar 2009)
+
+ 30 Mar 2009; Olivier Crête <tester@gentoo.org>
+ +gst-plugins-bad-0.10.11.ebuild:
+ Version bump
*gst-plugins-bad-0.10.9-r1 (26 Dec 2008)
diff --git a/media-libs/gst-plugins-bad/gst-plugins-bad-0.10.11.ebuild b/media-libs/gst-plugins-bad/gst-plugins-bad-0.10.11.ebuild
new file mode 100644
index 000000000000..845ef6228d44
--- /dev/null
+++ b/media-libs/gst-plugins-bad/gst-plugins-bad-0.10.11.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-bad/gst-plugins-bad-0.10.11.ebuild,v 1.1 2009/03/30 04:39:59 tester Exp $
+
+inherit gst-plugins-bad gnome2 eutils flag-o-matic libtool
+
+DESCRIPTION="Less plugins for GStreamer"
+HOMEPAGE="http://gstreamer.freedesktop.org/"
+SRC_URI="http://gstreamer.freedesktop.org/src/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=media-libs/gst-plugins-base-0.10.22
+ >=media-libs/gstreamer-0.10.22
+ !<media-plugins/gst-plugins-farsight-0.12.11"
+
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ strip-flags
+ replace-flags "-O3" "-O2"
+ filter-flags "-fprefetch-loop-arrays" # (Bug #22249)
+
+ gst-plugins-bad_src_configure
+
+ emake || die "emake failed."
+}
+
+src_install() {
+ gnome2_src_install
+}
+
+DOCS="AUTHORS ChangeLog NEWS README RELEASE"
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+}