summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2005-10-25 18:19:58 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2005-10-25 18:19:58 +0000
commit423ec9082310fedba2e0ed32f872973ad873fb3d (patch)
tree94748870685035ec222c3435db3d1d2b8cfb3dc2 /media-libs/alut/alut-20051024.ebuild
parentAdded src_test to fix broken upstream behavior and cleaning up ebuild. (diff)
downloadhistorical-423ec9082310fedba2e0ed32f872973ad873fb3d.tar.gz
historical-423ec9082310fedba2e0ed32f872973ad873fb3d.tar.bz2
historical-423ec9082310fedba2e0ed32f872973ad873fb3d.zip
Initial import of alut, which has been split from openal. Because of this, I'm keeping the latest openal KEYWORDS, which is all ~arch on supported architectures.
Package-Manager: portage-2.0.53_rc6
Diffstat (limited to 'media-libs/alut/alut-20051024.ebuild')
-rw-r--r--media-libs/alut/alut-20051024.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/media-libs/alut/alut-20051024.ebuild b/media-libs/alut/alut-20051024.ebuild
new file mode 100644
index 000000000000..b205061cf2e1
--- /dev/null
+++ b/media-libs/alut/alut-20051024.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/alut/alut-20051024.ebuild,v 1.1 2005/10/25 18:19:58 wolf31o2 Exp $
+
+inherit eutils gnuconfig
+
+IUSE=""
+DESCRIPTION="The OpenAL Utility Toolkit"
+SRC_URI="http://dev.gentoo.org/~wolf31o2/sources/openal/openal-${PV}.tar.bz2"
+HOMEPAGE="http://www.openal.org"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="~media-libs/openal-${PV}"
+
+DEPEND="sys-devel/autoconf
+ sys-devel/automake
+ sys-devel/libtool"
+
+S="${WORKDIR}/openal-${PV}/${PN}"
+
+#src_unpack() {
+# unpack "${A}"
+# cd "${S}"
+
+# use alsa && epatch ${FILESDIR}/${P}-alsa_dmix.patch
+
+# gnuconfig_update
+
+# export WANT_AUTOCONF=2.5
+# autoheader || die
+# autoconf || die
+#}
+
+src_compile() {
+ local myconf
+
+# use esd && myconf="${myconf} --enable-esd"
+# use sdl && myconf="${myconf} --enable-sdl"
+# use alsa && myconf="${myconf} --enable-alsa"
+# use arts && myconf="${myconf} --enable-arts"
+# use mpeg && myconf="${myconf} --enable-smpeg"
+# use vorbis && myconf="${myconf} --enable-vorbis"
+# use debug && myconf="${myconf} --enable-debug-maximus"
+ use debug && myconf="${myconf} --enable-debug"
+ ./autogen.sh
+
+ econf ${myconf} --libdir=/usr/$(get_libdir) || die
+ emake all || die
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+
+ dodoc AUTHORS ChangeLog NEWS README
+ dohtml doc/*
+}